aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-11-19 23:57:08 +0800
committerswills <swills@FreeBSD.org>2018-11-19 23:57:08 +0800
commit1a169f6a72605fdad38110c8079f94c82833cdf4 (patch)
tree8d3d2c40872fa7f4d249c096fa4b37062aa00d11 /x11
parent856f63cc00154c0f417e61e3d7bb218de9e1ebf8 (diff)
downloadfreebsd-ports-gnome-1a169f6a72605fdad38110c8079f94c82833cdf4.tar.gz
freebsd-ports-gnome-1a169f6a72605fdad38110c8079f94c82833cdf4.tar.zst
freebsd-ports-gnome-1a169f6a72605fdad38110c8079f94c82833cdf4.zip
devel/glib20: remove runtime dep on perl5
Since glib-mkenums was rewritten in python in glib 2.53.5, glib20 seems to no longer need perl5 at runtime. This makes perl5 a build dep only. Removing the run dep causes some other ports to fail, so add the build dep to those where needed. PR: 233138 Approved by: gnome (kwm, maintainer, older version of patch) Exp-run by: antoine
Diffstat (limited to 'x11')
-rw-r--r--x11/qt5-x11extras/Makefile3
-rw-r--r--x11/sakura/Makefile3
-rw-r--r--x11/xscreensaver-gnome-hacks/Makefile3
-rw-r--r--x11/xscreensaver-gnome/Makefile1
4 files changed, 6 insertions, 4 deletions
diff --git a/x11/qt5-x11extras/Makefile b/x11/qt5-x11extras/Makefile
index cc4e2d9665ab..0988117df050 100644
--- a/x11/qt5-x11extras/Makefile
+++ b/x11/qt5-x11extras/Makefile
@@ -9,7 +9,8 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt platform-specific features for X11-based systems
USE_QT= core gui
-USES= compiler:c++11-lang qmake qt-dist:5,x11extras
+USES= compiler:c++11-lang qmake qt-dist:5,x11extras perl5
+USE_PERL5= build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
.include <bsd.port.mk>
diff --git a/x11/sakura/Makefile b/x11/sakura/Makefile
index b825021bc90f..8d1d02b77538 100644
--- a/x11/sakura/Makefile
+++ b/x11/sakura/Makefile
@@ -20,7 +20,8 @@ OPTIONS_DEFINE= DOCS
USE_GNOME= cairo gdkpixbuf2 vte3
USE_XORG= x11
-USES= cmake pkgconfig gettext tar:bzip2
+USES= cmake pkgconfig gettext perl5 tar:bzip2
+USE_PERL5= build
LDFLAGS+= -lintl
post-patch:
diff --git a/x11/xscreensaver-gnome-hacks/Makefile b/x11/xscreensaver-gnome-hacks/Makefile
index fe3600eb590e..d2b05ab813bf 100644
--- a/x11/xscreensaver-gnome-hacks/Makefile
+++ b/x11/xscreensaver-gnome-hacks/Makefile
@@ -16,7 +16,8 @@ CONFLICTS= xscreensaver-[0-9]* xscreensaver-gnome-[0-9]*
OPTIONS_DEFINE= ALL_FORTUNES
ALL_FORTUNES_DESC= Enable support for all fortunes
-USES= shebangfix
+USES= perl5 shebangfix
+USE_PERL5= build
SHEBANG_FILES= ${SS_SCRIPTS:S,^,driver/,}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-nodriver
diff --git a/x11/xscreensaver-gnome/Makefile b/x11/xscreensaver-gnome/Makefile
index 118455a0c527..0dfe44d4a4c3 100644
--- a/x11/xscreensaver-gnome/Makefile
+++ b/x11/xscreensaver-gnome/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= libgle.so:graphics/gle
USE_XORG= x11 xpm
USE_GL= gl
-USE_PERL5= run
USE_GNOME= libglade2
USES+= dos2unix gettext gmake jpeg perl5 pathfix pkgconfig
GNU_CONFIGURE= yes