aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-01-03 13:30:39 +0800
committermarcus <marcus@FreeBSD.org>2003-01-03 13:30:39 +0800
commit1aaacb9e4f46e57c98dfde0493ed5563e8105406 (patch)
tree997d9601bdb53dc2dd4de8ee3823a99c0e339008 /x11
parent081c62c1dff3916f1d0540d8fe6ebb59491bbd3b (diff)
downloadfreebsd-ports-gnome-1aaacb9e4f46e57c98dfde0493ed5563e8105406.tar.gz
freebsd-ports-gnome-1aaacb9e4f46e57c98dfde0493ed5563e8105406.tar.zst
freebsd-ports-gnome-1aaacb9e4f46e57c98dfde0493ed5563e8105406.zip
Apparently, gcc-3.2.1 on Alpha doesn't like our little libtool recipe when it
comes to gdm2. Change USE_LIBTOOL back to GNU_CONFIGURE, and remove the associated configure hack. This fixes an ld crash on Alpha, and doesn't seem to have any adverse effects on x86, either. Special thanks to Aaron Schroeder <Aaron.Schroeder@qg.com> for letting me use his Alpha workstation to track this down. The RELEASE_5_0_0 tag should be adjusted to take this change. Reported by: bento
Diffstat (limited to 'x11')
-rw-r--r--x11/gdm2/Makefile2
-rw-r--r--x11/gdm2/files/patch-configure8
2 files changed, 1 insertions, 9 deletions
diff --git a/x11/gdm2/Makefile b/x11/gdm2/Makefile
index 1ebd55524914..922e4f9401e1 100644
--- a/x11/gdm2/Makefile
+++ b/x11/gdm2/Makefile
@@ -23,7 +23,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack gnomehier
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/x11/gdm2/files/patch-configure b/x11/gdm2/files/patch-configure
index f0917807b6b8..c7e1c3d22e11 100644
--- a/x11/gdm2/files/patch-configure
+++ b/x11/gdm2/files/patch-configure
@@ -1,13 +1,5 @@
--- configure.orig Wed Jul 17 17:49:15 2002
+++ configure Wed Jul 17 17:51:03 2002
-@@ -7396,6 +7396,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -8531,6 +8532,8 @@
cat >conftest.$ac_ext <<_ACEOF
#line 8532 "configure"