aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-08-24 20:06:41 +0800
committersobomax <sobomax@FreeBSD.org>2000-08-24 20:06:41 +0800
commit1d063f264f3eb8e3a811da325f284942db7f4bdd (patch)
tree7d3a260076c5bfaf2c77989fc53fbefde89fe5d6 /x11
parent36312cff11d3a567187e5878f5fa96a6324fa070 (diff)
downloadfreebsd-ports-gnome-1d063f264f3eb8e3a811da325f284942db7f4bdd.tar.gz
freebsd-ports-gnome-1d063f264f3eb8e3a811da325f284942db7f4bdd.tar.zst
freebsd-ports-gnome-1d063f264f3eb8e3a811da325f284942db7f4bdd.zip
Add gnomeres_applet - a GNOME applet for changing XFree display modes.
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/gnomeres_applet/Makefile37
-rw-r--r--x11/gnomeres_applet/distinfo1
-rw-r--r--x11/gnomeres_applet/pkg-comment1
-rw-r--r--x11/gnomeres_applet/pkg-descr12
-rw-r--r--x11/gnomeres_applet/pkg-plist5
6 files changed, 57 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index aaae53390ea6..e8cff6aed304 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -29,6 +29,7 @@
SUBDIR += gnomeapplets
SUBDIR += gnomecore
SUBDIR += gnomelibs
+ SUBDIR += gnomeres_applet
SUBDIR += gswitchit_applet
SUBDIR += gtk-theme-switch
SUBDIR += gvid
diff --git a/x11/gnomeres_applet/Makefile b/x11/gnomeres_applet/Makefile
new file mode 100644
index 000000000000..82bdbd1cb950
--- /dev/null
+++ b/x11/gnomeres_applet/Makefile
@@ -0,0 +1,37 @@
+# Ports collection Makefile for: gnomeres_applet
+# Date created: 5 June 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomeres_applet
+PORTVERSION= 0.6.0
+CATEGORIES= x11 gnome
+MASTER_SITES= http://www.sci.fi/~syrjala/gnomeres/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/x11/gnomeres_applet/distinfo b/x11/gnomeres_applet/distinfo
new file mode 100644
index 000000000000..156a8c19c2db
--- /dev/null
+++ b/x11/gnomeres_applet/distinfo
@@ -0,0 +1 @@
+MD5 (gnomeres_applet-0.6.0.tar.gz) = b47c6122a1e88f3a8b936094321e6c6d
diff --git a/x11/gnomeres_applet/pkg-comment b/x11/gnomeres_applet/pkg-comment
new file mode 100644
index 000000000000..e2e7abefe3f0
--- /dev/null
+++ b/x11/gnomeres_applet/pkg-comment
@@ -0,0 +1 @@
+A GNOME applet for changing display modes
diff --git a/x11/gnomeres_applet/pkg-descr b/x11/gnomeres_applet/pkg-descr
new file mode 100644
index 000000000000..d238d8b58c4c
--- /dev/null
+++ b/x11/gnomeres_applet/pkg-descr
@@ -0,0 +1,12 @@
+GnomeRes - A GNOME applet for changing display modes.
+
+Features:
+---------
+ * A menu from which you can select the display mode.
+ * Info on modes presented as tooltips.
+ * An arrow ponting at the current mode in the menu.
+ * Mouse wheel support.
+ * Can lock mode switching.
+ * Startup display mode configuration.
+
+WWW: http://www.sci.fi/~syrjala/gnomeres/
diff --git a/x11/gnomeres_applet/pkg-plist b/x11/gnomeres_applet/pkg-plist
new file mode 100644
index 000000000000..6dfe9a6773f8
--- /dev/null
+++ b/x11/gnomeres_applet/pkg-plist
@@ -0,0 +1,5 @@
+bin/gnomeres_applet
+etc/CORBA/servers/gnomeres_applet.gnorba
+share/gnome/applets/Utility/gnomeres_applet.desktop
+share/gnome/pixmaps/gnomeres_applet.xpm
+share/locale/fr/LC_MESSAGES/gnomeres_applet.mo