aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-03-23 20:35:14 +0800
committermadpilot <madpilot@FreeBSD.org>2013-03-23 20:35:14 +0800
commit1d9cd81cf281cfb9a83dfa828e6b676822250643 (patch)
tree9267140809b991ce859079385d78b0c588de38e2 /x11
parent68ab481dc75fd686f368078f5e52defc8a7e4fd5 (diff)
downloadfreebsd-ports-gnome-1d9cd81cf281cfb9a83dfa828e6b676822250643.tar.gz
freebsd-ports-gnome-1d9cd81cf281cfb9a83dfa828e6b676822250643.tar.zst
freebsd-ports-gnome-1d9cd81cf281cfb9a83dfa828e6b676822250643.zip
- Add "Conversation failure" error code to authentication errors
list in order to permit login with special usernames. - Fix conssole command - Bump PORTREVISION PR: ports/174482 Submitted by: Maxim Samsonov <xors@mailup.net> Approved by: Henry Hu <henry.hu.sh@gmail.com> (maintainer)
Diffstat (limited to 'x11')
-rw-r--r--x11/slim/Makefile2
-rw-r--r--x11/slim/files/patch-PAM.cpp10
-rw-r--r--x11/slim/files/patch-slim.conf2
3 files changed, 12 insertions, 2 deletions
diff --git a/x11/slim/Makefile b/x11/slim/Makefile
index 1f0911f0fee4..ad784dfeaafe 100644
--- a/x11/slim/Makefile
+++ b/x11/slim/Makefile
@@ -3,7 +3,7 @@
PORTNAME= slim
PORTVERSION= 1.3.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= x11
MASTER_SITES= http://slim.berlios.de/releases/
diff --git a/x11/slim/files/patch-PAM.cpp b/x11/slim/files/patch-PAM.cpp
new file mode 100644
index 000000000000..2858eb657d88
--- /dev/null
+++ b/x11/slim/files/patch-PAM.cpp
@@ -0,0 +1,10 @@
+--- PAM.cpp.orig 2012-06-26 12:20:14.000000000 +0400
++++ PAM.cpp 2012-12-16 16:05:09.000000000 +0400
+@@ -128,6 +128,7 @@
+ case PAM_MAXTRIES:
+ case PAM_CRED_INSUFFICIENT:
+ case PAM_AUTH_ERR:
++ case PAM_CONV_ERR:
+ throw Auth_Exception(pam_handle, "pam_authentication()", last_result);
+
+ case PAM_SUCCESS:
diff --git a/x11/slim/files/patch-slim.conf b/x11/slim/files/patch-slim.conf
index 37bcfbcad939..dde0e1a149c4 100644
--- a/x11/slim/files/patch-slim.conf
+++ b/x11/slim/files/patch-slim.conf
@@ -18,7 +18,7 @@
reboot_cmd /sbin/shutdown -r now
-console_cmd /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
-#suspend_cmd /usr/sbin/suspend
-+console_cmd %%LOCALBASE%%/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/motd; exec /bin/login"
++console_cmd %%LOCALBASE%%/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/motd; exec /usr/bin/login"
+suspend_cmd /usr/sbin/acpiconf -s 3
# Full path to the xauth binary