aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2005-08-30 20:04:06 +0800
committerMichael Landin <mich@FreeBSD.org>2005-08-30 20:04:06 +0800
commit1f7b4336c1c05e6069469b0ea2f2ed2702c93990 (patch)
tree6c66ac352fb38e3c9292ca19f8dba6b27ea6619f /x11
parent231b6cfb3448a3724110b506ebb181cb94af5cfe (diff)
downloadfreebsd-ports-gnome-1f7b4336c1c05e6069469b0ea2f2ed2702c93990.tar.gz
freebsd-ports-gnome-1f7b4336c1c05e6069469b0ea2f2ed2702c93990.tar.zst
freebsd-ports-gnome-1f7b4336c1c05e6069469b0ea2f2ed2702c93990.zip
o add WITHOUT_BACKGROUND_IMAGE knob [1]
- so you can decide if you want another dep. or not o add without-afterstep-config to configure args [2] - workaround for x11-wm/afterstep-stable weirdness Submitted by: glewis[2], Paulius Bulotas <paulius@devnull.lt>[1]
Diffstat (limited to 'x11')
-rw-r--r--x11/aterm/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index 776969c616c7..fbfadbb377a6 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -14,18 +14,21 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mich@FreeBSD.org
COMMENT= A color vt102 terminal emulator with transparency support
-LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage
-
USE_X_PREFIX= yes
USE_XPM= yes
GNU_CONFIGURE= yes
# `+=' is for slave ports
-CONFIGURE_ARGS+= \
- --enable-transparency --enable-background-image \
- --enable-fading --enable-utmp --enable-wtmp
+CONFIGURE_ARGS+= --enable-transparency \
+ --enable-fading --enable-utmp --enable-wtmp \
+ --without-afterstep-config
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+.if !defined(WITHOUT_BACKGROUND_IMAGE)
+LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage
+CONFIGURE_ARGS+= --enable-background-image
+.endif
+
.if !defined(WITHOUT_PNG)
CONFIGURE_ARGS+= --with-png
LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png