aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2013-01-07 00:18:05 +0800
committerolivierd <olivierd@FreeBSD.org>2013-01-07 00:18:05 +0800
commit2bc3047feff4c6a3363bedc9ac2d3555104135cb (patch)
treea01688551dbc81b43a4b30c06cfdccd818ff7d7f /x11
parent95b70acdf0adf0fb61fd7da63dafac0724906710 (diff)
downloadfreebsd-ports-gnome-2bc3047feff4c6a3363bedc9ac2d3555104135cb.tar.gz
freebsd-ports-gnome-2bc3047feff4c6a3363bedc9ac2d3555104135cb.tar.zst
freebsd-ports-gnome-2bc3047feff4c6a3363bedc9ac2d3555104135cb.zip
- Project name has changed (Terminal to xfce4-terminal)
- Update to 0.6.1 Approved by: rene, miwi (mentors, implicit)
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile2
-rw-r--r--x11/xfce4-terminal/Makefile54
-rw-r--r--x11/xfce4-terminal/distinfo2
-rw-r--r--x11/xfce4-terminal/pkg-descr4
-rw-r--r--x11/xfce4-terminal/pkg-plist82
5 files changed, 143 insertions, 1 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 95e1b047bcfe..bdee60993e1c 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -6,7 +6,6 @@
SUBDIR += 3ddesktop
SUBDIR += 9box
SUBDIR += 9menu
- SUBDIR += Terminal
SUBDIR += alltray
SUBDIR += appres
SUBDIR += apwal
@@ -364,6 +363,7 @@
SUBDIR += xfce4-quicklauncher-plugin
SUBDIR += xfce4-screenshooter-plugin
SUBDIR += xfce4-taskmanager
+ SUBDIR += xfce4-terminal
SUBDIR += xfce4-verve-plugin
SUBDIR += xfce4-wmdock-plugin
SUBDIR += xfce4-xfapplet-plugin
diff --git a/x11/xfce4-terminal/Makefile b/x11/xfce4-terminal/Makefile
new file mode 100644
index 000000000000..21dbc448131a
--- /dev/null
+++ b/x11/xfce4-terminal/Makefile
@@ -0,0 +1,54 @@
+# Created by: Matt Lancereau
+# $FreeBSD$
+
+PORTNAME= xfce4-terminal
+PORTVERSION= 0.6.1
+CATEGORIES= x11 xfce
+MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
+DIST_SUBDIR= xfce4
+
+MAINTAINER= xfce@FreeBSD.org
+COMMENT= Terminal emulator for the X windowing system
+
+USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack gtk20 glib20 intltool intlhack vte \
+ libxml2 desktopfileutils
+USE_XFCE= configenv libmenu
+USE_XORG= x11
+USE_PKGCONFIG= build
+
+CONFIGURE_ARGS= --without-gnome-default-appsdir
+
+OPTIONS_DEFINE= NLS
+
+MAN1= xfce4-terminal.1
+MANLANG= "" ar ca da de el es fr gl id it ja ko lt \
+ pl pt pt_BR ru sv tr ug uk zh_CN
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+post-patch:
+# Downgrade VTE to 0.26
+ @${REINPLACE_CMD} -e 's|0.28|0.26|g' ${WRKSRC}/configure
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -e 's| terminal||; \
+ s|po \\|terminal|' ${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+ @-update-desktop-database
+
+.include <bsd.port.mk>
diff --git a/x11/xfce4-terminal/distinfo b/x11/xfce4-terminal/distinfo
new file mode 100644
index 000000000000..18e17185ddf8
--- /dev/null
+++ b/x11/xfce4-terminal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xfce4/xfce4-terminal-0.6.1.tar.bz2) = 61346427e55af79e86511572bfabb2e025cb13720879226ea1b98a92f0bcd4c8
+SIZE (xfce4/xfce4-terminal-0.6.1.tar.bz2) = 837279
diff --git a/x11/xfce4-terminal/pkg-descr b/x11/xfce4-terminal/pkg-descr
new file mode 100644
index 000000000000..8b18c8e5adb3
--- /dev/null
+++ b/x11/xfce4-terminal/pkg-descr
@@ -0,0 +1,4 @@
+This is the Terminal emulator application. Terminal is a lightweight and
+easy to use terminal emulator for the X windowing system.
+
+WWW: http://www.xfce.org/projects
diff --git a/x11/xfce4-terminal/pkg-plist b/x11/xfce4-terminal/pkg-plist
new file mode 100644
index 000000000000..2b6e4e541a95
--- /dev/null
+++ b/x11/xfce4-terminal/pkg-plist
@@ -0,0 +1,82 @@
+bin/xfce4-terminal
+share/applications/xfce4-terminal.desktop
+%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/be/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/et/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/he/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/id/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/is/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/lv/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/si/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/te/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-terminal.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-terminal.mo
+share/xfce4/terminal/colorschemes/black-on-white.theme
+share/xfce4/terminal/colorschemes/dark-pastels.theme
+share/xfce4/terminal/colorschemes/green-on-black.theme
+share/xfce4/terminal/colorschemes/solarized-dark.theme
+share/xfce4/terminal/colorschemes/tango.theme
+share/xfce4/terminal/colorschemes/white-on-black.theme
+share/xfce4/terminal/colorschemes/xterm.theme
+share/xfce4/terminal/terminal-preferences.ui
+@exec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
+@dirrm share/xfce4/terminal/colorschemes
+@dirrm share/xfce4/terminal
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK
+%%NLS%%@dirrmtry share/locale/ur/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur
+%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ug
+%%NLS%%@dirrmtry share/locale/te/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/te
+%%NLS%%@dirrmtry share/locale/si/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/si
+%%NLS%%@dirrmtry share/locale/kk/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/kk
+%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ast
+@dirrmtry man/zh_CN/man1
+@dirrmtry man/zh_CN
+@dirrmtry man/ug/man1
+@dirrmtry man/ug