aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authornobutaka <nobutaka@FreeBSD.org>2015-02-09 23:18:54 +0800
committernobutaka <nobutaka@FreeBSD.org>2015-02-09 23:18:54 +0800
commit3327d7da04c73f979037bffb5d8a6a593238b2cd (patch)
treefa4f04a24c815fbf34686fc2e962e3250648ff4b /x11
parent1777409fad8c93a69a06709505843cbd01a93185 (diff)
downloadfreebsd-ports-gnome-3327d7da04c73f979037bffb5d8a6a593238b2cd.tar.gz
freebsd-ports-gnome-3327d7da04c73f979037bffb5d8a6a593238b2cd.tar.zst
freebsd-ports-gnome-3327d7da04c73f979037bffb5d8a6a593238b2cd.zip
Add ReGIS graphics support.
PR: 192084 Submitted by: IWAMOTO Kouichi <sue@iwmt.org>
Diffstat (limited to 'x11')
-rw-r--r--x11/mlterm/Makefile18
-rw-r--r--x11/mlterm/pkg-plist1
2 files changed, 17 insertions, 2 deletions
diff --git a/x11/mlterm/Makefile b/x11/mlterm/Makefile
index 6027894b111a..992ec8d68c2e 100644
--- a/x11/mlterm/Makefile
+++ b/x11/mlterm/Makefile
@@ -3,6 +3,7 @@
PORTNAME= mlterm
PORTVERSION= 3.4.2
+PORTREVISION= 1
CATEGORIES= x11
MASTER_SITES= SF/${PORTNAME}/01release/${PORTNAME}-${PORTVERSION}
@@ -17,17 +18,18 @@ USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gui=x11 --with-imagelib=gdk-pixbuf2 --enable-utmp \
--enable-optimize-redrawing \
- --with-tools="mlclient,mlconfig,mlterm-menu,mlcc,w3mmlconfig,mlimgloader" \
--disable-iiimf
+EXTERNAL_TOOLS= mlclient,mlconfig,mlterm-menu,mlcc,w3mmlconfig,mlimgloader
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= CAIRO DOCS FRIBIDI IBUS M17NLIB SCIM SIXEL UIM
+OPTIONS_DEFINE= CAIRO DOCS FRIBIDI IBUS M17NLIB REGIS SCIM SIXEL UIM
CAIRO_DESC= Use Cairo for type engine (experimental)
FRIBIDI_DESC= Use Fribidi for BiDi rendering
IBUS_DESC= IBUS support (experimental)
M17NLIB_DESC= m17n library support (experimental)
+REGIS_DESC= ReGIS graphics support
SCIM_DESC= SCIM support (experimental)
SIXEL_DESC= Sixel graphics support
UIM_DESC= uim support (experimental)
@@ -96,6 +98,18 @@ CONFIGURE_ARGS+= --disable-sixel
PLIST_SUB+= SIXEL="@comment "
.endif
+.if ${PORT_OPTIONS:MREGIS}
+LIB_DEPENDS+= libSDL.so:${PORTSDIR}/devel/sdl12 \
+ libSDL_ttf.so:${PORTSDIR}/graphics/sdl_ttf \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
+EXTERNAL_TOOLS+=,registobmp
+PLIST_SUB+= REGIS=""
+.else
+PLIST_SUB+= REGIS="@comment "
+.endif
+
+CONFIGURE_ARGS+=--with-tools="${EXTERNAL_TOOLS}"
+
.if ${OSVERSION} < 900004
LIB_DEPENDS+= libutempter.so:${PORTSDIR}/sysutils/libutempter
.endif
diff --git a/x11/mlterm/pkg-plist b/x11/mlterm/pkg-plist
index 185943ff7d96..fa0f5ac0217c 100644
--- a/x11/mlterm/pkg-plist
+++ b/x11/mlterm/pkg-plist
@@ -67,6 +67,7 @@ lib/mlterm/libtype_xft.so
libexec/mlterm/mlconfig
libexec/mlterm/mlimgloader
libexec/mlterm/mlterm-menu
+%%REGIS%%libexec/mlterm/registobmp
libexec/w3mmlconfig/mlconfig-data.pl
libexec/w3mmlconfig/mlconfig.cgi
man/man1/mlclient.1.gz