aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-01-05 20:55:36 +0800
committerantoine <antoine@FreeBSD.org>2014-01-05 20:55:36 +0800
commit539b785b754c1ca66de09ad3b6c148c562f41ed7 (patch)
treef576d674ef9a10d1cab73840fba066674a038567 /x11
parentbb8a8837026b3b67fdd5df8c5967ad4098f97ee8 (diff)
downloadfreebsd-ports-gnome-539b785b754c1ca66de09ad3b6c148c562f41ed7.tar.gz
freebsd-ports-gnome-539b785b754c1ca66de09ad3b6c148c562f41ed7.tar.zst
freebsd-ports-gnome-539b785b754c1ca66de09ad3b6c148c562f41ed7.zip
- Stage support
- Add missing OPTIONS_DEFINE
Diffstat (limited to 'x11')
-rw-r--r--x11/swarp/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11/swarp/Makefile b/x11/swarp/Makefile
index 4ed0f9de8002..f8c8c9e1b916 100644
--- a/x11/swarp/Makefile
+++ b/x11/swarp/Makefile
@@ -22,7 +22,8 @@ MAKE_ARGS= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lX11" \
PORTDOCS= README
PLIST_FILES= bin/swarp
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
post-patch:
@@ -30,8 +31,8 @@ post-patch:
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>