aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortrevor <trevor@FreeBSD.org>2003-12-04 00:57:36 +0800
committertrevor <trevor@FreeBSD.org>2003-12-04 00:57:36 +0800
commit5a0d02d50c92fa4ebfdcb5a0291ebec3a71ab5d3 (patch)
tree30dce75e5b414006a57144d2f35081ec91309e43 /x11
parent648f28f052d6a842636c0b1c152ffb9da9358cab (diff)
downloadfreebsd-ports-gnome-5a0d02d50c92fa4ebfdcb5a0291ebec3a71ab5d3.tar.gz
freebsd-ports-gnome-5a0d02d50c92fa4ebfdcb5a0291ebec3a71ab5d3.tar.zst
freebsd-ports-gnome-5a0d02d50c92fa4ebfdcb5a0291ebec3a71ab5d3.zip
The linux-gtk port sets USE_LINUX_PREFIX which adds a dependency
on linux_base 7.1, but the latter port has its own XFree86 libraries which conflict with the ones from this port. The rpm2cpio (used in pre-install) and rpm (used in do-install) ports conflict with each other. Fix the dependencies by bringing in parts of the linux-gtk Makefile so this port can stand on its own, and by using the rpm2cpio that accompanies rpm. While I'm here, be less verbose, reorder some lines to please portlint, and slim the pre-install a little. Approved by: portmgr (marcus) for 5.2 freeze
Diffstat (limited to 'x11')
-rw-r--r--x11/linux-XFree86-libs/Makefile42
1 files changed, 25 insertions, 17 deletions
diff --git a/x11/linux-XFree86-libs/Makefile b/x11/linux-XFree86-libs/Makefile
index dd1bb422b109..f1e64d57095f 100644
--- a/x11/linux-XFree86-libs/Makefile
+++ b/x11/linux-XFree86-libs/Makefile
@@ -11,37 +11,45 @@ PORTREVISION= 1
CATEGORIES= x11 linux
MASTER_SITES= ${MASTER_SITE_REDHAT_LINUX}
MASTER_SITE_SUBDIR= updates/9/en/os/i386
+PKGNAMEPREFIX= linux-
+DISTNAME= XFree86-libs-4.3.0-2.90.43.i386.rpm
+EXTRACT_SUFX=
+DIST_SUBDIR= rpm
+EXTRACT_ONLY=
MAINTAINER= trevor@FreeBSD.org
COMMENT= XFree86 libraries, Linux/i386 binary
-CONFLICTS= linux_base-6* linux_base-7* linux_base-deb* linux_base-gentoo*
-BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
+BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
RUN_DEPENDS=${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
BASEVERSION= 9
+CONFLICTS= linux_base-6* linux_base-7* linux_base-deb* linux_base-gentoo*
+MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= i386
PLIST= ${WRKDIR}/plist
-RPM_SET= XFree86-libs-4.3.0-2.90.43.i386.rpm
+PREFIX= ${LINUXBASE}
pre-install:
- ${RM} -rf ${WRKSRC}/tmp
- ${MKDIR} ${WRKSRC}/tmp
- cd ${WRKSRC}/tmp; \
- rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -id; \
+ @${RM} -rf ${WRKSRC}/tmp
+ @${MKDIR} ${WRKSRC}/tmp
+ @cd ${WRKSRC}/tmp; \
+ rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} | cpio -id; \
${FIND} * -type f -o -type l > ${PLIST}
-.for ii in \
- usr/X11R6/lib/X11/locale/lib/common \
- usr/X11R6/lib/X11/locale/lib \
- usr/X11R6/lib/X11/locale \
- usr/X11R6/lib/X11
- ${ECHO_CMD} @dirrm ${ii} >> ${PLIST}
+.for ii in X11/locale/lib/common X11/locale/lib X11/locale X11
+ @${ECHO_CMD} @dirrm usr/X11R6/lib/${ii} >> ${PLIST}
.endfor
post-install:
- ${RM} -f ${LINUXBASE}/etc/ld.so.cache
- ${FIND} ${LINUXBASE} -name lib -type d | ${SED} 's:${LINUXBASE}::g' \
+ @${RM} -f ${LINUXBASE}/etc/ld.so.cache
+ @${FIND} ${LINUXBASE} -name lib -type d | ${SED} 's:${LINUXBASE}::g' \
> ${LINUXBASE}/etc/ld.so.conf
- chroot ${LINUXBASE} sbin/ldconfig
+ @chroot ${LINUXBASE} sbin/ldconfig
+
+do-install:
+ @rpm -U --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm --nodeps \
+ --replacepkgs ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} || ${TRUE}
-.include "../../x11-toolkits/linux-gtk/Makefile"
+.include <bsd.port.mk>