aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
committersobomax <sobomax@FreeBSD.org>2001-03-30 00:35:19 +0800
commit6e2b9def0c49c3e565a14f5987fd3e9f46d285c6 (patch)
treec23d8d7c62c20c0978b7a404b38eb7b9d5596d0f /x11
parentfaa774bb672904227e681f88c16cfceef448ef6c (diff)
downloadfreebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.gz
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.tar.zst
freebsd-ports-gnome-6e2b9def0c49c3e565a14f5987fd3e9f46d285c6.zip
-pthread --> ${PTHREAD_LIBS}
-D_THREAD_SAFE --> ${PTHREAD_CFLAGS} Note: my first intention was to test this out on bento/beta, but per ade's requiest I opted to do it quickly.
Diffstat (limited to 'x11')
-rw-r--r--x11/gdm/Makefile2
-rw-r--r--x11/gdm2/Makefile2
-rw-r--r--x11/gnome-applets/Makefile2
-rw-r--r--x11/gnome-libs/Makefile2
-rw-r--r--x11/gnomeapplets/Makefile2
-rw-r--r--x11/gnomeapplets2/Makefile2
-rw-r--r--x11/gnomecore/Makefile2
-rw-r--r--x11/gnomelibs/Makefile2
-rw-r--r--x11/gnomeres_applet/Makefile2
-rw-r--r--x11/libgnome/Makefile2
-rw-r--r--x11/xscreensaver/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index ca85544ccf0d..42a4d93e02e5 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -28,7 +28,7 @@ pre-fetch:
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/gdm2/Makefile b/x11/gdm2/Makefile
index ca85544ccf0d..42a4d93e02e5 100644
--- a/x11/gdm2/Makefile
+++ b/x11/gdm2/Makefile
@@ -28,7 +28,7 @@ pre-fetch:
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/gnome-applets/Makefile b/x11/gnome-applets/Makefile
index f96a4c3450dd..6cdc5a2ccfef 100644
--- a/x11/gnome-applets/Makefile
+++ b/x11/gnome-applets/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/gnome-libs/Makefile b/x11/gnome-libs/Makefile
index 62c2e6714418..d8b55194da78 100644
--- a/x11/gnome-libs/Makefile
+++ b/x11/gnome-libs/Makefile
@@ -35,7 +35,7 @@ MAN1= gnome.1 gnome-config.1
MAN5= gnome-mime.5
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/gnomeapplets/Makefile b/x11/gnomeapplets/Makefile
index f96a4c3450dd..6cdc5a2ccfef 100644
--- a/x11/gnomeapplets/Makefile
+++ b/x11/gnomeapplets/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/gnomeapplets2/Makefile b/x11/gnomeapplets2/Makefile
index f96a4c3450dd..6cdc5a2ccfef 100644
--- a/x11/gnomeapplets2/Makefile
+++ b/x11/gnomeapplets2/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/gnomecore/Makefile b/x11/gnomecore/Makefile
index d99dadc36adb..8a4837132e06 100644
--- a/x11/gnomecore/Makefile
+++ b/x11/gnomecore/Makefile
@@ -31,7 +31,7 @@ MAN1= gnome-session.1 gnome-wm.1 save-session.1
MAN5= default.session.5
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/gnomelibs/Makefile b/x11/gnomelibs/Makefile
index 62c2e6714418..d8b55194da78 100644
--- a/x11/gnomelibs/Makefile
+++ b/x11/gnomelibs/Makefile
@@ -35,7 +35,7 @@ MAN1= gnome.1 gnome-config.1
MAN5= gnome-mime.5
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/gnomeres_applet/Makefile b/x11/gnomeres_applet/Makefile
index 8239bd47e6a6..1cee4f296e10 100644
--- a/x11/gnomeres_applet/Makefile
+++ b/x11/gnomeres_applet/Makefile
@@ -19,7 +19,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 62c2e6714418..d8b55194da78 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -35,7 +35,7 @@ MAN1= gnome.1 gnome-config.1
MAN5= gnome-mime.5
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index 47d1391b6286..dd216ba8acc0 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -38,7 +38,7 @@ MAN1= attraction.1 blitspin.1 bouboule.1 braid.1 \
post-patch:
@ ${CP} ${WRKSRC}/configure ${WRKSRC}/configure.Patched
- @ ${SED} -e 's#-lpthread#-pthread#g' \
+ @ ${SED} -e 's#-lpthread#${PTHREAD_LIBS}#g' \
${WRKSRC}/configure.Patched > ${WRKSRC}/configure
.include <bsd.port.pre.mk>