aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-01-20 23:40:43 +0800
committernetchild <netchild@FreeBSD.org>2005-01-20 23:40:43 +0800
commit74d450a5468f965ba1bf575a962a7ae8dc4197d1 (patch)
tree4792fe7a277a529455663938ffe5908e504fe7a8 /x11
parentb26b992b2a2fba96418979152a3edbcb6d348c9d (diff)
downloadfreebsd-ports-gnome-74d450a5468f965ba1bf575a962a7ae8dc4197d1.tar.gz
freebsd-ports-gnome-74d450a5468f965ba1bf575a962a7ae8dc4197d1.tar.zst
freebsd-ports-gnome-74d450a5468f965ba1bf575a962a7ae8dc4197d1.zip
Minimal changes to let users update the linux base and the linux X11 bits
in any order: - add the X11 lib path to ld.so.conf in the linux base port - (re)generate the ld.so.cache file in the linux base port too - don't change the ld.so.conf in the linux X11 port At deinstall time the linux base port may still complain about a changed ld.so.cache file. A clean way to solve this would be to use ("@unexec" and "@exec") in the plist. Since the plist is autogenerated this would need some little magic in the plist generation or we have to switch to a static plist. Delay the decission about how to handle this until we know when/how to update to a more recent linux base port.
Diffstat (limited to 'x11')
-rw-r--r--x11/linux-XFree86-libs/Makefile2
-rw-r--r--x11/linux-XFree86-libs/files/pkg-install.in4
2 files changed, 1 insertions, 5 deletions
diff --git a/x11/linux-XFree86-libs/Makefile b/x11/linux-XFree86-libs/Makefile
index f9633844e267..27536f0db694 100644
--- a/x11/linux-XFree86-libs/Makefile
+++ b/x11/linux-XFree86-libs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= XFree86-libs
PORTVERSION= 4.3.99.902
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 linux
MASTER_SITES= ${MASTER_SITE_SUSE} \
ftp://ftp.in2p3.fr/pub/linux/suse/update/9.1/rpm/i586/ \
diff --git a/x11/linux-XFree86-libs/files/pkg-install.in b/x11/linux-XFree86-libs/files/pkg-install.in
index 1be02068a889..ad62ac87cbc9 100644
--- a/x11/linux-XFree86-libs/files/pkg-install.in
+++ b/x11/linux-XFree86-libs/files/pkg-install.in
@@ -4,9 +4,5 @@ PATH=/bin:/sbin:/usr/bin:/usr/sbin
export PATH
if [ "$2" = "POST-INSTALL" ]; then
- rm -f %%LINUXBASE%%/etc/ld.so.cache
- ( find %%LINUXBASE%% -name lib -type d | sed -e 's:%%LINUXBASE%%::g'; \
- find %%PREFIX%% -name lib -type d | sed -e 's:%%PREFIX%%::g' ) \
- | sort -u >%%LINUXBASE%%/etc/ld.so.conf
chroot %%LINUXBASE%% /sbin/ldconfig
fi