aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-03-26 03:14:43 +0800
committereadler <eadler@FreeBSD.org>2013-03-26 03:14:43 +0800
commit829086f391d67260ccc3007dc40423d9941b869e (patch)
treec71927c24616b647a0be8594203b80a737a11e2a /x11
parent11b654553e6799f28ab93b56abaf6a16d6806ab0 (diff)
downloadfreebsd-ports-gnome-829086f391d67260ccc3007dc40423d9941b869e.tar.gz
freebsd-ports-gnome-829086f391d67260ccc3007dc40423d9941b869e.tar.zst
freebsd-ports-gnome-829086f391d67260ccc3007dc40423d9941b869e.zip
For some of the unmaintained ports in the x11 category convert them to OptionsNG
While here, trim the headers
Diffstat (limited to 'x11')
-rw-r--r--x11/3ddesktop/Makefile10
-rw-r--r--x11/bbdock/Makefile10
-rw-r--r--x11/gdkxft/Makefile10
-rw-r--r--x11/gromit/Makefile10
-rw-r--r--x11/gtk-theme-switch/Makefile10
-rw-r--r--x11/gtkterm2/Makefile10
-rw-r--r--x11/imwheel/Makefile10
-rw-r--r--x11/libdnd/Makefile10
-rw-r--r--x11/libsx/Makefile10
-rw-r--r--x11/mrxvt/Makefile6
-rw-r--r--x11/multi-aterm/Makefile6
-rw-r--r--x11/peeper/Makefile11
-rw-r--r--x11/simdock/Makefile10
-rw-r--r--x11/swarp/Makefile10
-rw-r--r--x11/temperature.app/Makefile10
-rw-r--r--x11/wmappl/Makefile10
-rw-r--r--x11/wmbutton/Makefile12
-rw-r--r--x11/xbanner/Makefile10
-rw-r--r--x11/xcalib/Makefile4
-rw-r--r--x11/xmangekyou/Makefile10
-rw-r--r--x11/xrsi/Makefile10
-rw-r--r--x11/xsel/Makefile10
22 files changed, 82 insertions, 127 deletions
diff --git a/x11/3ddesktop/Makefile b/x11/3ddesktop/Makefile
index 5ef9d6246b08..9030a67d4b96 100644
--- a/x11/3ddesktop/Makefile
+++ b/x11/3ddesktop/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: 3ddesktop
-# Date created: 12 June 2003
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
-#
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= 3ddesktop
PORTVERSION= 0.2.9
@@ -27,6 +23,8 @@ PLIST_DIRS= %%DATADIR%%
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_DECL_GETOPT ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+.include <bsd.port.options.mk>
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-O3||g ; \
@@ -36,7 +34,7 @@ post-patch:
s|@AUTOMAKE@|${TRUE}|g'
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in README README.windowmanagers
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
diff --git a/x11/bbdock/Makefile b/x11/bbdock/Makefile
index a2e4af8b6308..afdfdf7424d8 100644
--- a/x11/bbdock/Makefile
+++ b/x11/bbdock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: BBDock
-# Date created: July 31, 2006
-# Whom: Francis Bacque <idroxid01@yahoo.fr>
-#
+# Created by: Francis Bacque <idroxid01@yahoo.fr>
# $FreeBSD$
-#
PORTNAME= bbdock
PORTVERSION= 0.2.9
@@ -25,8 +21,10 @@ PORTDOCS= README
PLIST_FILES= bin/bbdock
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/x11/gdkxft/Makefile b/x11/gdkxft/Makefile
index 6aa6ebdd62f3..a1fced9290ee 100644
--- a/x11/gdkxft/Makefile
+++ b/x11/gdkxft/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gdkxft
-# Date created: 3 September 2001
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gdkxft
PORTVERSION= 1.5
@@ -28,6 +24,8 @@ USE_LDCONFIG= yes
MAN8= gdkxft_sysinstall.8
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|gtk-config --prefix|$$GTK_CONFIG --prefix|g ; \
s|libgdk.la|libgdk-12.so|g ; \
@@ -44,7 +42,7 @@ post-patch:
.endfor
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/x11/gromit/Makefile b/x11/gromit/Makefile
index ce5b19fd0d6a..2c6eb2156905 100644
--- a/x11/gromit/Makefile
+++ b/x11/gromit/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gromit
-# Date Created: 03 Mar 2003
-# Whom: Sergei Kolobov <sergei@kolobov.com>
-#
+# Created by: Sergei Kolobov <sergei@kolobov.com>
# $FreeBSD$
-#
PORTNAME= gromit
PORTVERSION= 20041213
@@ -19,11 +15,13 @@ USE_PKGCONFIG= build
DOCS= AUTHORS ChangeLog README
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gromit ${PREFIX}/bin
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/gromitrc ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
diff --git a/x11/gtk-theme-switch/Makefile b/x11/gtk-theme-switch/Makefile
index 03a1034abf82..5902ebe754b3 100644
--- a/x11/gtk-theme-switch/Makefile
+++ b/x11/gtk-theme-switch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gtk-theme-switch
-# Date Created: 24 July 2000
-# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
-#
+# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gtk-theme-switch
PORTVERSION= 1.0.1
@@ -19,7 +15,9 @@ USE_GMAKE= yes
MAN1= gtk-theme-switch.1
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${PREFIX}/share/gtk-theme-switch
${INSTALL_MAN} ${WRKSRC}/readme ${PREFIX}/share/gtk-theme-switch/README
diff --git a/x11/gtkterm2/Makefile b/x11/gtkterm2/Makefile
index ebcb6868ed20..866226a41ae5 100644
--- a/x11/gtkterm2/Makefile
+++ b/x11/gtkterm2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gtkterm2
-# Date created: 2004-06-12
-# Whom: michael johnson <ahze@ahze.net>
-#
+# Created by: michael johnson <ahze@ahze.net>
# $FreeBSD$
-#
PORTNAME= gtkterm2
PORTVERSION= 0.2.3
@@ -28,6 +24,8 @@ PLIST_DIRS= %%DATADIR%%/pixmaps %%DATADIR%%
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=""||g' ${WRKSRC}/configure
@@ -38,7 +36,7 @@ do-install:
@${MKDIR} ${DATADIR}/pixmaps
${INSTALL_DATA} ${WRKSRC}/pixmaps/gtkterm2.png \
${DATADIR}/pixmaps/gtkterm2.png
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
.endif
diff --git a/x11/imwheel/Makefile b/x11/imwheel/Makefile
index 7b091b3a967c..7999fccdc736 100644
--- a/x11/imwheel/Makefile
+++ b/x11/imwheel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: imwheel-0.9.7
-# Date created: 18 Feb 2000
-# Whom: jhb
-#
+# Created by: jhb
# $FreeBSD$
-#
PORTNAME= imwheel
PORTVERSION= 1.0.0.p12
@@ -24,13 +20,15 @@ CONFIGURE_ARGS= --disable-gpm
MAN1= imwheel.1
+.include <bsd.port.options.mk>
+
post-patch:
.for i in imwheel.1 util.c
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/${i}
.endfor
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/EMACS ${DOCSDIR}
.endif
diff --git a/x11/libdnd/Makefile b/x11/libdnd/Makefile
index a6d5ee07d85c..35e17eb13812 100644
--- a/x11/libdnd/Makefile
+++ b/x11/libdnd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libDnd
-# Date created: 8 August 1997
-# Whom: lukin@okbmei.msk.su
-#
+# Created by: lukin@okbmei.msk.su
# $FreeBSD$
-#
PORTNAME= libdnd
PORTVERSION= 1.1
@@ -24,8 +20,10 @@ CPPFLAGS+= -I${LOCALBASE}/include/
LDFLAGS+= -L${LOCALBASE}/lib/
MAKE_JOBS_UNSAFE= yes
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/share/doc/libdnd
${INSTALL_MAN} ${WRKDIR}/DND/DNDdoc/* ${DOCSDIR}
.endif
diff --git a/x11/libsx/Makefile b/x11/libsx/Makefile
index 3724329e5f92..ae246626e849 100644
--- a/x11/libsx/Makefile
+++ b/x11/libsx/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libsx
-# Date created: 5 December 1996
-# Whom: Pedro Giffuni
-#
+# Created by: Pedro Giffuni
# $FreeBSD$
-#
PORTNAME= libsx
PORTVERSION= 1.1
@@ -23,6 +19,8 @@ USE_XORG= x11 xaw xext xmu xt
ALL_TARGET= src freq
MAKE_JOBS_UNSAFE= yes
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_DATA} ${WRKSRC}/src/libsx.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/freq/libfreq.a ${PREFIX}/lib
@@ -31,7 +29,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/freq/freq.h ${PREFIX}/include/X11/libsx
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/share/doc/libsx
${INSTALL_DATA} ${WRKSRC}/docs/* ${PREFIX}/share/doc/libsx
${GZIP_CMD} ${PREFIX}/share/doc/libsx/*.doc
diff --git a/x11/mrxvt/Makefile b/x11/mrxvt/Makefile
index f579ed3f278c..05269e782471 100644
--- a/x11/mrxvt/Makefile
+++ b/x11/mrxvt/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mrxvt
-# Date created: 27 Nov 2004
-# Whom: David Yeske <dyeske@gmail.com>
-#
+# Created by: David Yeske <dyeske@gmail.com>
# $FreeBSD$
-#
PORTNAME= mrxvt
PORTVERSION= 0.4.2
diff --git a/x11/multi-aterm/Makefile b/x11/multi-aterm/Makefile
index 7a2be5e4c196..a695a4062ce3 100644
--- a/x11/multi-aterm/Makefile
+++ b/x11/multi-aterm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: multi-aterm
-# Date created: 2003-07-11
-# Whom: Sebastian Yepes <esn@x123.info>
-#
+# Created by: Sebastian Yepes <esn@x123.info>
# $FreeBSD$
-#
PORTNAME= multi-aterm
PORTVERSION= 0.2.1
diff --git a/x11/peeper/Makefile b/x11/peeper/Makefile
index dd774ac12a11..694cf80b2261 100644
--- a/x11/peeper/Makefile
+++ b/x11/peeper/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: peeper
-# Date created: Aug 9, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= peeper
PORTVERSION= 0.1
@@ -21,9 +16,11 @@ MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} `${IMLIB_CONFIG} --cflags-gdk`" \
LIBS="`${IMLIB_CONFIG} --libs-gdk`"
ALL_TARGET= peeper
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/peeper ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/x11/simdock/Makefile b/x11/simdock/Makefile
index 8f24bd9e3f10..ead02f6c2691 100644
--- a/x11/simdock/Makefile
+++ b/x11/simdock/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: simdock
-# Date created: 28 Jul 2007
-# Whom: Yinghong.Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong.Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= simdock
PORTVERSION= 1.2
@@ -25,6 +21,8 @@ WRKSRC= ${WRKDIR}/trunk
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS README TODO
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
${WRKSRC}/Makefile.in \
@@ -34,7 +32,7 @@ post-patch:
${WRKSRC}/src/main.cc
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
diff --git a/x11/swarp/Makefile b/x11/swarp/Makefile
index 81fae8530c46..19bedc16170c 100644
--- a/x11/swarp/Makefile
+++ b/x11/swarp/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: swarp
-# Date created: 2008-01-15
-# Whom: Daniel Roethlisberger <daniel@roe.ch>
-#
+# Created by: Daniel Roethlisberger <daniel@roe.ch>
# $FreeBSD$
-#
PORTNAME= swarp
PORTVERSION= 0.1
@@ -26,11 +22,13 @@ MAKE_ARGS= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lX11" \
PORTDOCS= README
PLIST_FILES= bin/swarp
+.include <bsd.port.options.mk>
+
post-patch:
@${ECHO_CMD} -n > ${WRKSRC}/config.mk
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/x11/temperature.app/Makefile b/x11/temperature.app/Makefile
index 8e7a6752bc0b..6be20b2610d2 100644
--- a/x11/temperature.app/Makefile
+++ b/x11/temperature.app/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Temperature.app
-# Date created: 06 May 2001
-# Whom: Per Otterstr=F6m <pelle@fukt.bth.se>
-#
+# Created by: Per Otterstr=F6m <pelle@fukt.bth.se>
# $FreeBSD$
-#
PORTNAME= temperature.app
PORTVERSION= 1.4
@@ -22,9 +18,11 @@ RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
USE_XORG= x11 xpm
+.include <bsd.port.options.mk>
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/Temperature.app ${PREFIX}/bin
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/x11/wmappl/Makefile b/x11/wmappl/Makefile
index 8e3392be8cff..e8431834bfed 100644
--- a/x11/wmappl/Makefile
+++ b/x11/wmappl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmappl
-# Date created: 3 March 2002
-# Whom: od <od@iclub.nsu.ru>
-#
+# Created by: od <od@iclub.nsu.ru>
# $FreeBSD$
-#
PORTNAME= wmappl
PORTVERSION= 0.71
@@ -23,6 +19,8 @@ MAKE_ENV= DATADIR="${DATADIR}"
MAN1= wmappl.1
MAN5= wmapplrc.5
+.include <bsd.port.options.mk>
+
post-extract:
@${RM} -rf ${WRKSRC}/icons/CVS
@@ -32,7 +30,7 @@ post-install:
@${MKDIR} ${DATADIR}
@cd ${WRKDIR} && ${INSTALL_DATA} *.xpm ${DATADIR}
@cd ${WRKDIR}/smallicons && ${INSTALL_DATA} *.xpm ${DATADIR}
-.ifndef(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_CMD} "===> Installing README as ${DOCSDIR}/README"
@${ECHO_CMD} "===> Please read for configuration information"
@${MKDIR} ${DOCSDIR}
diff --git a/x11/wmbutton/Makefile b/x11/wmbutton/Makefile
index a29cdb1a182a..5ce6fdf49428 100644
--- a/x11/wmbutton/Makefile
+++ b/x11/wmbutton/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmbutton
-# Date created: 10 Apr 1999
-# Whom: Jim Mock <jim@FreeBSD.org>
-#
+# Created by: Jim Mock <jim@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= wmbutton
PORTVERSION= 0.6.1
@@ -24,6 +20,8 @@ PORTDOCS= README
PORTEXAMPLES= dot.wmbutton
PLIST_FILES= bin/wmbutton
+.include <bsd.port.options.mk>
+
do-build:
cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} \
-I${LOCALBASE}/include/X11 -I${LOCALBASE}/include \
@@ -32,11 +30,11 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/wmbutton ${PREFIX}/bin/wmbutton
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/.wmbutton ${EXAMPLESDIR}/dot.wmbutton
.endif
diff --git a/x11/xbanner/Makefile b/x11/xbanner/Makefile
index 0d8170b130d3..ab6957448c8a 100644
--- a/x11/xbanner/Makefile
+++ b/x11/xbanner/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xbanner
-# Date created: 13 Jan 1999
-# Whom: giffunip@asme.org
-#
+# Created by: giffunip@asme.org
# $FreeBSD$
-#
PORTNAME= xbanner
PORTVERSION= 1.31
@@ -18,6 +14,8 @@ COMMENT= Make your XDM login screen look beautiful
USE_XORG= xpm x11
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/xres.c ${WRKSRC}/samples/XBanner.ad
@@ -25,7 +23,7 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/samples/XBanner.ad \
${PREFIX}/lib/X11/app-defaults/XBanner
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${PREFIX}/share/doc/XBanner
${INSTALL_DATA} ${WRKSRC}/QuickStart ${PREFIX}/share/doc/XBanner
${INSTALL_DATA} ${WRKSRC}/docs/* ${PREFIX}/share/doc/XBanner
diff --git a/x11/xcalib/Makefile b/x11/xcalib/Makefile
index 427c25fd12bb..9c3f01dfe8e4 100644
--- a/x11/xcalib/Makefile
+++ b/x11/xcalib/Makefile
@@ -19,6 +19,8 @@ DEFINES= -DXCALIB_VERSION=\"${PORTVERSION}\" -DUNIX
LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib -lm -lX11 -lXxf86vm -lXext
CFLAGS+= -I./icclib -I${LOCALBASE}/include -I${LOCALBASE}/include
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' \
${WRKSRC}/Makefile
@@ -28,7 +30,7 @@ do-install:
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/*.icc ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
diff --git a/x11/xmangekyou/Makefile b/x11/xmangekyou/Makefile
index d0208a41cde5..6711a7eb25bc 100644
--- a/x11/xmangekyou/Makefile
+++ b/x11/xmangekyou/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: XMangekyou
-# Date created: 30 October 1998
-# Whom: Sakai Hiroaki <sakai@miya.ee.kagu.sut.ac.jp>
-#
+# Created by: Sakai Hiroaki <sakai@miya.ee.kagu.sut.ac.jp>
# $FreeBSD$
-#
PORTNAME= xmangekyou
PORTVERSION= 2.0.1
@@ -23,6 +19,8 @@ PORTDOCS= COPYRIGHT.euc HISTORY.euc README.euc
PLIST_FILES= bin/xmangekyou lib/X11/XMangekyou/animation.dat
PLIST_DIRS= lib/X11/XMangekyou
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|= /usr/X11R6|= $${PREFIX}|g ; \
s|gcc |$${CC} |g ; \
@@ -35,7 +33,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/xmangekyou.1.gz ${MANPREFIX}/man/man1
@${MKDIR} ${PREFIX}/lib/X11/XMangekyou
${INSTALL_DATA} ${WRKSRC}/animation.dat ${PREFIX}/lib/X11/XMangekyou
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.euc ${DOCSDIR}
.endif
diff --git a/x11/xrsi/Makefile b/x11/xrsi/Makefile
index 56637f8d9856..0119704d619c 100644
--- a/x11/xrsi/Makefile
+++ b/x11/xrsi/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xrsi
-# Date created: 2007-03-17
-# Whom: Martin Tournoij <carpetsmoker@xs4all.nl>
-#
+# Created by: Martin Tournoij <carpetsmoker@xs4all.nl>
# $FreeBSD$
-#
PORTNAME= xrsi
PORTVERSION= 0.9
@@ -18,12 +14,14 @@ USE_XORG= x11
PLIST_FILES= bin/xrsi
PORTDOCS= Readme Licence
+.include <bsd.port.options.mk>
+
do-build:
${CC} ${CFLAGS} -I${LOCALBASE}/include -L${LOCALBASE}/lib -lX11 -o ${WRKSRC}/xrsi ${WRKSRC}/xrsi.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xrsi ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Readme ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/Licence ${DOCSDIR}/
diff --git a/x11/xsel/Makefile b/x11/xsel/Makefile
index 84f78e01ff55..2d384fa2aa29 100644
--- a/x11/xsel/Makefile
+++ b/x11/xsel/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: xsel
-# Date created: Jan 14, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= xsel
PORTVERSION= 0.04.1
@@ -24,13 +20,15 @@ MAN1= ${PORTNAME}.1
PLIST_FILES= bin/${PORTNAME}
PORTDOCS= ${PORTNAME}.html
+.include <bsd.port.options.mk>
+
do-build:
@cd ${WRKSRC} && ${CC} ${CFLAGS} xsel.c -o xsel ${LDFLAGS}
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
@${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.man ${MAN1PREFIX}/man/man1/${PORTNAME}.1
-.ifndef NOPORTDOCS
+.if ${PORT_OPTIONS:MDOCS}
@${INSTALL} -d ${DOCSDIR}/
@cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif