aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-10-04 06:34:44 +0800
committerwill <will@FreeBSD.org>2003-10-04 06:34:44 +0800
commit8f83b0f304ffe579fd4a068d613cf47bb015e5a8 (patch)
tree14d060b659c29b8e11092216ba0d95308a108c5c /x11
parent2205ebb5c60a6843e652faa33a5623131e615aff (diff)
downloadfreebsd-ports-gnome-8f83b0f304ffe579fd4a068d613cf47bb015e5a8.tar.gz
freebsd-ports-gnome-8f83b0f304ffe579fd4a068d613cf47bb015e5a8.tar.zst
freebsd-ports-gnome-8f83b0f304ffe579fd4a068d613cf47bb015e5a8.zip
Fix the -pthread problem in case the option gets removed again. This
patch involved patching the core auto* routines in KDE to accept the PTHREAD_* variables in the environment, with fallbacks. We decided the easiest way to implement this in ports was to generate configure instead of risking incorrect generation at port configure time. Said patch has already been committed to HEAD in KDE and as such will be removed with the 3.2 upgrade once it is released. Ports using Makefile.kde that shouldn't be using them (i.e. non-KDE modules) have this support commented out due to lack of patch. Helped out: Adriaan de Groot <adridg@cs.kun.nl> Lauri Watts <lauri@kde.org> Andy Fawcett <andy@athame.co.uk>
Diffstat (limited to 'x11')
-rw-r--r--x11/kde3/Makefile.kde22
-rw-r--r--x11/kde4-baseapps/distinfo2
-rw-r--r--x11/kde4-runtime/distinfo2
-rw-r--r--x11/kde4-workspace/distinfo2
-rw-r--r--x11/kde4/Makefile.kde22
-rw-r--r--x11/kdebase3/distinfo2
-rw-r--r--x11/kdebase4-runtime/distinfo2
-rw-r--r--x11/kdebase4-workspace/distinfo2
-rw-r--r--x11/kdebase4/distinfo2
-rw-r--r--x11/kdelibs3/distinfo2
-rw-r--r--x11/kdelibs3/files/patch-configure38
-rw-r--r--x11/kdelibs4/distinfo2
-rw-r--r--x11/kdelibs4/files/patch-configure38
13 files changed, 62 insertions, 76 deletions
diff --git a/x11/kde3/Makefile.kde b/x11/kde3/Makefile.kde
index a974fa4da75e..611f52ea17e3 100644
--- a/x11/kde3/Makefile.kde
+++ b/x11/kde3/Makefile.kde
@@ -37,6 +37,8 @@ post-extract:
# Unfortunately, this feature doesn't work right now due to binary files.
_NO_KDE_PATCHUP=yes
+CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
+
# Start options here.
.if !defined(_NO_KDE_PATCHUP)
.if !defined(KDE_PATCHFROM_VER)
@@ -90,6 +92,26 @@ CONFIGURE_ARGS+= --with-xinerama
.endif
.endif # !defined(_NO_KDE_XINERAMA)
+.if defined(KDE_I18N)
+_NO_KDE_FIXPTHREAD= yes
+.endif
+
+.if !defined(_NO_KDE_FIXPTHREAD)
+PTHFIX_DATE?= 2003092201
+MASTER_SITES+= http://www.fruitsalad.org/patches/:kde \
+ ${MASTER_SITE_KDE_kde:S,src,FreeBSD/patches,g}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}-${PTHFIX_DATE}-configure.tar.bz2:kde
+PATCH_SITES+= http://www.fruitsalad.org/patches/:kde \
+ ${MASTER_SITE_KDE_kde:S,src,FreeBSD/patches,g}
+PATCHFILES+= patch-ltmain.sh:kde
+USE_REINPLACE= yes
+
+pre-configure: fix-pedantic
+fix-pedantic:
+ @${REINPLACE_CMD} "s,-pedantic,,g" ${WRKSRC}/configure
+.endif
+
kde-version-check:
.if exists(${LOCALBASE}/include/kfm.h)
@${ECHO}
diff --git a/x11/kde4-baseapps/distinfo b/x11/kde4-baseapps/distinfo
index 7997c9f6f51c..0b7b33f0942b 100644
--- a/x11/kde4-baseapps/distinfo
+++ b/x11/kde4-baseapps/distinfo
@@ -1 +1,3 @@
MD5 (KDE/kdebase-3.1.4.tar.bz2) = e6859ad85b176e11ce997490786c124d
+MD5 (KDE/kdebase-2003092201-configure.tar.bz2) = 7b732232e887c62f5338e7117b0a30bf
+MD5 (KDE/patch-ltmain.sh) = 44696638ed79bdd194c6f72442509fe1
diff --git a/x11/kde4-runtime/distinfo b/x11/kde4-runtime/distinfo
index 7997c9f6f51c..0b7b33f0942b 100644
--- a/x11/kde4-runtime/distinfo
+++ b/x11/kde4-runtime/distinfo
@@ -1 +1,3 @@
MD5 (KDE/kdebase-3.1.4.tar.bz2) = e6859ad85b176e11ce997490786c124d
+MD5 (KDE/kdebase-2003092201-configure.tar.bz2) = 7b732232e887c62f5338e7117b0a30bf
+MD5 (KDE/patch-ltmain.sh) = 44696638ed79bdd194c6f72442509fe1
diff --git a/x11/kde4-workspace/distinfo b/x11/kde4-workspace/distinfo
index 7997c9f6f51c..0b7b33f0942b 100644
--- a/x11/kde4-workspace/distinfo
+++ b/x11/kde4-workspace/distinfo
@@ -1 +1,3 @@
MD5 (KDE/kdebase-3.1.4.tar.bz2) = e6859ad85b176e11ce997490786c124d
+MD5 (KDE/kdebase-2003092201-configure.tar.bz2) = 7b732232e887c62f5338e7117b0a30bf
+MD5 (KDE/patch-ltmain.sh) = 44696638ed79bdd194c6f72442509fe1
diff --git a/x11/kde4/Makefile.kde b/x11/kde4/Makefile.kde
index a974fa4da75e..611f52ea17e3 100644
--- a/x11/kde4/Makefile.kde
+++ b/x11/kde4/Makefile.kde
@@ -37,6 +37,8 @@ post-extract:
# Unfortunately, this feature doesn't work right now due to binary files.
_NO_KDE_PATCHUP=yes
+CONFIGURE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
+
# Start options here.
.if !defined(_NO_KDE_PATCHUP)
.if !defined(KDE_PATCHFROM_VER)
@@ -90,6 +92,26 @@ CONFIGURE_ARGS+= --with-xinerama
.endif
.endif # !defined(_NO_KDE_XINERAMA)
+.if defined(KDE_I18N)
+_NO_KDE_FIXPTHREAD= yes
+.endif
+
+.if !defined(_NO_KDE_FIXPTHREAD)
+PTHFIX_DATE?= 2003092201
+MASTER_SITES+= http://www.fruitsalad.org/patches/:kde \
+ ${MASTER_SITE_KDE_kde:S,src,FreeBSD/patches,g}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ ${PORTNAME}-${PTHFIX_DATE}-configure.tar.bz2:kde
+PATCH_SITES+= http://www.fruitsalad.org/patches/:kde \
+ ${MASTER_SITE_KDE_kde:S,src,FreeBSD/patches,g}
+PATCHFILES+= patch-ltmain.sh:kde
+USE_REINPLACE= yes
+
+pre-configure: fix-pedantic
+fix-pedantic:
+ @${REINPLACE_CMD} "s,-pedantic,,g" ${WRKSRC}/configure
+.endif
+
kde-version-check:
.if exists(${LOCALBASE}/include/kfm.h)
@${ECHO}
diff --git a/x11/kdebase3/distinfo b/x11/kdebase3/distinfo
index 7997c9f6f51c..0b7b33f0942b 100644
--- a/x11/kdebase3/distinfo
+++ b/x11/kdebase3/distinfo
@@ -1 +1,3 @@
MD5 (KDE/kdebase-3.1.4.tar.bz2) = e6859ad85b176e11ce997490786c124d
+MD5 (KDE/kdebase-2003092201-configure.tar.bz2) = 7b732232e887c62f5338e7117b0a30bf
+MD5 (KDE/patch-ltmain.sh) = 44696638ed79bdd194c6f72442509fe1
diff --git a/x11/kdebase4-runtime/distinfo b/x11/kdebase4-runtime/distinfo
index 7997c9f6f51c..0b7b33f0942b 100644
--- a/x11/kdebase4-runtime/distinfo
+++ b/x11/kdebase4-runtime/distinfo
@@ -1 +1,3 @@
MD5 (KDE/kdebase-3.1.4.tar.bz2) = e6859ad85b176e11ce997490786c124d
+MD5 (KDE/kdebase-2003092201-configure.tar.bz2) = 7b732232e887c62f5338e7117b0a30bf
+MD5 (KDE/patch-ltmain.sh) = 44696638ed79bdd194c6f72442509fe1
diff --git a/x11/kdebase4-workspace/distinfo b/x11/kdebase4-workspace/distinfo
index 7997c9f6f51c..0b7b33f0942b 100644
--- a/x11/kdebase4-workspace/distinfo
+++ b/x11/kdebase4-workspace/distinfo
@@ -1 +1,3 @@
MD5 (KDE/kdebase-3.1.4.tar.bz2) = e6859ad85b176e11ce997490786c124d
+MD5 (KDE/kdebase-2003092201-configure.tar.bz2) = 7b732232e887c62f5338e7117b0a30bf
+MD5 (KDE/patch-ltmain.sh) = 44696638ed79bdd194c6f72442509fe1
diff --git a/x11/kdebase4/distinfo b/x11/kdebase4/distinfo
index 7997c9f6f51c..0b7b33f0942b 100644
--- a/x11/kdebase4/distinfo
+++ b/x11/kdebase4/distinfo
@@ -1 +1,3 @@
MD5 (KDE/kdebase-3.1.4.tar.bz2) = e6859ad85b176e11ce997490786c124d
+MD5 (KDE/kdebase-2003092201-configure.tar.bz2) = 7b732232e887c62f5338e7117b0a30bf
+MD5 (KDE/patch-ltmain.sh) = 44696638ed79bdd194c6f72442509fe1
diff --git a/x11/kdelibs3/distinfo b/x11/kdelibs3/distinfo
index 60ea331ded3c..592382dac09e 100644
--- a/x11/kdelibs3/distinfo
+++ b/x11/kdelibs3/distinfo
@@ -1 +1,3 @@
MD5 (KDE/kdelibs-3.1.4.tar.bz2) = 82c265de78d53c7060a09c5cb1a78942
+MD5 (KDE/kdelibs-2003092201-configure.tar.bz2) = 24127f6cb3ce49450e7f0292918ab8ad
+MD5 (KDE/patch-ltmain.sh) = 44696638ed79bdd194c6f72442509fe1
diff --git a/x11/kdelibs3/files/patch-configure b/x11/kdelibs3/files/patch-configure
deleted file mode 100644
index 6ddc066122cd..000000000000
--- a/x11/kdelibs3/files/patch-configure
+++ /dev/null
@@ -1,38 +0,0 @@
---- configure.orig Thu Jan 30 15:08:09 2003
-+++ configure Thu Jan 30 15:08:30 2003
-@@ -2813,7 +2813,7 @@
- fi
- else
- if test "$GCC" = yes; then
-- CFLAGS="-O2"
-+ CFLAGS=""
- else
- CFLAGS=
- fi
-@@ -3220,7 +3220,7 @@
- CFLAGS="-g -O2 $CFLAGS"
- fi
- else
-- CFLAGS="-O2 $CFLAGS"
-+ CFLAGS="$CFLAGS"
- fi
- fi
-
-@@ -3462,7 +3462,7 @@
- fi
- else
- if test "$GXX" = yes; then
-- CXXFLAGS="-O2"
-+ CXXFLAGS=""
- else
- CXXFLAGS=
- fi
-@@ -3811,7 +3811,7 @@
- if test "$CXX" = "KCC"; then
- CXXFLAGS="+K3 $CXXFLAGS"
- else
-- CXXFLAGS="-O2 $CXXFLAGS"
-+ CXXFLAGS="$CXXFLAGS"
- fi
- fi
- fi
diff --git a/x11/kdelibs4/distinfo b/x11/kdelibs4/distinfo
index 60ea331ded3c..592382dac09e 100644
--- a/x11/kdelibs4/distinfo
+++ b/x11/kdelibs4/distinfo
@@ -1 +1,3 @@
MD5 (KDE/kdelibs-3.1.4.tar.bz2) = 82c265de78d53c7060a09c5cb1a78942
+MD5 (KDE/kdelibs-2003092201-configure.tar.bz2) = 24127f6cb3ce49450e7f0292918ab8ad
+MD5 (KDE/patch-ltmain.sh) = 44696638ed79bdd194c6f72442509fe1
diff --git a/x11/kdelibs4/files/patch-configure b/x11/kdelibs4/files/patch-configure
deleted file mode 100644
index 6ddc066122cd..000000000000
--- a/x11/kdelibs4/files/patch-configure
+++ /dev/null
@@ -1,38 +0,0 @@
---- configure.orig Thu Jan 30 15:08:09 2003
-+++ configure Thu Jan 30 15:08:30 2003
-@@ -2813,7 +2813,7 @@
- fi
- else
- if test "$GCC" = yes; then
-- CFLAGS="-O2"
-+ CFLAGS=""
- else
- CFLAGS=
- fi
-@@ -3220,7 +3220,7 @@
- CFLAGS="-g -O2 $CFLAGS"
- fi
- else
-- CFLAGS="-O2 $CFLAGS"
-+ CFLAGS="$CFLAGS"
- fi
- fi
-
-@@ -3462,7 +3462,7 @@
- fi
- else
- if test "$GXX" = yes; then
-- CXXFLAGS="-O2"
-+ CXXFLAGS=""
- else
- CXXFLAGS=
- fi
-@@ -3811,7 +3811,7 @@
- if test "$CXX" = "KCC"; then
- CXXFLAGS="+K3 $CXXFLAGS"
- else
-- CXXFLAGS="-O2 $CXXFLAGS"
-+ CXXFLAGS="$CXXFLAGS"
- fi
- fi
- fi