aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-07-18 16:02:55 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-07-18 16:02:55 +0800
commit9eb69ec3aef2e1b07989f1ae210856cbe4cd073e (patch)
tree986af56388b76159c663bd0bb4595b002f3db2aa /x11
parent5868bedd793d547be7d95a8bde44942ae7393eb4 (diff)
downloadfreebsd-ports-gnome-9eb69ec3aef2e1b07989f1ae210856cbe4cd073e.tar.gz
freebsd-ports-gnome-9eb69ec3aef2e1b07989f1ae210856cbe4cd073e.tar.zst
freebsd-ports-gnome-9eb69ec3aef2e1b07989f1ae210856cbe4cd073e.zip
- Add radio-style selection of Xaw3d/Xaw3dxft/neXtaw
- Add option to enable the logging function of xterm Submitted by: "S. Wall" <xterm-user@wallfamily.us> (based on)
Diffstat (limited to 'x11')
-rw-r--r--x11/xterm/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/x11/xterm/Makefile b/x11/xterm/Makefile
index 441082d9d267..050d0999eeb2 100644
--- a/x11/xterm/Makefile
+++ b/x11/xterm/Makefile
@@ -15,7 +15,7 @@ COMMENT= Terminal emulator for the X Window System
CONFLICTS= x11iraf-[0-9]*
-USE_XORG= xaw xft
+USE_XORG= xft
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-utempter --enable-narrowproto
@@ -25,7 +25,9 @@ LIBS+= -L${LOCALBASE}/lib
ICONVERSION= 1
-OPTIONS_DEFINE= WCHAR LUIT DECTERM PCRE DABBREV 256COLOR SIXEL GNOME XAW3DXFT
+OPTIONS_DEFINE= WCHAR LUIT DECTERM PCRE DABBREV 256COLOR SIXEL GNOME LOGGING
+OPTIONS_RADIO= 3D
+OPTIONS_RADIO_3D= XAW3D XAW3DXFT NEXTAW
DABBREV_DESC= Enable support for dabbrev-expand
DECTERM_DESC= Enable DECterm Locator support
@@ -33,7 +35,10 @@ LUIT_DESC= Use LUIT for locale convertion from/to UTF-8
SIXEL_DESC= Enable Sixel graphics support
WCHAR_DESC= Enable wide-character support
256COLOR_DESC= Enable 256-color support
-XAW3DXFT_DESC= Enable Xaw 3d xft library support
+LOGGING_DESC= Enable logging terminal I/O to a file
+XAW3D_DESC= Link with Xaw 3d library
+XAW3DXFT_DESC= Link with Xaw 3d xft (extended fonts) library
+NEXTAW_DESC= Link with neXT Athena library
OPTIONS_DEFAULT=WCHAR LUIT 256COLOR
@@ -47,11 +52,20 @@ PCRE_LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
DABBREV_CONFIGURE_ENABLE= dabbrev
SIXEL_CONFIGURE_ENABLE= sixel-graphics
GNOME_USES= desktop-file-utils
+LOGGING_CONFIGURE_ENABLE= logging
+XAW3D_CONFIGURE_WITH= Xaw3d
+XAW3D_LIB_DEPENDS= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
XAW3DXFT_CONFIGURE_WITH= Xaw3dxft
XAW3DXFT_LIB_DEPENDS= libXaw3dxft.so:${PORTSDIR}/x11-toolkits/libxaw3dxft
+NEXTAW_CONFIGURE_WITH= neXtaw
+NEXTAW_LIB_DEPENDS= libneXtaw.so:${PORTSDIR}/x11-toolkits/neXtaw
.include <bsd.port.options.mk>
+.if ! ${PORT_OPTIONS:MXAW3D} && ! ${PORT_OPTIONS:MXAW3DXFT} && ! ${PORT_OPTIONS:MNEXTAW}
+USE_XORG+= xaw
+.endif
+
.if ${OSVERSION} < 900004
LIB_DEPENDS+= libutempter.so:${PORTSDIR}/sysutils/libutempter
.endif