aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-04-17 15:33:34 +0800
committertobik <tobik@FreeBSD.org>2019-04-17 15:33:34 +0800
commita0ae3ecc502dcbce23438ff6d05df59909528154 (patch)
treee05f59866e6139badbc92c7524966ba640a8fed5 /x11
parentcb55b190e0ecf582a7e823ac459c89c83fb58b1e (diff)
downloadfreebsd-ports-gnome-a0ae3ecc502dcbce23438ff6d05df59909528154.tar.gz
freebsd-ports-gnome-a0ae3ecc502dcbce23438ff6d05df59909528154.tar.zst
freebsd-ports-gnome-a0ae3ecc502dcbce23438ff6d05df59909528154.zip
Mk/Uses/cargo.mk: Push lib dependencies back down into ports
Some crates are optional via Cargo features or are only used during tests, however the framework has no way to discriminate between test or run dependencies using just CARGO_CRATES leading to more run dependencies than necessary for some packages. With more ported Rust applications it's time to let individual ports make that decision now. The environmental setup to use dependencies from ports instead of bundled ones and implied build dependencies (cmake, gmake, pkgconf) are left in place for now. Assign cargo.mk to rust@ while here.
Diffstat (limited to 'x11')
-rw-r--r--x11/alacritty/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/x11/alacritty/Makefile b/x11/alacritty/Makefile
index bbe36d46474d..cd6544337311 100644
--- a/x11/alacritty/Makefile
+++ b/x11/alacritty/Makefile
@@ -12,9 +12,10 @@ COMMENT= GPU-accelerated terminal emulator
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE-APACHE
-LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
-USES= cargo
+USES= cargo ssl
USE_GITHUB= yes
GH_ACCOUNT= jwilm