aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2011-04-08 14:25:19 +0800
committermartymac <martymac@FreeBSD.org>2011-04-08 14:25:19 +0800
commitb21fd35f4733032fe5bcdb7f072e8c0ee8428b3f (patch)
tree87655bb6587bd838b882f5d4479fbe85cda70f02 /x11
parentcc75945d4903869603dc1def6a5933c82f9b5f00 (diff)
downloadfreebsd-ports-gnome-b21fd35f4733032fe5bcdb7f072e8c0ee8428b3f.tar.gz
freebsd-ports-gnome-b21fd35f4733032fe5bcdb7f072e8c0ee8428b3f.tar.zst
freebsd-ports-gnome-b21fd35f4733032fe5bcdb7f072e8c0ee8428b3f.zip
Add st, a minimalistic X terminal.
PR: ports/156100 Submitted by: Matthew Donovan <kitchetech at gmail.com>
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/sterm/Makefile54
-rw-r--r--x11/sterm/distinfo2
-rw-r--r--x11/sterm/files/patch-Makefile11
-rw-r--r--x11/sterm/files/patch-config.mk21
-rw-r--r--x11/sterm/pkg-descr6
6 files changed, 95 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 53291bd9c8b8..fed8b08fe5f1 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -271,6 +271,7 @@
SUBDIR += sselp
SUBDIR += stalonetray
SUBDIR += startup-notification
+ SUBDIR += sterm
SUBDIR += swarp
SUBDIR += sxpc
SUBDIR += tabbed
diff --git a/x11/sterm/Makefile b/x11/sterm/Makefile
new file mode 100644
index 000000000000..b73d2be0b129
--- /dev/null
+++ b/x11/sterm/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: sterm
+# Date created: April 01, 2011
+# Whom: Matthew Donovan <kitchetech@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sterm
+PORTVERSION= 0.0.20110401
+CATEGORIES= x11
+MASTER_SITES= http://kitchetech.com/port/distfile/ \
+ LOCAL/martymac
+
+MAINTAINER= kitchetech@gmail.com
+COMMENT= A simple X terminal
+
+RUN_DEPENDS= ${LOCALBASE}/share/misc/terminfo.db:${PORTSDIR}/devel/ncurses
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_XORG= x11
+
+MAN1= st.1
+PLIST_FILES= bin/st
+
+PORTDOCS= README
+
+pre-everything::
+ @${ECHO_MSG} "You can build st with your own config.h using the ST_CONF knob:"
+ @${ECHO_MSG} "make ST_CONF=/path/to/st/config.h install clean"
+
+post-patch:
+.if defined(ST_CONF)
+ @${ECHO_MSG} "creating config.h from ${ST_CONF}"
+ @${CP} ${ST_CONF} ${WRKSRC}/config.h
+.endif
+ @${REINPLACE_CMD} -e 's|^VERSION = .*|VERSION = ${PORTVERSION}|' \
+ -e 's|^PREFIX = .*|PREFIX = ${PREFIX}|' \
+ -e 's|^LOCALBASE = .*|LOCALBASE = ${LOCALBASE}|' \
+ -e "s|^MANPREFIX = .*|MANPREFIX = ${MANPREFIX}/man|" \
+ -e "s|^X11INC = .*|X11INC = ${LOCALBASE}/include|" \
+ -e "s|^X11LIB = .*|X11LIB = ${LOCALBASE}/lib|" \
+ ${WRKSRC}/config.mk
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/sterm/distinfo b/x11/sterm/distinfo
new file mode 100644
index 000000000000..6f66b1ca787b
--- /dev/null
+++ b/x11/sterm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sterm-0.0.20110401.tar.gz) = 966a9f30b5112b5f30a17ab2016947b2027f892aa19e486ca7d96ebab1cc8863
+SIZE (sterm-0.0.20110401.tar.gz) = 17303
diff --git a/x11/sterm/files/patch-Makefile b/x11/sterm/files/patch-Makefile
new file mode 100644
index 000000000000..e078cce28b9b
--- /dev/null
+++ b/x11/sterm/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2011-04-06 14:22:13.614498469 +0200
++++ Makefile 2011-04-06 14:23:02.470588628 +0200
+@@ -48,7 +48,7 @@
+ @mkdir -p ${DESTDIR}${MANPREFIX}/man1
+ @sed "s/VERSION/${VERSION}/g" < st.1 > ${DESTDIR}${MANPREFIX}/man1/st.1
+ @chmod 644 ${DESTDIR}${MANPREFIX}/man1/st.1
+- @tic -s st.info
++ @tic -s -o ${LOCALBASE}/share/misc st.info
+
+ uninstall:
+ @echo removing executable file from ${DESTDIR}${PREFIX}/bin
diff --git a/x11/sterm/files/patch-config.mk b/x11/sterm/files/patch-config.mk
new file mode 100644
index 000000000000..2745d9a21f59
--- /dev/null
+++ b/x11/sterm/files/patch-config.mk
@@ -0,0 +1,21 @@
+--- config.mk.orig 2011-01-23 12:30:01.000000000 +0100
++++ config.mk 2011-04-06 14:25:05.291720015 +0200
+@@ -5,6 +5,7 @@
+
+ # paths
+ PREFIX = /usr/local
++LOCALBASE= /usr/local
+ MANPREFIX = ${PREFIX}/share/man
+
+ X11INC = /usr/X11R6/include
+@@ -16,8 +17,8 @@
+
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\"
+-CFLAGS += -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+-LDFLAGS += -s ${LIBS}
++CFLAGS += -std=c99 -pedantic -Wall ${INCS} ${CPPFLAGS}
++LDFLAGS += ${LIBS}
+
+ # compiler and linker
+ CC ?= cc
diff --git a/x11/sterm/pkg-descr b/x11/sterm/pkg-descr
new file mode 100644
index 000000000000..62adf9a6d33f
--- /dev/null
+++ b/x11/sterm/pkg-descr
@@ -0,0 +1,6 @@
+st is a minimalistic X terminal.
+
+It consists of a single binary, configuration is done at compile-time by a
+config.h file.
+
+WWW: http://st.suckless.org