aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2007-08-20 22:59:46 +0800
committerdanfe <danfe@FreeBSD.org>2007-08-20 22:59:46 +0800
commitbc754e9c5fd5f6fdce01f01d88ca66c2aebcd24c (patch)
tree65f3d78ba310427fbbf14e6601a2236d2592100c /x11
parenta010e248c0972e37d5b0d8158e599aff89eaa33e (diff)
downloadfreebsd-ports-gnome-bc754e9c5fd5f6fdce01f01d88ca66c2aebcd24c.tar.gz
freebsd-ports-gnome-bc754e9c5fd5f6fdce01f01d88ca66c2aebcd24c.tar.zst
freebsd-ports-gnome-bc754e9c5fd5f6fdce01f01d88ca66c2aebcd24c.zip
Fix an edge case of "make describe".
Reported by: portsnap buildbox
Diffstat (limited to 'x11')
-rw-r--r--x11/nvidia-driver/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11/nvidia-driver/Makefile b/x11/nvidia-driver/Makefile
index 3ab5060e317e..c8f4161801f4 100644
--- a/x11/nvidia-driver/Makefile
+++ b/x11/nvidia-driver/Makefile
@@ -60,6 +60,10 @@ XFREE86_SUB= ""
XSERVVERSION!= /usr/sbin/pkg_info -O x11-servers/XFree86-4-Server 2>/dev/null | ${GREP} Server- || /usr/sbin/pkg_info -O x11-servers/xorg-server 2>/dev/null | ${GREP} server- || /usr/sbin/pkg_info -qO x11-servers/xorg-server-snap 2>/dev/null
XLIBVERSION!= /usr/sbin/pkg_info -O x11/XFree86-4-libraries 2>/dev/null | ${GREP} libraries- || /usr/sbin/pkg_info -O graphics/libGL 2>/dev/null | ${GREP} libGL- || true
+.if empty(XSERVVERSION)
+IGNORE= needs an X server implementation installed
+.endif
+
PLIST_SUB+= XSERVVERSION=${XSERVVERSION} XLIBVERSION=${XLIBVERSION} \
LINUXBASE=${LINUXBASE} SHLIB_VERSION=${PORTVERSION} \
MODULESDIR=${MODULESDIR} XORG=${XORG_SUB} XFREE86=${XFREE86_SUB}
@@ -129,9 +133,6 @@ post-patch: .SILENT
${REINPLACE_CMD} -e 's/afterinstall/dontexecute/' ${WRKSRC}/Makefile
pre-su-install:
-.if empty(XSERVVERSION)
-IGNORE= needs an X server implementation installed
-.endif
@${MKDIR} ${PREFIX}/${MODULESDIR}/drivers
post-install: