aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2008-04-15 09:48:26 +0800
committerahze <ahze@FreeBSD.org>2008-04-15 09:48:26 +0800
commitbfbf1d97d34df5d4fd8fd702019f5340867e4869 (patch)
tree4f38349473f9223f5c76078097ac38bd4ba1b302 /x11
parent15a802ad76f66c13a1fc975fc346cdc02c796c2b (diff)
downloadfreebsd-ports-gnome-bfbf1d97d34df5d4fd8fd702019f5340867e4869.tar.gz
freebsd-ports-gnome-bfbf1d97d34df5d4fd8fd702019f5340867e4869.tar.zst
freebsd-ports-gnome-bfbf1d97d34df5d4fd8fd702019f5340867e4869.zip
Add babl
Babl is a dynamic, any to any, pixel format conversion library. It provides conversions between the myriad of buffer types images can be stored in. Babl doesn't only help with existing pixel formats, but also facilitates creation of new and uncommon ones. WWW: http://www.gegl.org/babl/
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/babl/Makefile33
-rw-r--r--x11/babl/distinfo3
-rw-r--r--x11/babl/pkg-descr6
-rw-r--r--x11/babl/pkg-plist16
5 files changed, 59 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 62f04043d056..d1d532ee2211 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -13,6 +13,7 @@
SUBDIR += appres
SUBDIR += apwal
SUBDIR += aterm
+ SUBDIR += babl
SUBDIR += bbappconf
SUBDIR += bbdock
SUBDIR += bbrun
diff --git a/x11/babl/Makefile b/x11/babl/Makefile
new file mode 100644
index 000000000000..c753dd609016
--- /dev/null
+++ b/x11/babl/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: babl
+# Date created: 2008-04-14
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= babl
+PORTVERSION= 0.0.20
+CATEGORIES= x11
+MASTER_SITES= ftp://ftp.gimp.org/pub/%SUBDIR%/ \
+ http://gimp.mirrors.hoobly.com/%SUBDIR%/ \
+ http://ftp.gwdg.de/pub/misc/grafik/gimp/%SUBDIR%/ \
+ ftp://ftp.fh-heilbronn.de/mirrors/ftp.gimp.org/%SUBDIR%/ \
+ ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/%SUBDIR%/ \
+ http://www.mirrorservice.org/sites/ftp.gimp.org/pub/%SUBDIR%/ \
+ ${MASTER_SITE_RINGSERVER:S,%SUBDIR%,graphics/%SUBDIR%,}
+MASTER_SITE_SUBDIR= babl/${PORTVERSION:R}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Dynamic pixel format conversion library
+
+USE_LDCONFIG= yes
+USE_BZIP2= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= pkgconfig gnomeprefix ltverhack
+USE_GMAKE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11/babl/distinfo b/x11/babl/distinfo
new file mode 100644
index 000000000000..1744036ef163
--- /dev/null
+++ b/x11/babl/distinfo
@@ -0,0 +1,3 @@
+MD5 (babl-0.0.20.tar.bz2) = dbf67b333b0812dfe0d0f057864b0f9a
+SHA256 (babl-0.0.20.tar.bz2) = 8d942c570351a19fcac59b296b6082bbc276d7ead44659bf8fd02df835673496
+SIZE (babl-0.0.20.tar.bz2) = 393851
diff --git a/x11/babl/pkg-descr b/x11/babl/pkg-descr
new file mode 100644
index 000000000000..0111cb4b134c
--- /dev/null
+++ b/x11/babl/pkg-descr
@@ -0,0 +1,6 @@
+Babl is a dynamic, any to any, pixel format conversion library. It
+provides conversions between the myriad of buffer types images can be
+stored in. Babl doesn't only help with existing pixel formats, but also
+facilitates creation of new and uncommon ones.
+
+WWW: http://www.gegl.org/babl/
diff --git a/x11/babl/pkg-plist b/x11/babl/pkg-plist
new file mode 100644
index 000000000000..ab24afa13ade
--- /dev/null
+++ b/x11/babl/pkg-plist
@@ -0,0 +1,16 @@
+include/babl-0.0/babl/babl-classes.h
+include/babl-0.0/babl/babl.h
+lib/babl-0.0/CIE-Lab.so
+lib/babl-0.0/gegl-fixups.so
+lib/babl-0.0/gggl-lies.so
+lib/babl-0.0/gggl.so
+lib/babl-0.0/gimp-8bit.so
+lib/babl-0.0/naive-CMYK.so
+lib/libbabl-0.0.a
+lib/libbabl-0.0.la
+lib/libbabl-0.0.so
+lib/libbabl-0.0.so.0
+libdata/pkgconfig/babl.pc
+@dirrm lib/babl-0.0
+@dirrm include/babl-0.0/babl
+@dirrm include/babl-0.0