aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-01-24 17:40:38 +0800
committerdanfe <danfe@FreeBSD.org>2005-01-24 17:40:38 +0800
commitc0c2a173c72c3a397ee429fb5d523c61192b2a2b (patch)
treec914598e8b8e067a895858d46f7f95ae57966aa1 /x11
parent19d6ce1f130091f2b42090f0c85329dd3787b17d (diff)
downloadfreebsd-ports-gnome-c0c2a173c72c3a397ee429fb5d523c61192b2a2b.tar.gz
freebsd-ports-gnome-c0c2a173c72c3a397ee429fb5d523c61192b2a2b.tar.zst
freebsd-ports-gnome-c0c2a173c72c3a397ee429fb5d523c61192b2a2b.zip
- Fix the build with modern GCC
- Grab maintainership
Diffstat (limited to 'x11')
-rw-r--r--x11/decurs/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/x11/decurs/Makefile b/x11/decurs/Makefile
index ccafc6f8008d..713f45f6f42a 100644
--- a/x11/decurs/Makefile
+++ b/x11/decurs/Makefile
@@ -11,7 +11,7 @@ PORTREVISION= 3
CATEGORIES= x11
MASTER_SITES= http://varg.dyndns.org/psi/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= A GTK+ based program that lets you edit you XFree86 mouse cursors
LIB_DEPENDS= gtkmm-2.0.6:${PORTSDIR}/x11-toolkits/gtk--2
@@ -22,13 +22,24 @@ GNU_CONFIGURE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000 || ${ARCH} != "i386"
-BROKEN= "Does not compile on FreeBSD ${OSVERSION} or on !i386"
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
+.if ${OSVERSION} > 500035
+USE_REINPLACE= yes
.endif
post-patch:
@${SED} -e 's:%%PREFIX%%:${PREFIX}:g' \
${FILESDIR}/decurs.exec > ${WRKSRC}/decurs.exec
+.if ${OSVERSION} > 500035
+# Hack for contemporary GCC
+ @${REINPLACE_CMD} -e 's/, CppString \&str/, const CppString \&str/' \
+ ${WRKSRC}/src/cppstring.cc ${WRKSRC}/src/cppstring.hh
+ @${REINPLACE_CMD} -E 's/^\/\/ friend//; s/([^:])ostream/\1std::ostream/g' \
+ ${WRKSRC}/src/cppstring.hh
+.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/decurs ${PREFIX}/bin/decurs.bin