aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2006-09-14 21:08:27 +0800
committerlofi <lofi@FreeBSD.org>2006-09-14 21:08:27 +0800
commitc0f4aeaa9880a149f86c69625464682f27f042f1 (patch)
tree5229229be9657389d80d64c28630c14339dc1de9 /x11
parentfdbf122b687b948115863e710e9527c2c2bda926 (diff)
downloadfreebsd-ports-gnome-c0f4aeaa9880a149f86c69625464682f27f042f1.tar.gz
freebsd-ports-gnome-c0f4aeaa9880a149f86c69625464682f27f042f1.tar.zst
freebsd-ports-gnome-c0f4aeaa9880a149f86c69625464682f27f042f1.zip
Fix KControl/kcmshell so the Peripherals/Digital Camera KControl module
(installed by graphics/kamera) will work.
Diffstat (limited to 'x11')
-rw-r--r--x11/kde4-baseapps/Makefile2
-rw-r--r--x11/kde4-baseapps/files/patch-kcontrol_kcontrol-Makefile.in11
-rw-r--r--x11/kde4-runtime/Makefile2
-rw-r--r--x11/kde4-runtime/files/patch-kcontrol_kcontrol-Makefile.in11
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kde4-workspace/files/patch-kcontrol_kcontrol-Makefile.in11
-rw-r--r--x11/kdebase3/Makefile2
-rw-r--r--x11/kdebase3/files/patch-kcontrol_kcontrol-Makefile.in11
-rw-r--r--x11/kdebase4-runtime/Makefile2
-rw-r--r--x11/kdebase4-runtime/files/patch-kcontrol_kcontrol-Makefile.in11
-rw-r--r--x11/kdebase4-workspace/Makefile2
-rw-r--r--x11/kdebase4-workspace/files/patch-kcontrol_kcontrol-Makefile.in11
-rw-r--r--x11/kdebase4/Makefile2
-rw-r--r--x11/kdebase4/files/patch-kcontrol_kcontrol-Makefile.in11
-rw-r--r--x11/kdelibs3/Makefile1
-rw-r--r--x11/kdelibs3/files/patch-kcmshell-Makefile.in11
-rw-r--r--x11/kdelibs4/Makefile1
-rw-r--r--x11/kdelibs4/files/patch-kcmshell-Makefile.in11
18 files changed, 108 insertions, 7 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index 2dc9cbdf9f48..36013d60433f 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kde4-baseapps/files/patch-kcontrol_kcontrol-Makefile.in b/x11/kde4-baseapps/files/patch-kcontrol_kcontrol-Makefile.in
new file mode 100644
index 000000000000..cc47b08b7e98
--- /dev/null
+++ b/x11/kde4-baseapps/files/patch-kcontrol_kcontrol-Makefile.in
@@ -0,0 +1,11 @@
+--- kcontrol/kcontrol/Makefile.in.orig Thu Sep 14 06:24:48 2006
++++ kcontrol/kcontrol/Makefile.in Thu Sep 14 06:24:55 2006
+@@ -1239,7 +1239,7 @@
+ echo 'extern "C" int kdemain(int argc, char* argv[]);' >> kcontrol_dummy.cpp; \
+ echo 'extern "C" KDE_EXPORT int kdeinitmain(int argc, char* argv[]) { return kdemain(argc,argv); }' >> kcontrol_dummy.cpp
+ kcontrol_LDFLAGS = $(KDE_RPATH) -no-undefined $(all_libraries)
+-kcontrol_LDADD = libkdeinit_kcontrol.la
++kcontrol_LDADD = libkdeinit_kcontrol.la -lintl
+ kcontrol_DEPENDENCIES = libkdeinit_kcontrol.la
+
+ #>+ 5
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 2dc9cbdf9f48..36013d60433f 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kde4-runtime/files/patch-kcontrol_kcontrol-Makefile.in b/x11/kde4-runtime/files/patch-kcontrol_kcontrol-Makefile.in
new file mode 100644
index 000000000000..cc47b08b7e98
--- /dev/null
+++ b/x11/kde4-runtime/files/patch-kcontrol_kcontrol-Makefile.in
@@ -0,0 +1,11 @@
+--- kcontrol/kcontrol/Makefile.in.orig Thu Sep 14 06:24:48 2006
++++ kcontrol/kcontrol/Makefile.in Thu Sep 14 06:24:55 2006
+@@ -1239,7 +1239,7 @@
+ echo 'extern "C" int kdemain(int argc, char* argv[]);' >> kcontrol_dummy.cpp; \
+ echo 'extern "C" KDE_EXPORT int kdeinitmain(int argc, char* argv[]) { return kdemain(argc,argv); }' >> kcontrol_dummy.cpp
+ kcontrol_LDFLAGS = $(KDE_RPATH) -no-undefined $(all_libraries)
+-kcontrol_LDADD = libkdeinit_kcontrol.la
++kcontrol_LDADD = libkdeinit_kcontrol.la -lintl
+ kcontrol_DEPENDENCIES = libkdeinit_kcontrol.la
+
+ #>+ 5
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 2dc9cbdf9f48..36013d60433f 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kde4-workspace/files/patch-kcontrol_kcontrol-Makefile.in b/x11/kde4-workspace/files/patch-kcontrol_kcontrol-Makefile.in
new file mode 100644
index 000000000000..cc47b08b7e98
--- /dev/null
+++ b/x11/kde4-workspace/files/patch-kcontrol_kcontrol-Makefile.in
@@ -0,0 +1,11 @@
+--- kcontrol/kcontrol/Makefile.in.orig Thu Sep 14 06:24:48 2006
++++ kcontrol/kcontrol/Makefile.in Thu Sep 14 06:24:55 2006
+@@ -1239,7 +1239,7 @@
+ echo 'extern "C" int kdemain(int argc, char* argv[]);' >> kcontrol_dummy.cpp; \
+ echo 'extern "C" KDE_EXPORT int kdeinitmain(int argc, char* argv[]) { return kdemain(argc,argv); }' >> kcontrol_dummy.cpp
+ kcontrol_LDFLAGS = $(KDE_RPATH) -no-undefined $(all_libraries)
+-kcontrol_LDADD = libkdeinit_kcontrol.la
++kcontrol_LDADD = libkdeinit_kcontrol.la -lintl
+ kcontrol_DEPENDENCIES = libkdeinit_kcontrol.la
+
+ #>+ 5
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 2dc9cbdf9f48..36013d60433f 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase3/files/patch-kcontrol_kcontrol-Makefile.in b/x11/kdebase3/files/patch-kcontrol_kcontrol-Makefile.in
new file mode 100644
index 000000000000..cc47b08b7e98
--- /dev/null
+++ b/x11/kdebase3/files/patch-kcontrol_kcontrol-Makefile.in
@@ -0,0 +1,11 @@
+--- kcontrol/kcontrol/Makefile.in.orig Thu Sep 14 06:24:48 2006
++++ kcontrol/kcontrol/Makefile.in Thu Sep 14 06:24:55 2006
+@@ -1239,7 +1239,7 @@
+ echo 'extern "C" int kdemain(int argc, char* argv[]);' >> kcontrol_dummy.cpp; \
+ echo 'extern "C" KDE_EXPORT int kdeinitmain(int argc, char* argv[]) { return kdemain(argc,argv); }' >> kcontrol_dummy.cpp
+ kcontrol_LDFLAGS = $(KDE_RPATH) -no-undefined $(all_libraries)
+-kcontrol_LDADD = libkdeinit_kcontrol.la
++kcontrol_LDADD = libkdeinit_kcontrol.la -lintl
+ kcontrol_DEPENDENCIES = libkdeinit_kcontrol.la
+
+ #>+ 5
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index 2dc9cbdf9f48..36013d60433f 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase4-runtime/files/patch-kcontrol_kcontrol-Makefile.in b/x11/kdebase4-runtime/files/patch-kcontrol_kcontrol-Makefile.in
new file mode 100644
index 000000000000..cc47b08b7e98
--- /dev/null
+++ b/x11/kdebase4-runtime/files/patch-kcontrol_kcontrol-Makefile.in
@@ -0,0 +1,11 @@
+--- kcontrol/kcontrol/Makefile.in.orig Thu Sep 14 06:24:48 2006
++++ kcontrol/kcontrol/Makefile.in Thu Sep 14 06:24:55 2006
+@@ -1239,7 +1239,7 @@
+ echo 'extern "C" int kdemain(int argc, char* argv[]);' >> kcontrol_dummy.cpp; \
+ echo 'extern "C" KDE_EXPORT int kdeinitmain(int argc, char* argv[]) { return kdemain(argc,argv); }' >> kcontrol_dummy.cpp
+ kcontrol_LDFLAGS = $(KDE_RPATH) -no-undefined $(all_libraries)
+-kcontrol_LDADD = libkdeinit_kcontrol.la
++kcontrol_LDADD = libkdeinit_kcontrol.la -lintl
+ kcontrol_DEPENDENCIES = libkdeinit_kcontrol.la
+
+ #>+ 5
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 2dc9cbdf9f48..36013d60433f 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase4-workspace/files/patch-kcontrol_kcontrol-Makefile.in b/x11/kdebase4-workspace/files/patch-kcontrol_kcontrol-Makefile.in
new file mode 100644
index 000000000000..cc47b08b7e98
--- /dev/null
+++ b/x11/kdebase4-workspace/files/patch-kcontrol_kcontrol-Makefile.in
@@ -0,0 +1,11 @@
+--- kcontrol/kcontrol/Makefile.in.orig Thu Sep 14 06:24:48 2006
++++ kcontrol/kcontrol/Makefile.in Thu Sep 14 06:24:55 2006
+@@ -1239,7 +1239,7 @@
+ echo 'extern "C" int kdemain(int argc, char* argv[]);' >> kcontrol_dummy.cpp; \
+ echo 'extern "C" KDE_EXPORT int kdeinitmain(int argc, char* argv[]) { return kdemain(argc,argv); }' >> kcontrol_dummy.cpp
+ kcontrol_LDFLAGS = $(KDE_RPATH) -no-undefined $(all_libraries)
+-kcontrol_LDADD = libkdeinit_kcontrol.la
++kcontrol_LDADD = libkdeinit_kcontrol.la -lintl
+ kcontrol_DEPENDENCIES = libkdeinit_kcontrol.la
+
+ #>+ 5
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 2dc9cbdf9f48..36013d60433f 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdebase
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdebase4/files/patch-kcontrol_kcontrol-Makefile.in b/x11/kdebase4/files/patch-kcontrol_kcontrol-Makefile.in
new file mode 100644
index 000000000000..cc47b08b7e98
--- /dev/null
+++ b/x11/kdebase4/files/patch-kcontrol_kcontrol-Makefile.in
@@ -0,0 +1,11 @@
+--- kcontrol/kcontrol/Makefile.in.orig Thu Sep 14 06:24:48 2006
++++ kcontrol/kcontrol/Makefile.in Thu Sep 14 06:24:55 2006
+@@ -1239,7 +1239,7 @@
+ echo 'extern "C" int kdemain(int argc, char* argv[]);' >> kcontrol_dummy.cpp; \
+ echo 'extern "C" KDE_EXPORT int kdeinitmain(int argc, char* argv[]) { return kdemain(argc,argv); }' >> kcontrol_dummy.cpp
+ kcontrol_LDFLAGS = $(KDE_RPATH) -no-undefined $(all_libraries)
+-kcontrol_LDADD = libkdeinit_kcontrol.la
++kcontrol_LDADD = libkdeinit_kcontrol.la -lintl
+ kcontrol_DEPENDENCIES = libkdeinit_kcontrol.la
+
+ #>+ 5
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index baf10175e129..e642612b2a0a 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdelibs3/files/patch-kcmshell-Makefile.in b/x11/kdelibs3/files/patch-kcmshell-Makefile.in
new file mode 100644
index 000000000000..d4142d7fa1e9
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kcmshell-Makefile.in
@@ -0,0 +1,11 @@
+--- kcmshell/Makefile.in.orig Thu Sep 14 05:45:09 2006
++++ kcmshell/Makefile.in Thu Sep 14 05:45:54 2006
+@@ -1033,7 +1033,7 @@
+ echo 'extern "C" int kdemain(int argc, char* argv[]);' >> kcmshell_dummy.cpp; \
+ echo 'extern "C" KDE_EXPORT int kdeinitmain(int argc, char* argv[]) { return kdemain(argc,argv); }' >> kcmshell_dummy.cpp
+ kcmshell_LDFLAGS = $(KDE_RPATH) -no-undefined $(all_libraries)
+-kcmshell_LDADD = libkdeinit_kcmshell.la
++kcmshell_LDADD = libkdeinit_kcmshell.la -lintl
+ kcmshell_DEPENDENCIES = libkdeinit_kcmshell.la
+
+ #>+ 5
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index baf10175e129..e642612b2a0a 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
diff --git a/x11/kdelibs4/files/patch-kcmshell-Makefile.in b/x11/kdelibs4/files/patch-kcmshell-Makefile.in
new file mode 100644
index 000000000000..d4142d7fa1e9
--- /dev/null
+++ b/x11/kdelibs4/files/patch-kcmshell-Makefile.in
@@ -0,0 +1,11 @@
+--- kcmshell/Makefile.in.orig Thu Sep 14 05:45:09 2006
++++ kcmshell/Makefile.in Thu Sep 14 05:45:54 2006
+@@ -1033,7 +1033,7 @@
+ echo 'extern "C" int kdemain(int argc, char* argv[]);' >> kcmshell_dummy.cpp; \
+ echo 'extern "C" KDE_EXPORT int kdeinitmain(int argc, char* argv[]) { return kdemain(argc,argv); }' >> kcmshell_dummy.cpp
+ kcmshell_LDFLAGS = $(KDE_RPATH) -no-undefined $(all_libraries)
+-kcmshell_LDADD = libkdeinit_kcmshell.la
++kcmshell_LDADD = libkdeinit_kcmshell.la -lintl
+ kcmshell_DEPENDENCIES = libkdeinit_kcmshell.la
+
+ #>+ 5