aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2019-01-07 14:41:41 +0800
committerjbeich <jbeich@FreeBSD.org>2019-01-07 14:41:41 +0800
commitca6360a92e945cdeed6529a158124c7966d35733 (patch)
tree2f0f0b8df2c96c4e619746dab51741bc98660a02 /x11
parent9cbcfc49a4c3629f5b589a418af804ab099c6a24 (diff)
downloadfreebsd-ports-gnome-ca6360a92e945cdeed6529a158124c7966d35733.tar.gz
freebsd-ports-gnome-ca6360a92e945cdeed6529a158124c7966d35733.tar.zst
freebsd-ports-gnome-ca6360a92e945cdeed6529a158124c7966d35733.zip
x11-toolkits/wlroots: improve error messages
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xcb-util-errors/Makefile20
-rw-r--r--x11/xcb-util-errors/distinfo3
-rw-r--r--x11/xcb-util-errors/pkg-descr7
-rw-r--r--x11/xcb-util-errors/pkg-plist6
5 files changed, 37 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 3f3a9af842ca..31b9663c775a 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -367,6 +367,7 @@
SUBDIR += xcb-proto
SUBDIR += xcb-util
SUBDIR += xcb-util-cursor
+ SUBDIR += xcb-util-errors
SUBDIR += xcb-util-image
SUBDIR += xcb-util-keysyms
SUBDIR += xcb-util-renderutil
diff --git a/x11/xcb-util-errors/Makefile b/x11/xcb-util-errors/Makefile
new file mode 100644
index 000000000000..97fb276a0f0b
--- /dev/null
+++ b/x11/xcb-util-errors/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= xcb-util-errors
+PORTVERSION= 1.0
+CATEGORIES= x11
+MASTER_SITES= http://xcb.freedesktop.org/dist/
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Pretty-print XCB codes
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= xcb-proto>=1.6:x11/xcb-proto
+
+XORG_CAT= lib
+USE_XORG= xcb
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/x11/xcb-util-errors/distinfo b/x11/xcb-util-errors/distinfo
new file mode 100644
index 000000000000..180b099c39e7
--- /dev/null
+++ b/x11/xcb-util-errors/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1430056740
+SHA256 (xorg/lib/xcb-util-errors-1.0.tar.bz2) = 682681769e818ba085870d1ccd65f1f282ca16ca7d6f0f73ee70bc3642aa1995
+SIZE (xorg/lib/xcb-util-errors-1.0.tar.bz2) = 297943
diff --git a/x11/xcb-util-errors/pkg-descr b/x11/xcb-util-errors/pkg-descr
new file mode 100644
index 000000000000..b5ee702ddcff
--- /dev/null
+++ b/x11/xcb-util-errors/pkg-descr
@@ -0,0 +1,7 @@
+xcb-util-errors is a utility library that gives human readable
+names to error codes and event codes and also to major and minor
+numbers. The necessary information is drawn from xcb-proto's protocol
+descriptions. This library is especially useful when working with
+extensions and is mostly useful for debugging.
+
+WWW: http://xcb.freedesktop.org/
diff --git a/x11/xcb-util-errors/pkg-plist b/x11/xcb-util-errors/pkg-plist
new file mode 100644
index 000000000000..44c3ff5c9e4c
--- /dev/null
+++ b/x11/xcb-util-errors/pkg-plist
@@ -0,0 +1,6 @@
+include/xcb/xcb_errors.h
+lib/libxcb-errors.a
+lib/libxcb-errors.so
+lib/libxcb-errors.so.0
+lib/libxcb-errors.so.0.0.0
+libdata/pkgconfig/xcb-errors.pc