aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2004-12-27 14:15:25 +0800
committerdanfe <danfe@FreeBSD.org>2004-12-27 14:15:25 +0800
commitd5e59a39aead0c9935d6c589017c77e79ca03532 (patch)
treea062839ef211c334b3ee0da34d26f25b66bc79fd /x11
parent094e72fd6e9240dadd9629331d3a6dcd7ceba5b0 (diff)
downloadfreebsd-ports-gnome-d5e59a39aead0c9935d6c589017c77e79ca03532.tar.gz
freebsd-ports-gnome-d5e59a39aead0c9935d6c589017c77e79ca03532.tar.zst
freebsd-ports-gnome-d5e59a39aead0c9935d6c589017c77e79ca03532.zip
Add XCurs, an editor for new, XFree86/XOrg style full-color cursor
properties.
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/xcurs/Makefile40
-rw-r--r--x11/xcurs/distinfo2
-rw-r--r--x11/xcurs/files/patch-gladew.py24
-rw-r--r--x11/xcurs/files/patch-xcurs.py23
-rw-r--r--x11/xcurs/pkg-descr5
-rw-r--r--x11/xcurs/pkg-plist9
7 files changed, 104 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 9193f5598f9f..b3f7aa5a26eb 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -204,6 +204,7 @@
SUBDIR += xcoloredit
SUBDIR += xcolors
SUBDIR += xcolorsel
+ SUBDIR += xcurs
SUBDIR += xcut
SUBDIR += xdialog
SUBDIR += xdtm
diff --git a/x11/xcurs/Makefile b/x11/xcurs/Makefile
new file mode 100644
index 000000000000..c653de00412b
--- /dev/null
+++ b/x11/xcurs/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: XCurs
+# Date created: 27 Dec 2004
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xcurs
+PORTVERSION= 0.5.1
+CATEGORIES= x11 python
+MASTER_SITES= http://varg.dyndns.org/psi/files/xcurs/ \
+ http://freebsd.nsu.ru/distfiles/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= An editor for new XFree86/XOrg style full-color cursors properties
+
+USE_GNOME= pygtk2
+USE_REINPLACE= yes
+USE_PYTHON= yes
+NO_BUILD= yes
+
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,#!/usr/bin/python,#!/usr/bin/env python,g' \
+ ${WRKSRC}/parsexcursor.py ${WRKSRC}/xcurs.py
+ @${REINPLACE_CMD} -e 's,gtk\.mainquit,gtk\.main_quit,' ${WRKSRC}/xcurs.py \
+ ${WRKSRC}/gladew.py ${WRKSRC}/filesel.py
+ @${REINPLACE_CMD} -e 's,gtk\.mainloop,gtk\.main,' ${WRKSRC}/filesel.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/xcurs.py ${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/filesel.py ${WRKSRC}/gladew.py \
+ ${WRKSRC}/parsexcursor.py ${WRKSRC}/xcursorlist.py \
+ ${PREFIX}/lib/${PORTNAME}
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/xcurs.glade ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/x11/xcurs/distinfo b/x11/xcurs/distinfo
new file mode 100644
index 000000000000..4c0e7cdc439e
--- /dev/null
+++ b/x11/xcurs/distinfo
@@ -0,0 +1,2 @@
+MD5 (xcurs-0.5.1.tar.gz) = 64d81c204bf69604a8d881e571dc1d45
+SIZE (xcurs-0.5.1.tar.gz) = 15687
diff --git a/x11/xcurs/files/patch-gladew.py b/x11/xcurs/files/patch-gladew.py
new file mode 100644
index 000000000000..fa2241d7bc5e
--- /dev/null
+++ b/x11/xcurs/files/patch-gladew.py
@@ -0,0 +1,24 @@
+--- gladew.py.orig Mon Dec 27 11:44:55 2004
++++ gladew.py Mon Dec 27 11:44:39 2004
+@@ -2,7 +2,11 @@
+ pygtk.require('2.0')
+ import gtk.glade
+ import gobject
+-import new, types
++import os, sys, new, types
++
++def find_datafile(filename):
++ prefix = os.path.split(os.path.dirname(sys.argv[0]))[0]
++ return os.path.join(prefix, 'share', 'xcurs', filename)
+
+ class GladeWidget:
+ #if we are doing instance counting, this holds the variable
+@@ -13,7 +17,7 @@
+
+ #initialize variables
+ self.autoclose = autoclose
+- self.widgets = gtk.glade.XML(glade_file, widget_name)
++ self.widgets = gtk.glade.XML(find_datafile(glade_file), widget_name)
+ callbacks = {}
+
+ #find and store methods as bound callbacks
diff --git a/x11/xcurs/files/patch-xcurs.py b/x11/xcurs/files/patch-xcurs.py
new file mode 100644
index 000000000000..d101a74e6e07
--- /dev/null
+++ b/x11/xcurs/files/patch-xcurs.py
@@ -0,0 +1,23 @@
+--- xcurs.py.orig Wed Sep 1 03:50:28 2004
++++ xcurs.py Mon Dec 27 11:24:46 2004
+@@ -1,6 +1,10 @@
+ #!/usr/bin/python -OO
+
+-import sys, re
++import os, sys, re
++
++prefix = os.path.split(os.path.dirname(sys.argv[0]))[0]
++sys.path.append(os.path.join(prefix, 'lib', 'xcurs'))
++
+ import pygtk
+ pygtk.require('2.0')
+ import gtk.glade
+@@ -8,7 +12,7 @@
+ import gladew
+ import Image
+
+-import os, new, types
++import new, types
+
+ # for xcurs
+ # import parsexcursor
diff --git a/x11/xcurs/pkg-descr b/x11/xcurs/pkg-descr
new file mode 100644
index 000000000000..f8161b330686
--- /dev/null
+++ b/x11/xcurs/pkg-descr
@@ -0,0 +1,5 @@
+XCurs is a program for editing XCursor formatted XFree86/X.Org mouse cursors.
+This type of format became available as a result of Keith Packard's work on
+XFree86 v4.3.
+
+WWW: http://varg.dyndns.org/psi/pub/code/xcurs/
diff --git a/x11/xcurs/pkg-plist b/x11/xcurs/pkg-plist
new file mode 100644
index 000000000000..4e4c67295bab
--- /dev/null
+++ b/x11/xcurs/pkg-plist
@@ -0,0 +1,9 @@
+bin/xcurs
+lib/xcurs/filesel.py
+lib/xcurs/gladew.py
+lib/xcurs/parsexcursor.py
+lib/xcurs/xcursorlist.py
+@dirrm lib/xcurs
+%%DATADIR%%/README
+%%DATADIR%%/xcurs.glade
+@dirrm %%DATADIR%%