aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-02-06 19:58:33 +0800
committermarino <marino@FreeBSD.org>2015-02-06 19:58:33 +0800
commite64ca194aeb8dc501c303c87af8c91c54ffecb4a (patch)
tree71bb438bf8e937f9632a84bc866f15884b7a1f7f /x11
parent2a38f5fb25f687324c6d3b0a3904d63889647045 (diff)
downloadfreebsd-ports-gnome-e64ca194aeb8dc501c303c87af8c91c54ffecb4a.tar.gz
freebsd-ports-gnome-e64ca194aeb8dc501c303c87af8c91c54ffecb4a.tar.zst
freebsd-ports-gnome-e64ca194aeb8dc501c303c87af8c91c54ffecb4a.zip
x11/dzen2: Upgrade version 0.8.5 => 0.9.5
PR: 195756 Submitted by: maintainer (martin - sugioarto.com) Assisted by: Zsolt Udvari
Diffstat (limited to 'x11')
-rw-r--r--x11/dzen2/Makefile19
-rw-r--r--x11/dzen2/distinfo4
-rw-r--r--x11/dzen2/files/patch-Xft115
-rw-r--r--x11/dzen2/files/patch-gadgets__kittscanner.sh17
-rw-r--r--x11/dzen2/pkg-descr2
5 files changed, 131 insertions, 26 deletions
diff --git a/x11/dzen2/Makefile b/x11/dzen2/Makefile
index f8a3ab74660b..ecad81e13f45 100644
--- a/x11/dzen2/Makefile
+++ b/x11/dzen2/Makefile
@@ -2,20 +2,25 @@
# $FreeBSD$
PORTNAME= dzen2
-PORTVERSION= 0.8.5
-PORTREVISION= 2
+PORTVERSION= 0.9.5
CATEGORIES= x11
-MASTER_SITES= http://gotmor.googlepages.com/
MAINTAINER= udvzsolt@gmail.com
COMMENT= General purpose messaging, notification and menuing program for X11
LICENSE= MIT
+USE_GITHUB= yes
+GH_ACCOUNT= robm
+GH_PROJECT= dzen
+GH_COMMIT= 488ab66
+GH_TAGNAME= 488ab66019
+
+USES= pkgconfig
USE_XORG= x11
-OPTIONS_DEFINE= EXAMPLES GADGETS XPM XINERAMA
-OPTIONS_DEFAULT= XPM XINERAMA
+OPTIONS_DEFINE= EXAMPLES GADGETS XPM XINERAMA XFT
+OPTIONS_DEFAULT= XPM XFT XINERAMA
GADGETS_DESC=Build and install gadgets
OPTIONS_SUB=yes
@@ -29,7 +34,9 @@ XPM_CFLAGS= -DDZEN_XPM
XPM_LDFLAGS= -lXpm
XINERAMA_USE= XORG=xinerama
XINERAMA_LDFLAGS= -lXinerama
-XINERAMA_CLAGS= -DDZEN_XINERAMA
+XINERAMA_CFLAGS= -DDZEN_XINERAMA
+XFT_CFLAGS= -DDZEN_XFT -I${LOCALBASE}/include/freetype2
+XFT_USE= XORG=xft
MAKE_ARGS+= LDFLAGS="${LDFLAGS} \$${LIBS}" \
CFLAGS="${CFLAGS} ${INCS} -DVERSION=\\\"\$${VERSION}\\\""
diff --git a/x11/dzen2/distinfo b/x11/dzen2/distinfo
index a9f65d0d2258..d60c2c30a4b6 100644
--- a/x11/dzen2/distinfo
+++ b/x11/dzen2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dzen2-0.8.5.tar.gz) = 5e4ce96e8ed22a4a0ad6cfafacdde0532d13d049d77744214b196c4b2bcddff9
-SIZE (dzen2-0.8.5.tar.gz) = 33274
+SHA256 (dzen2-0.9.5.tar.gz) = d4f7943cd39dc23fd825eb684b49dc3484860fa8443d30b06ee38af72a53b556
+SIZE (dzen2-0.9.5.tar.gz) = 38178
diff --git a/x11/dzen2/files/patch-Xft b/x11/dzen2/files/patch-Xft
new file mode 100644
index 000000000000..7c5bc78eb1cd
--- /dev/null
+++ b/x11/dzen2/files/patch-Xft
@@ -0,0 +1,115 @@
+--- draw.c.orig 2013-09-23 11:57:39.000000000 +0200
++++ draw.c 2014-12-06 20:30:50.785932524 +0100
+@@ -395,21 +395,20 @@
+ XpmColorSymbol xpms;
+ #endif
+
++ /* icon cache */
++ int ip;
++
+ #ifdef DZEN_XFT
+ XftDraw *xftd=NULL;
+ XftColor xftc;
+ char *xftcs;
+- int xftcs_f=0;
+ char *xftcs_bg;
+- int xftcs_bgf=0;
+
+- xftcs = (char *)dzen.fg;
+- xftcs_bg = (char *)dzen.bg;
++ /* set default fg/bg for XFT */
++ xftcs = estrdup(dzen.fg);
++ xftcs_bg = estrdup(dzen.bg);
+ #endif
+
+- /* icon cache */
+- int ip;
+-
+ /* parse line and return the text without control commands */
+ if(nodraw) {
+ rbuf = emalloc(MAX_LINE_LEN);
+@@ -446,8 +445,7 @@
+ xpms.pixel = dzen.norm[ColBG];
+ #endif
+ #ifdef DZEN_XFT
+- xftcs_bg = (char *)dzen.bg;
+- xftcs_bgf = 0;
++ xftcs_bg = estrdup(dzen.bg);
+ #endif
+ }
+ else {
+@@ -679,15 +677,9 @@
+ case bg:
+ lastbg = tval[0] ? (unsigned)getcolor(tval) : dzen.norm[ColBG];
+ #ifdef DZEN_XFT
+- if(xftcs_bgf) free(xftcs_bg);
+- if(tval[0]) {
+- xftcs_bg = estrdup(tval);
+- xftcs_bgf = 1;
+- } else {
+- xftcs_bg = (char *)dzen.bg;
+- xftcs_bgf = 0;
+- }
+-#endif
++ if(xftcs_bg) free(xftcs_bg);
++ xftcs_bg = estrdup(tval[0] ? tval : dzen.bg);
++#endif
+
+ break;
+
+@@ -695,19 +687,14 @@
+ lastfg = tval[0] ? (unsigned)getcolor(tval) : dzen.norm[ColFG];
+ XSetForeground(dzen.dpy, dzen.tgc, lastfg);
+ #ifdef DZEN_XFT
+- if(tval[0]) {
+- xftcs = estrdup(tval);
+- xftcs_f = 1;
+- } else {
+- xftcs = (char *)dzen.fg;
+- xftcs_f = 0;
+- }
+-#endif
++ if (xftcs) free(xftcs);
++ xftcs = estrdup(tval[0] ? tval : dzen.fg);
++#endif
+ break;
+
+ case fn:
+ if(tval[0]) {
+-#ifndef DZEN_XFT
++#ifndef DZEN_XFT
+ if(!strncmp(tval, "dfnt", 4)) {
+ cur_fnt = &(dzen.fnpl[atoi(tval+4)]);
+
+@@ -816,18 +803,8 @@
+ DefaultColormap(dzen.dpy, dzen.screen), xftcs, &xftc);
+ }
+
+- XftDrawStringUtf8(xftd, &xftc,
++ XftDrawStringUtf8(xftd, &xftc,
+ cur_fnt->xftfont, px, py + dzen.font.xftfont->ascent, (const FcChar8 *)lbuf, strlen(lbuf));
+-
+- if(xftcs_f) {
+- free(xftcs);
+- xftcs_f = 0;
+- }
+- if(xftcs_bgf) {
+- free(xftcs_bg);
+- xftcs_bgf = 0;
+- }
+-
+ #endif
+
+ max_y = MAX(max_y, py+dzen.font.height);
+@@ -920,6 +897,11 @@
+ #endif
+ }
+
++#ifdef DZEN_XFT
++ if(xftcs) free(xftcs);
++ if(xftcs_bg) free(xftcs_bg);
++#endif
++
+ return nodraw ? rbuf : NULL;
+ }
+
diff --git a/x11/dzen2/files/patch-gadgets__kittscanner.sh b/x11/dzen2/files/patch-gadgets__kittscanner.sh
deleted file mode 100644
index 6f53699f2f34..000000000000
--- a/x11/dzen2/files/patch-gadgets__kittscanner.sh
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./gadgets/kittscanner.sh.orig 2014-06-17 15:00:13.000000000 +0200
-+++ ./gadgets/kittscanner.sh 2014-06-17 15:00:24.000000000 +0200
-@@ -19,10 +19,10 @@
-
- SLEEP=0.1
-
--#DZEN=/usr/local/bin/dzen2
--DZEN=../dzen2
--#DZENOPTS="-bg $BG -fg $INACTIVE_LED_COLOR"
--DZENOPTS="-bg $BG -fg $INACTIVE_LED_COLOR -xs 1 -y 30"
-+DZEN=/usr/local/bin/dzen2
-+#DZEN=../dzen2
-+DZENOPTS="-bg $BG -fg $INACTIVE_LED_COLOR"
-+#DZENOPTS="-bg $BG -fg $INACTIVE_LED_COLOR -xs 1 -y 30"
-
- #-----------------------------------------------------------------------
-
diff --git a/x11/dzen2/pkg-descr b/x11/dzen2/pkg-descr
index e6c3203de98d..b27f7d061b69 100644
--- a/x11/dzen2/pkg-descr
+++ b/x11/dzen2/pkg-descr
@@ -3,4 +3,4 @@ for X11. It was desigend to be scriptable in any language and
integrate well with window managers like dwm, wmii and xmonad though
it will work with any windowmanger.
-WWW: http://gotmor.googlepages.com/dzen
+WWW: https://github.com/robm/dzen