aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2004-11-18 20:54:08 +0800
committerbland <bland@FreeBSD.org>2004-11-18 20:54:08 +0800
commitea00ce0e8ed0c269df010bd979cfbb4181e28418 (patch)
tree7ae27ed8870efe536260b91feea8ac9c7ae53935 /x11
parent27ea938adde587b7566e4d837bdc5547a0e02b61 (diff)
downloadfreebsd-ports-gnome-ea00ce0e8ed0c269df010bd979cfbb4181e28418.tar.gz
freebsd-ports-gnome-ea00ce0e8ed0c269df010bd979cfbb4181e28418.tar.zst
freebsd-ports-gnome-ea00ce0e8ed0c269df010bd979cfbb4181e28418.zip
Fix regexps for URL matching.
PR: 74058 SUbmitted by: Jean-Yves Lefort <jylefort@brutele.be>
Diffstat (limited to 'x11')
-rw-r--r--x11/gnome-terminal/Makefile2
-rw-r--r--x11/gnome-terminal/files/patch-src::terminal-screen.c24
-rw-r--r--x11/gnometerminal/Makefile2
-rw-r--r--x11/gnometerminal/files/patch-src::terminal-screen.c24
4 files changed, 50 insertions, 2 deletions
diff --git a/x11/gnome-terminal/Makefile b/x11/gnome-terminal/Makefile
index e03172a93f81..1ea847abe292 100644
--- a/x11/gnome-terminal/Makefile
+++ b/x11/gnome-terminal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnometerminal
PORTVERSION= 2.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-terminal/2.8
diff --git a/x11/gnome-terminal/files/patch-src::terminal-screen.c b/x11/gnome-terminal/files/patch-src::terminal-screen.c
new file mode 100644
index 000000000000..aafbb3a44ce0
--- /dev/null
+++ b/x11/gnome-terminal/files/patch-src::terminal-screen.c
@@ -0,0 +1,24 @@
+--- src/terminal-screen.c.orig Thu Nov 18 12:45:11 2004
++++ src/terminal-screen.c Thu Nov 18 12:46:31 2004
+@@ -246,16 +246,16 @@
+ #define USER "[" USERCHARS "]+(:["PASSCHARS "]+)?"
+
+ terminal_widget_match_add (screen->priv->term,
+- "\\<(" SCHEME "://(" USER "@)?)[" HOSTCHARS ".]+(:[0-9]+)?"
+- "(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) \t\r\n,\\\"])?\\>", FLAVOR_AS_IS);
++ "[[:<:]](" SCHEME "://(" USER "@)?)[" HOSTCHARS ".]+(:[0-9]+)?"
++ "(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) \t\r\n,\\\"])?[[:>:]]", FLAVOR_AS_IS);
+
+ terminal_widget_match_add (screen->priv->term,
+- "\\<(www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+(:[0-9]+)?"
+- "(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) \t\r\n,\\\"])?\\>", FLAVOR_DEFAULT_TO_HTTP);
++ "[[:<:]](www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+(:[0-9]+)?"
++ "(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) \t\r\n,\\\"])?[[:>:]]", FLAVOR_DEFAULT_TO_HTTP);
+
+ terminal_widget_match_add (screen->priv->term,
+
+- "\\<(mailto:)?[a-z0-9]+@[a-z0-9][a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+\\>", FLAVOR_MAILTO);
++ "[[:<:]](mailto:)?[a-z0-9]+@[a-z0-9][a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+[[:>:]]", FLAVOR_MAILTO);
+
+ terminal_screen_setup_dnd (screen);
+
diff --git a/x11/gnometerminal/Makefile b/x11/gnometerminal/Makefile
index e03172a93f81..1ea847abe292 100644
--- a/x11/gnometerminal/Makefile
+++ b/x11/gnometerminal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnometerminal
PORTVERSION= 2.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-terminal/2.8
diff --git a/x11/gnometerminal/files/patch-src::terminal-screen.c b/x11/gnometerminal/files/patch-src::terminal-screen.c
new file mode 100644
index 000000000000..aafbb3a44ce0
--- /dev/null
+++ b/x11/gnometerminal/files/patch-src::terminal-screen.c
@@ -0,0 +1,24 @@
+--- src/terminal-screen.c.orig Thu Nov 18 12:45:11 2004
++++ src/terminal-screen.c Thu Nov 18 12:46:31 2004
+@@ -246,16 +246,16 @@
+ #define USER "[" USERCHARS "]+(:["PASSCHARS "]+)?"
+
+ terminal_widget_match_add (screen->priv->term,
+- "\\<(" SCHEME "://(" USER "@)?)[" HOSTCHARS ".]+(:[0-9]+)?"
+- "(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) \t\r\n,\\\"])?\\>", FLAVOR_AS_IS);
++ "[[:<:]](" SCHEME "://(" USER "@)?)[" HOSTCHARS ".]+(:[0-9]+)?"
++ "(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) \t\r\n,\\\"])?[[:>:]]", FLAVOR_AS_IS);
+
+ terminal_widget_match_add (screen->priv->term,
+- "\\<(www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+(:[0-9]+)?"
+- "(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) \t\r\n,\\\"])?\\>", FLAVOR_DEFAULT_TO_HTTP);
++ "[[:<:]](www|ftp)[" HOSTCHARS "]*\\.[" HOSTCHARS ".]+(:[0-9]+)?"
++ "(/[-A-Za-z0-9_$.+!*(),;:@&=?/~#%]*[^]'.}>) \t\r\n,\\\"])?[[:>:]]", FLAVOR_DEFAULT_TO_HTTP);
+
+ terminal_widget_match_add (screen->priv->term,
+
+- "\\<(mailto:)?[a-z0-9]+@[a-z0-9][a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+\\>", FLAVOR_MAILTO);
++ "[[:<:]](mailto:)?[a-z0-9]+@[a-z0-9][a-z0-9-]*(\\.[a-z0-9][a-z0-9-]*)+[[:>:]]", FLAVOR_MAILTO);
+
+ terminal_screen_setup_dnd (screen);
+