aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2003-12-21 11:39:32 +0800
committerbland <bland@FreeBSD.org>2003-12-21 11:39:32 +0800
commitebbc59b489889beb51b6f71cd6b3b03dcd3333d0 (patch)
tree4be841f277408e48509222284d26c2892db95d1c /x11
parentcba895d6717bba2a3bcca94ec5c84b4bedb81ca1 (diff)
downloadfreebsd-ports-gnome-ebbc59b489889beb51b6f71cd6b3b03dcd3333d0.tar.gz
freebsd-ports-gnome-ebbc59b489889beb51b6f71cd6b3b03dcd3333d0.tar.zst
freebsd-ports-gnome-ebbc59b489889beb51b6f71cd6b3b03dcd3333d0.zip
Make buildable on -CURRENT.
Approved by: maintainer
Diffstat (limited to 'x11')
-rw-r--r--x11/gmrun/Makefile6
-rw-r--r--x11/gmrun/files/patch-src::gtkcompletionline.cc11
2 files changed, 13 insertions, 4 deletions
diff --git a/x11/gmrun/Makefile b/x11/gmrun/Makefile
index dbaf10d3743f..fdd3b1d98aa0 100644
--- a/x11/gmrun/Makefile
+++ b/x11/gmrun/Makefile
@@ -14,8 +14,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= adamw@FreeBSD.org
COMMENT= A customizable program to run programs, with tab-completion
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
-
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -23,8 +21,8 @@ USE_GNOME= gnomeprefix gnomehack gtk20
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
+.if ${OSVERSION} < 500000
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
.endif
post-install:
diff --git a/x11/gmrun/files/patch-src::gtkcompletionline.cc b/x11/gmrun/files/patch-src::gtkcompletionline.cc
new file mode 100644
index 000000000000..aca565accc3c
--- /dev/null
+++ b/x11/gmrun/files/patch-src::gtkcompletionline.cc
@@ -0,0 +1,11 @@
+--- src/gtkcompletionline.cc Thu Dec 18 14:47:42 2003
++++ src/gtkcompletionline.cc.orig Thu Dec 18 14:50:30 2003
+@@ -348,7 +348,7 @@
+ }
+
+ static int
+-select_executables_only(const struct dirent* dent)
++select_executables_only(struct dirent* dent)
+ {
+ int len = strlen(dent->d_name);
+ int lenp = prefix.length();