aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2019-01-17 21:53:43 +0800
committerdanfe <danfe@FreeBSD.org>2019-01-17 21:53:43 +0800
commitf00aa0d930420f6a73b732151bdb0be37b57c707 (patch)
tree8c4ee2d51c2cca0aad5eb3deb2e5b08d26b5ea0b /x11
parent1145095c4641e560ec0a73bd4b4c46b0ae366161 (diff)
downloadfreebsd-ports-gnome-f00aa0d930420f6a73b732151bdb0be37b57c707.tar.gz
freebsd-ports-gnome-f00aa0d930420f6a73b732151bdb0be37b57c707.tar.zst
freebsd-ports-gnome-f00aa0d930420f6a73b732151bdb0be37b57c707.zip
Unbreak the build against modern compilers caused by some sloppy C++ coding.
Diffstat (limited to 'x11')
-rw-r--r--x11/metisse/Makefile8
-rw-r--r--x11/metisse/files/patch-FvwmCompositor_main_AScreen.cxx11
2 files changed, 16 insertions, 3 deletions
diff --git a/x11/metisse/Makefile b/x11/metisse/Makefile
index 257d5d545093..01ddfb1dfb7a 100644
--- a/x11/metisse/Makefile
+++ b/x11/metisse/Makefile
@@ -13,8 +13,6 @@ COMMENT= Innovative X-based window system
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= fails to build
-
LIB_DEPENDS= libNucleo.so:x11-toolkits/nucleo \
libpng.so:graphics/png
RUN_DEPENDS= xorg-fonts>0:x11-fonts/xorg-fonts
@@ -75,6 +73,12 @@ GTK2_USE= GNOME=gtk20
GCONF_USE= GNOME=gconf2,libglade2
post-patch:
+ @${REINPLACE_CMD} -e '/foldable/s,false),0x0),' \
+ ${WRKSRC}/FvwmCompositor/desktop/MetisseDesktop.cxx
+ @${REINPLACE_CMD} -e '1296s,opt ==,*&,' \
+ ${WRKSRC}/FvwmCompositor/fvwmmodule/FvwmModule.cxx
+ @${REINPLACE_CMD} -e 's,1<<31,1l<<31,' \
+ ${WRKSRC}/fvwm-insitu/libs/Module.h
# Catch up with new <fribidi-types.h> header name
@${REINPLACE_CMD} -e 's,fribidi_types\.h,fribidi-types.h,' \
${WRKSRC}/fvwm-insitu/libs/FBidi.c
diff --git a/x11/metisse/files/patch-FvwmCompositor_main_AScreen.cxx b/x11/metisse/files/patch-FvwmCompositor_main_AScreen.cxx
index dc9366d5ab05..7dc2bacb8d05 100644
--- a/x11/metisse/files/patch-FvwmCompositor_main_AScreen.cxx
+++ b/x11/metisse/files/patch-FvwmCompositor_main_AScreen.cxx
@@ -1,4 +1,4 @@
---- FvwmCompositor/main/AScreen.cxx.orig 2008-11-25 10:22:45.000000000 +0000
+--- FvwmCompositor/main/AScreen.cxx.orig 2008-11-25 10:22:45 UTC
+++ FvwmCompositor/main/AScreen.cxx
@@ -10,6 +10,7 @@
*
@@ -8,3 +8,12 @@
#ifdef HAVE_CONFIG_H
#include "config-not-xserver.h"
#endif
+@@ -5159,7 +5160,7 @@ AScreen::AScreen(MetisseDesktop *metisseDesktop, bool
+ _clipOpWaitForCtrlReleased = false;
+ _clipAutoRepeatOff = false;
+ _miIn = false;
+- _motionInterceptTk = false;
++ _motionInterceptTk = 0;
+ _miTkcount = 0;
+ _miFeed = 0;
+ _setupRightLongPressTimeOut();