aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2005-11-04 19:02:02 +0800
committernovel <novel@FreeBSD.org>2005-11-04 19:02:02 +0800
commitf2f77bb497ac7ff9a73e66a7ad91877db32a3806 (patch)
tree95f035b0c301373d3ebffb4528ac5c941201e6c9 /x11
parentac20d8ef01b0271e7cfb727834d6d056ece4c541 (diff)
downloadfreebsd-ports-gnome-f2f77bb497ac7ff9a73e66a7ad91877db32a3806.tar.gz
freebsd-ports-gnome-f2f77bb497ac7ff9a73e66a7ad91877db32a3806.tar.zst
freebsd-ports-gnome-f2f77bb497ac7ff9a73e66a7ad91877db32a3806.zip
Use getopt_long() when getopt_long_only() is not avaible.
Reported by: pointyhat via kris
Diffstat (limited to 'x11')
-rw-r--r--x11/xidle/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11/xidle/Makefile b/x11/xidle/Makefile
index 2a336947991a..c3486cb5bc59 100644
--- a/x11/xidle/Makefile
+++ b/x11/xidle/Makefile
@@ -24,8 +24,17 @@ MAKE_ARGS+= X11LIBDIR="${X11BASE}/lib" \
PLIST_FILES= bin/xidle
MAN1= xidle.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 502104
+USE_REINPLACE= yes
+
+post-extract:
+ @${REINPLACE_CMD} -e 's|getopt_long_only|getopt_long|' ${WRKSRC}/xidle.c
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xidle ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xidle.1 ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>