aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2012-07-07 20:40:27 +0800
committeravilla <avilla@FreeBSD.org>2012-07-07 20:40:27 +0800
commitf742a229880f5612163f102fefdf4278d88b32b3 (patch)
treeaf50245b79590533f2b43dd0ae24d78838868198 /x11
parent119d18d8b4508e5a371071435ef6b04a200b5835 (diff)
downloadfreebsd-ports-gnome-f742a229880f5612163f102fefdf4278d88b32b3.tar.gz
freebsd-ports-gnome-f742a229880f5612163f102fefdf4278d88b32b3.tar.zst
freebsd-ports-gnome-f742a229880f5612163f102fefdf4278d88b32b3.zip
- Import my upstream commit to fix conflict with x11/kdelibs3.
Diffstat (limited to 'x11')
-rw-r--r--x11/kactivities/files/patch-git_2d114b630
1 files changed, 30 insertions, 0 deletions
diff --git a/x11/kactivities/files/patch-git_2d114b6 b/x11/kactivities/files/patch-git_2d114b6
new file mode 100644
index 000000000000..2d9364848ee3
--- /dev/null
+++ b/x11/kactivities/files/patch-git_2d114b6
@@ -0,0 +1,30 @@
+From: Alberto Villa <avilla@FreeBSD.org>
+Date: Sat, 07 Jul 2012 11:31:28 +0000
+Subject: Make Nepomuk code rely on NEPOMUK_INCLUDE_DIRS
+X-Git-Url: http://quickgit.kde.org/?p=kactivities.git&amp;a=commitdiff&amp;h=2d114b655547ba26254983c1b7f48f8eea058b43
+---
+Make Nepomuk code rely on NEPOMUK_INCLUDE_DIRS
+
+Including only SOPRANO_INCLUDE_DIR made the build pick up KDE 3
+headers on FreeBSD, where KDE SC 4 is installed in non-default prefix
+(while Soprano and KDE 3 aren't). NEPOMUK_INCLUDE_DIRS ensures that
+KDE include directories come first in the inclusion order.
+Additionally, it's better to rely on FindNepomuk.cmake to set the
+correct include directories, instead of adding the Soprano one by hand.
+
+This is a backport of commit edbbe3e115b0a4806873969c808383b2926ec581.
+---
+
+
+--- ./service/CMakeLists.txt
++++ ./service/CMakeLists.txt
+@@ -31,7 +31,7 @@
+
+ if(Nepomuk_FOUND)
+ set(HAVE_NEPOMUK 1)
+- include_directories(${SOPRANO_INCLUDE_DIR})
++ include_directories(${NEPOMUK_INCLUDE_DIRS})
+ set(ADDITIONAL_LINK_LIBS
+ ${ADDITIONAL_LINK_LIBS}
+ ${NEPOMUK_LIBRARIES}
+