aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-04-15 16:20:27 +0800
committertijl <tijl@FreeBSD.org>2015-04-15 16:20:27 +0800
commitff176a3eb176ed56a19a9ec55117606d2c0c34a4 (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /x11
parentf04a4518f0a5a0ff6bd706dc17a0016965d1ee39 (diff)
downloadfreebsd-ports-gnome-ff176a3eb176ed56a19a9ec55117606d2c0c34a4.tar.gz
freebsd-ports-gnome-ff176a3eb176ed56a19a9ec55117606d2c0c34a4.tar.zst
freebsd-ports-gnome-ff176a3eb176ed56a19a9ec55117606d2c0c34a4.zip
converters/libiconv:
- Remove const qualifier from iconv(3) to match POSIX: http://pubs.opengroup.org/onlinepubs/9699919799/functions/iconv.html - Patch iconv.h to expose more GNU extensions when LIBICONV_PLUG is defined because the base system iconv supports these extensions too. Add/remove patches to/from ports to call iconv with non-const arguments. This breaks some ports on FreeBSD 10 because base system iconv.h still has the const qualifier. Fix this by letting USES=iconv add a build dependency on converters/libiconv so ports can use its iconv.h (with LIBICONV_PLUG defined) instead of the base system iconv.h. This exposed some ports that link with libiconv when it is available instead of using libc iconv. In these cases one of the following changes has been made: - patch configure scripts to test for libc iconv first - add ac_cv_lib_iconv_libiconv=no or similar to CONFIGURE_ARGS to disable some configure tests - converters/wkhtmltopdf: this includes Qt4 so add a patch from devel/qt4 - lang/gcc5-aux: respect CFLAGS and friends during configure such that LIBICONV_PLUG is defined in the iconv test, also switch to external gettext - mail/gnarwl: replace patches with CPPFLAGS/LIBS - multimedia/ffmpeg2theora: remove iconv test from SConstruct and use ICONV_LIB in port Makefile instead, also fix a bug in subtitles.c - net-im/licq: finish conversion to cmake - net-mgmt/bandwidthd, net-mgmt/icinga, net-mgmt/nagios, net-mgmt/nagios4: don't need iconv - textproc/p5-XML-TinyXML: finish conversion to USES=perl5 Other changes: - databases/qdbm and slaves: respect CFLAGS and friends, also enable bzip2 and lzo support - games/ldmud: respect CFLAGS and friends - graphics/inventor: replace some patches with MAKE_ARGS/MAKE_ENV to respect CFLAGS and friends, also remove FreeBSD/alpha patch and add missing xorg dependencies PR: 199099 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'x11')
-rw-r--r--x11/x3270/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/x11/x3270/Makefile b/x11/x3270/Makefile
index a539fc7e3d75..01cbd5b87b46 100644
--- a/x11/x3270/Makefile
+++ b/x11/x3270/Makefile
@@ -3,7 +3,7 @@
PORTNAME= x3270
PORTVERSION= 3.3.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11 net
MASTER_SITES= http://x3270.bgp.nu/download/current/
EXTRACT_SUFX= ga7-src.tgz
@@ -21,8 +21,9 @@ CONFLICTS= c3270-*
USES= iconv fonts imake:env
USE_XORG= ice sm x11 xaw xext xmu xt
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-fontdir=${FONTSDIR} \
- --disable-dbcs
+CONFIGURE_ARGS= --with-fontdir=${FONTSDIR} \
+ --disable-dbcs \
+ ac_cv_search_libiconv=no
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
.if defined(WITHOUT_OPENSSL)