aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--security/xinetd/Makefile2
-rw-r--r--security/xinetd/files/patch-xinetd_child.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/security/xinetd/Makefile b/security/xinetd/Makefile
index 097e9a9a85cc..6728596e7bb9 100644
--- a/security/xinetd/Makefile
+++ b/security/xinetd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xinetd
PORTVERSION= 2.3.15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= GENTOO
diff --git a/security/xinetd/files/patch-xinetd_child.c b/security/xinetd/files/patch-xinetd_child.c
new file mode 100644
index 000000000000..6ddbf9125988
--- /dev/null
+++ b/security/xinetd/files/patch-xinetd_child.c
@@ -0,0 +1,24 @@
+--- xinetd/child.c.orig 2016-07-13 19:00:31 UTC
++++ xinetd/child.c
+@@ -168,7 +168,8 @@ void exec_server( const struct server *s
+ }
+ #endif
+
+- (void) Sclose( descriptor ) ;
++ if ( descriptor > MAX_PASS_FD )
++ (void) Sclose( descriptor ) ;
+
+ #ifndef solaris
+ #if !defined(HAVE_SETSID)
+@@ -321,11 +322,6 @@ void child_process( struct server *serp
+ signals_pending[0] = -1;
+ signals_pending[1] = -1;
+
+- Sclose(0);
+- Sclose(1);
+- Sclose(2);
+-
+-
+ #ifdef DEBUG_SERVER
+ if ( debug.on )
+ {