aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/mame-devel/Makefile11
-rw-r--r--emulators/mame/Makefile11
-rw-r--r--emulators/sdlmame-devel/Makefile11
-rw-r--r--emulators/sdlmame/Makefile11
4 files changed, 40 insertions, 4 deletions
diff --git a/emulators/mame-devel/Makefile b/emulators/mame-devel/Makefile
index e533322fe0ee..d6a571494c1d 100644
--- a/emulators/mame-devel/Makefile
+++ b/emulators/mame-devel/Makefile
@@ -43,4 +43,13 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# In FreeBSD 5.x fails to build due to an internal compiler error. Using the
+# version 3.4 from ports which probably fixes this error requires a hack to
+# get around bsd.gcc.mk handling, so use a higher version than in base system.
+.if ${OSVERSION} < 600000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index e533322fe0ee..d6a571494c1d 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -43,4 +43,13 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# In FreeBSD 5.x fails to build due to an internal compiler error. Using the
+# version 3.4 from ports which probably fixes this error requires a hack to
+# get around bsd.gcc.mk handling, so use a higher version than in base system.
+.if ${OSVERSION} < 600000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/sdlmame-devel/Makefile b/emulators/sdlmame-devel/Makefile
index e533322fe0ee..d6a571494c1d 100644
--- a/emulators/sdlmame-devel/Makefile
+++ b/emulators/sdlmame-devel/Makefile
@@ -43,4 +43,13 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# In FreeBSD 5.x fails to build due to an internal compiler error. Using the
+# version 3.4 from ports which probably fixes this error requires a hack to
+# get around bsd.gcc.mk handling, so use a higher version than in base system.
+.if ${OSVERSION} < 600000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/sdlmame/Makefile b/emulators/sdlmame/Makefile
index e533322fe0ee..d6a571494c1d 100644
--- a/emulators/sdlmame/Makefile
+++ b/emulators/sdlmame/Makefile
@@ -43,4 +43,13 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# In FreeBSD 5.x fails to build due to an internal compiler error. Using the
+# version 3.4 from ports which probably fixes this error requires a hack to
+# get around bsd.gcc.mk handling, so use a higher version than in base system.
+.if ${OSVERSION} < 600000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>