aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--mail/Makefile1
-rw-r--r--mail/greylite/Makefile64
-rw-r--r--mail/greylite/distinfo2
-rw-r--r--mail/greylite/files/pkg-message.in5
-rw-r--r--mail/greylite/pkg-descr14
6 files changed, 86 insertions, 1 deletions
diff --git a/MOVED b/MOVED
index e28cf497fc49..c30f9843f322 100644
--- a/MOVED
+++ b/MOVED
@@ -6656,7 +6656,6 @@ mail/ezmlm-web||2014-09-01|Not staged
mail/firemime||2014-09-01|Not staged
mail/firepay||2014-09-01|Not staged
mail/ftrack||2014-09-01|Not staged
-mail/greylite||2014-09-01|Not staged
mail/ilohamail||2014-09-01|Not staged
mail/majordomo||2014-09-01|Not staged
mail/p3scan||2014-09-01|Not staged
diff --git a/mail/Makefile b/mail/Makefile
index 6c70dedbdc19..e0f6a1e5fb08 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -159,6 +159,7 @@
SUBDIR += gotmail
SUBDIR += grepmail
SUBDIR += greyfix
+ SUBDIR += greylite
SUBDIR += gubby
SUBDIR += hashcash
SUBDIR += hbiff
diff --git a/mail/greylite/Makefile b/mail/greylite/Makefile
new file mode 100644
index 000000000000..85e35ca9ba37
--- /dev/null
+++ b/mail/greylite/Makefile
@@ -0,0 +1,64 @@
+# Created by: Mij <mij@bitchx.it>
+# $FreeBSD$
+
+PORTNAME= greylite
+PORTVERSION= 2.3
+PORTREVISION= 4
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= oliver
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= Modified greylisting for qmail and for any other MDA
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
+
+USES= tar:bzip2
+USE_SQLITE= 3
+PLIST_FILES= bin/greylite \
+ %%DNSBLENV%%bin/dnsblenv \
+ %%UCSPI2SOCKET%%bin/ucspi2socket \
+ man/man8/greylite.8.gz
+
+MANCOMPRESSED= yes
+SUB_FILES= pkg-message
+
+OPTIONS_DEFINE= GEOIP DNSBLENV UCSPI2SOCKET
+OPTIONS_DEFAULT= GEOIP DNSBLENV UCSPI2SOCKET
+GEOIP_DESC= Support for GeoIP in suspicion rules
+DNSBLENV_DESC= Module for interfacing with DNS blacklists
+UCSPI2SOCKET_DESC= Module for using greylite as SMTP proxy
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MGEOIP}
+LIB_DEPENDS+= libGeoIP.so:${PORTSDIR}/net/GeoIP
+MAKE_ARGS+= WITH_GEOIP=yep
+.endif
+
+.if ${PORT_OPTIONS:MDNSBLENV}
+LIB_DEPENDS+= libcares.so:${PORTSDIR}/dns/c-ares
+MAKE_ARGS+= WITH_DNSBLENV=yep
+PLIST_SUB+= DNSBLENV=""
+.else
+PLIST_SUB+= DNSBLENV="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MUCSPI2SOCKET}
+MAKE_ARGS+= WITH_UCSPI2SOCKET=yep
+PLIST_SUB+= UCSPI2SOCKET=""
+.else
+PLIST_SUB+= UCSPI2SOCKET="@comment "
+.endif
+
+post-patch:
+ ${CP} ${WRKSRC}/Makefile.bsdmake ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e 's|PREFIX\?=.*|PREFIX=${STAGEDIR}${PREFIX}|g' \
+ ${WRKSRC}/Makefile
+
+do-build:
+ ${MAKE} -C ${WRKSRC} ${MAKE_ARGS}
+
+.include <bsd.port.post.mk>
diff --git a/mail/greylite/distinfo b/mail/greylite/distinfo
new file mode 100644
index 000000000000..0af5a4ef2f09
--- /dev/null
+++ b/mail/greylite/distinfo
@@ -0,0 +1,2 @@
+SHA256 (greylite-2.3.tar.bz2) = db676e2511ff42ad9ba2201be55df10e89b19bbc225ce523fa218d4e542c16db
+SIZE (greylite-2.3.tar.bz2) = 20663
diff --git a/mail/greylite/files/pkg-message.in b/mail/greylite/files/pkg-message.in
new file mode 100644
index 000000000000..0d76c900a170
--- /dev/null
+++ b/mail/greylite/files/pkg-message.in
@@ -0,0 +1,5 @@
+################################################################
+Greylite has been installed. Some steps are required for setting
+it up with qmail. greylite(8) has a synthesis and the website at
+http://mij.oltrelinux.com/net/greylite/ has more information.
+################################################################
diff --git a/mail/greylite/pkg-descr b/mail/greylite/pkg-descr
new file mode 100644
index 000000000000..258a650c7dce
--- /dev/null
+++ b/mail/greylite/pkg-descr
@@ -0,0 +1,14 @@
+Greylite is a SPAM filter with exceptional effectiveness and without false
+positives. It combines natively with qmail and works as a proxy for any SMTP
+server.
+
+It implements a modified greylisting algorithm that improves the filtering
+effectiveness and minimizes the delay drawbacks associated with the standard
+greylisting algorithm.
+
+It can be tuned to recognize suspicious clients and reject their attempts
+multiple times, reaching filtering rates of over 99% without false positives.
+
+Greylite is easy to setup and maintain, and it is small and fast.
+
+WWW: http://mij.oltrelinux.com/net/greylite/