aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pecl-imagick/Makefile26
-rw-r--r--graphics/pecl-imagick/distinfo3
-rw-r--r--graphics/pecl-imagick/pkg-descr3
4 files changed, 33 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 0f122beecb41..45ad3a19ed1f 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -507,6 +507,7 @@
SUBDIR += pear-Image_Canvas
SUBDIR += pear-Image_Color
SUBDIR += pear-Image_Graph
+ SUBDIR += pecl-imagick
SUBDIR += pecl-imlib2
SUBDIR += pecomato
SUBDIR += peps
diff --git a/graphics/pecl-imagick/Makefile b/graphics/pecl-imagick/Makefile
new file mode 100644
index 000000000000..396ec427f98e
--- /dev/null
+++ b/graphics/pecl-imagick/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pecl-imagick
+# Date created: 13 Apr 2007
+# Whom: Andrey Slusar <anray@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= imagick
+PORTVERSION= 0.9.13
+CATEGORIES= graphics
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= anray@FreeBSD.org
+COMMENT= Provides a wrapper to the ImageMagick/GraphicsMagick library
+
+LIB_DEPENDS= Magick.10:${PORTSDIR}/graphics/ImageMagick
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --with-imagick=${LOCALBASE}
+
+.include <bsd.port.mk>
diff --git a/graphics/pecl-imagick/distinfo b/graphics/pecl-imagick/distinfo
new file mode 100644
index 000000000000..8b2e719012fe
--- /dev/null
+++ b/graphics/pecl-imagick/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/imagick-0.9.13.tgz) = d0e7b6c206b8f174de5f9d300c2fe8dd
+SHA256 (PECL/imagick-0.9.13.tgz) = 968912a49ecebfe0c819121cfd1f589e6e1b93000440aea1b61afb4212f43ac5
+SIZE (PECL/imagick-0.9.13.tgz) = 71869
diff --git a/graphics/pecl-imagick/pkg-descr b/graphics/pecl-imagick/pkg-descr
new file mode 100644
index 000000000000..3be2ebfe695f
--- /dev/null
+++ b/graphics/pecl-imagick/pkg-descr
@@ -0,0 +1,3 @@
+Provides a wrapper to the ImageMagick/GraphicsMagick library.
+
+WWW: http://pecl.php.net/package/imagick/