aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/fb-adb/Makefile10
-rw-r--r--graphics/sekrit-twc-zimg/Makefile11
-rw-r--r--multimedia/vapoursynth/Makefile8
3 files changed, 9 insertions, 20 deletions
diff --git a/devel/fb-adb/Makefile b/devel/fb-adb/Makefile
index 39cf68cdfd0d..77a414dbb27d 100644
--- a/devel/fb-adb/Makefile
+++ b/devel/fb-adb/Makefile
@@ -11,8 +11,6 @@ COMMENT= Better shell for Android devices
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= Does not build
-
BUILD_DEPENDS= xxd:editors/vim-lite \
${BASH_CMD}:shells/${BASH_CMD:T}
RUN_DEPENDS= adb:devel/android-tools-adb
@@ -39,11 +37,9 @@ CONFIGURE_ENV+= HOST_CFLAGS="${CPPFLAGS} ${CFLAGS:N-[Og]*:N-pipe}" \
STUB_LDFLAGS="${STUB_LDFLAGS}" \
LDFLAGS="" LIBS=""
-OPTIONS_DEFINE= ASSERT BASH DEBUG
-OPTIONS_DEFINE_amd64= NDK
-OPTIONS_DEFINE_i386= NDK
-OPTIONS_DEFAULT_amd64= NDK
-OPTIONS_DEFAULT_i386= NDK
+OPTIONS_DEFINE= ASSERT BASH DEBUG NDK
+OPTIONS_DEFAULT=NDK
+OPTIONS_EXCLUDE=${ARCH:Namd64:Ni386:C/.+/NDK/}
OPTIONS_EXCLUDE_DragonFly=NDK
ASSERT_CONFIGURE_ENABLE=checking
diff --git a/graphics/sekrit-twc-zimg/Makefile b/graphics/sekrit-twc-zimg/Makefile
index 3abbdd623036..a522929d89e1 100644
--- a/graphics/sekrit-twc-zimg/Makefile
+++ b/graphics/sekrit-twc-zimg/Makefile
@@ -14,8 +14,6 @@ LICENSE_NAME= Do What The Fuck You Want To Public License version 2
LICENSE_FILE= ${WRKSRC}/COPYING
LICENSE_PERMS= ${_LICENSE_PERMS_DEFAULT}
-BROKEN_powerpc64= Does not build
-
USE_GITHUB= yes
GH_ACCOUNT= sekrit-twc
@@ -31,12 +29,9 @@ CPPFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-OPTIONS_DEFINE= TEST
-
-OPTIONS_DEFINE_amd64= SIMD
-OPTIONS_DEFINE_i386= SIMD
-OPTIONS_DEFAULT_amd64= SIMD
-OPTIONS_DEFAULT_i386= SIMD # runtime detection
+OPTIONS_DEFINE= SIMD TEST
+OPTIONS_DEFAULT=SIMD
+OPTIONS_EXCLUDE=${ARCH:Namd64:Ni386:C/.+/SIMD/}
SIMD_CONFIGURE_ENABLE= x86simd
diff --git a/multimedia/vapoursynth/Makefile b/multimedia/vapoursynth/Makefile
index de65133f91ac..53e53d4fd06a 100644
--- a/multimedia/vapoursynth/Makefile
+++ b/multimedia/vapoursynth/Makefile
@@ -20,13 +20,11 @@ INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
DATADIR= ${PREFIX}/lib/vapoursynth
-OPTIONS_DEFINE= DEBUG DOCS FRAME_GUARD
+OPTIONS_DEFINE= DEBUG DOCS FRAME_GUARD SIMD
OPTIONS_DEFAULT=${OPTIONS_GROUP_COMPS} ${OPTIONS_GROUP_PLUGINS}
-OPTIONS_SUB= yes
-
-OPTIONS_DEFINE_amd64= SIMD
-OPTIONS_DEFINE_i386= SIMD
OPTIONS_DEFAULT_amd64= SIMD
+OPTIONS_EXCLUDE=${ARCH:Namd64:Ni386:C/.+/SIMD/}
+OPTIONS_SUB= yes
OPTIONS_GROUP= COMPS PLUGINS
COMPS_DESC= Components