aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/sip_scenario/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net/sip_scenario/Makefile b/net/sip_scenario/Makefile
index b960c143711e..7f896c4a4c48 100644
--- a/net/sip_scenario/Makefile
+++ b/net/sip_scenario/Makefile
@@ -12,8 +12,9 @@ COMMENT= SIP call flow creator (HTML format)
LICENSE= APACHE20
-USES= perl5 zip
+USES= perl5 zip shebangfix
USE_PERL5= run
+NO_BUILD= yes
WRKSRC= ${WRKDIR}
@@ -23,12 +24,10 @@ WRKSRC= ${WRKDIR}
# http://www.abptech.com/support/resources/SIP_scen_generator_v1.2.7/index/SipScenarioPart2.pdf
# download them and install them in /usr/local/share/doc/sip_scenario/
+SHEBANG_FILES= sip_scenario.pl
PLIST_FILES= bin/sip_scenario.pl
-NO_BUILD= yes
-NO_STAGE= yes
do-install:
- ${SED} -i -e '1s/local\///' ${WRKSRC}/sip_scenario.pl
- ${INSTALL_SCRIPT} ${WRKSRC}/sip_scenario.pl ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/sip_scenario.pl ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>