aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/wmwork/Makefile6
-rw-r--r--misc/wmwork/files/patch-wmwork.c23
2 files changed, 27 insertions, 2 deletions
diff --git a/misc/wmwork/Makefile b/misc/wmwork/Makefile
index 21332839dc7e..b4f2183b4ce9 100644
--- a/misc/wmwork/Makefile
+++ b/misc/wmwork/Makefile
@@ -7,9 +7,11 @@
PORTNAME= wmwork
PORTVERSION= 0.2.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc windowmaker afterstep
-MASTER_SITES= http://www.godisch.de/debian/wmwork/
+MASTER_SITES= http://people.debian.org/~godisch/wmwork/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= xride
MAINTAINER= xride@FreeBSD.org
COMMENT= A dockapp that keeps track of time you have spent on something
diff --git a/misc/wmwork/files/patch-wmwork.c b/misc/wmwork/files/patch-wmwork.c
new file mode 100644
index 000000000000..3dbf7a64a142
--- /dev/null
+++ b/misc/wmwork/files/patch-wmwork.c
@@ -0,0 +1,23 @@
+--- wmwork.c.orig 2009-02-26 07:19:00.000000000 +0100
++++ wmwork.c 2009-02-26 07:22:35.000000000 +0100
+@@ -590,9 +590,9 @@
+ p = first;
+ do {
+ if (F == stderr)
+- fprintf(F, "%s: > %s:%li:%s\n", PACKAGE_NAME, p->name, p->time, p->comment ? p->comment : "");
++ fprintf(F, "%s: > %s:%u:%s\n", PACKAGE_NAME, p->name, p->time, p->comment ? p->comment : "");
+ else
+- fprintf(F, "%s:%li:%s\n", p->name, p->time, p->comment ? p->comment : "");
++ fprintf(F, "%s:%u:%s\n", p->name, p->time, p->comment ? p->comment : "");
+ p = p->next;
+ } while (p != first);
+
+@@ -614,7 +614,7 @@
+ if (sess_time == 0)
+ return 1;
+ strftime(tbuff, sizeof(tbuff), "%a, %d %b %Y %H:%M:%S %z", localtime(&now.tv_sec));
+- snprintf(rbuff, sizeof(rbuff), "%s %03li:%02li:%02li", tbuff, sess_time / 3600, sess_time / 60 % 60, sess_time % 60);
++ snprintf(rbuff, sizeof(rbuff), "%s %03i:%02i:%02i", tbuff, sess_time / 3600, sess_time / 60 % 60, sess_time % 60);
+
+ if ((fname = malloc(path_len)) == NULL) {
+ fprintf(stderr, "%s: cannot allocate memory for path variable\n", PACKAGE_NAME);