aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/toybox/Makefile41
-rw-r--r--sysutils/toybox/distinfo3
-rw-r--r--sysutils/toybox/pkg-descr5
4 files changed, 50 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 729360f1e301..4bef2cd82805 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1309,6 +1309,7 @@
SUBDIR += topless
SUBDIR += torque
SUBDIR += toshctl
+ SUBDIR += toybox
SUBDIR += tracker
SUBDIR += tracker-miners
SUBDIR += tree
diff --git a/sysutils/toybox/Makefile b/sysutils/toybox/Makefile
new file mode 100644
index 000000000000..42b2adbc1d42
--- /dev/null
+++ b/sysutils/toybox/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= toybox
+PORTVERSION= 0.8.2
+CATEGORIES= sysutils
+
+MAINTAINER= vidar@karlsen.tech
+COMMENT= All-in-one command line
+
+LICENSE= 0BSD
+LICENSE_NAME= BSD Zero Clause License
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= bash:shells/bash gsed:textproc/gsed
+LIB_DEPENDS= libinotify.so:devel/libinotify
+
+USES= gmake shebangfix
+
+SHEBANG_FILES= scripts/change.sh scripts/findglobals.sh \
+ scripts/genconfig.sh scripts/install.sh \
+ scripts/make.sh scripts/minicom.sh \
+ scripts/portability.sh scripts/runtest.sh \
+ scripts/single.sh scripts/test.sh configure
+
+PLIST_FILES= bin/toybox
+
+USE_GITHUB= yes
+GH_ACCOUNT= landley
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<sys/inotify.h>|"${LOCALBASE}/include/sys/inotify.h"|' \
+ ${WRKSRC}/lib/portability.c
+
+do-configure:
+ cd ${WRKSRC} && ${GMAKE} bsd_defconfig
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/toybox ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/toybox/distinfo b/sysutils/toybox/distinfo
new file mode 100644
index 000000000000..84abd6d5331b
--- /dev/null
+++ b/sysutils/toybox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1574378247
+SHA256 (landley-toybox-0.8.2_GH0.tar.gz) = 9d8a9b00a6c93da5b472d8a4c7d9549339ed050d1578c557a20add100172b0f5
+SIZE (landley-toybox-0.8.2_GH0.tar.gz) = 1057417
diff --git a/sysutils/toybox/pkg-descr b/sysutils/toybox/pkg-descr
new file mode 100644
index 000000000000..57ffb55f8885
--- /dev/null
+++ b/sysutils/toybox/pkg-descr
@@ -0,0 +1,5 @@
+Toybox combines common command line utilities together
+into a single BSD-licensed executable that's simple, small,
+fast, reasonably standards-compliant, and powerful.
+
+WWW: http://landley.net/toybox/