aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/chicken/Makefile9
-rw-r--r--lang/chicken/distinfo6
-rw-r--r--lang/chicken/pkg-descr6
-rw-r--r--lang/chicken/pkg-plist5
4 files changed, 14 insertions, 12 deletions
diff --git a/lang/chicken/Makefile b/lang/chicken/Makefile
index 16bda443e1a9..e6d2cdd9f11b 100644
--- a/lang/chicken/Makefile
+++ b/lang/chicken/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= chicken
-PORTVERSION= 4.5.0
+PORTVERSION= 4.6.0
CATEGORIES= lang scheme
-MASTER_SITES= http://www.call-with-current-continuation.org/ \
- http://chicken.wiki.br/releases/${PORTVERSION}/
+MASTER_SITES= http://code.call-cc.org/releases/${PORTVERSION}/
MAINTAINER= vmagerya@gmail.com
COMMENT= A Scheme-to-C compiler
@@ -17,9 +16,9 @@ COMMENT= A Scheme-to-C compiler
USE_GMAKE= yes
USE_LDCONFIG= yes
MAKE_ARGS+= PLATFORM=bsd PREFIX=${PREFIX} \
- TOPMANDIR=${PREFIX}/man ARCH=${NEW_ARCH}
+ TOPMANDIR=${PREFIX}/man ARCH=${NEW_ARCH} \
+ C_COMPILER_OPTIMIZATION_OPTIONS="${CFLAGS}"
-PLATFORM= bsd
NEW_ARCH= ${ARCH:S/i386/x86/:S/amd64/x86-64/}
MAN1= chicken.1 chicken-bug.1 chicken-install.1 chicken-profile.1 \
diff --git a/lang/chicken/distinfo b/lang/chicken/distinfo
index 30fdf41fca3d..4c430cd866d8 100644
--- a/lang/chicken/distinfo
+++ b/lang/chicken/distinfo
@@ -1,3 +1,3 @@
-MD5 (chicken-4.5.0.tar.gz) = 753aea676a18c8dc0161dfb4d1717e20
-SHA256 (chicken-4.5.0.tar.gz) = 95919725411268614022ffc2426c826290cbebb6d574c1f2ebcaee5ac3ef9fd9
-SIZE (chicken-4.5.0.tar.gz) = 2914920
+MD5 (chicken-4.6.0.tar.gz) = 538a93e786e550ad848a040bcd902184
+SHA256 (chicken-4.6.0.tar.gz) = c55d1dadf9941b3efbc7be9181d5c7cbc304a20c614625fbf710c0acaa1cd245
+SIZE (chicken-4.6.0.tar.gz) = 3019126
diff --git a/lang/chicken/pkg-descr b/lang/chicken/pkg-descr
index 5c27b43cca35..a8fac70e2fb8 100644
--- a/lang/chicken/pkg-descr
+++ b/lang/chicken/pkg-descr
@@ -1,6 +1,6 @@
CHICKEN is a compiler for the Scheme programming language. CHICKEN
-produces portable, efficient C, supports almost all of the current
-Scheme language standard (R5RS), and includes many enhancements and
+produces portable, efficient C, supports almost all of the R5RS
+Scheme language standard, and includes many enhancements and
extensions.
-WWW: http://www.call-with-current-continuation.org/
+WWW: http://www.call-cc.org/
diff --git a/lang/chicken/pkg-plist b/lang/chicken/pkg-plist
index dfd15b015c73..300d41186ae5 100644
--- a/lang/chicken/pkg-plist
+++ b/lang/chicken/pkg-plist
@@ -37,6 +37,7 @@ lib/chicken/5/utils.import.so
lib/libchicken.a
lib/libchicken.so
lib/libchicken.so.5
+%%DATADIR%%/chicken.png
%%DATADIR%%/setup.defaults
%%DOCSDIR%%/LICENSE
%%DOCSDIR%%/NEWS
@@ -48,18 +49,20 @@ lib/libchicken.so.5
%%DOCSDIR%%/manual/Bugs and limitations
%%DOCSDIR%%/manual/C interface
%%DOCSDIR%%/manual/Callbacks
+%%DOCSDIR%%/manual/Cross development
%%DOCSDIR%%/manual/Data representation
%%DOCSDIR%%/manual/Declarations
%%DOCSDIR%%/manual/Deployment
%%DOCSDIR%%/manual/Deviations from the standard
%%DOCSDIR%%/manual/Embedding
+%%DOCSDIR%%/manual/Exceptions
%%DOCSDIR%%/manual/Extensions
%%DOCSDIR%%/manual/Extensions to the standard
%%DOCSDIR%%/manual/Foreign type specifiers
%%DOCSDIR%%/manual/Getting started
%%DOCSDIR%%/manual/Interface to external functions and variables
%%DOCSDIR%%/manual/Locations
-%%DOCSDIR%%/manual/Modules and macros
+%%DOCSDIR%%/manual/Modules
%%DOCSDIR%%/manual/Non-standard macros and special forms
%%DOCSDIR%%/manual/Non-standard read syntax
%%DOCSDIR%%/manual/Other support procedures