aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--irc/anope/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/irc/anope/Makefile b/irc/anope/Makefile
index bb12b3434d0c..cb9246ad1f25 100644
--- a/irc/anope/Makefile
+++ b/irc/anope/Makefile
@@ -32,6 +32,14 @@ OPTIONS= MYSQL "Use mysql" ON \
HYB "Hybrid IRCd 7.0 [experimental]" OFF \
VIA "ViagraIRCd 1.3.x [or later]" OFF \
PTL "PTlink 6.15.0 [experimental]" OFF
+# in that case, OPTIONS are ignored, no defaults
+.if defined(PACKAGE_BUILDING) || defined(BATCH)
+WITH_MYSQL= yes
+WITH_MODULES= yes
+WITH_MD5= yes
+WITH_THREAD= yes
+WITH_UNREAL= yes
+.endif
#}}}
ANOPEBIN?= ${PREFIX}/libexec/anope