aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/rakudo/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/lang/rakudo/Makefile b/lang/rakudo/Makefile
index aad400385442..764ca6a830ea 100644
--- a/lang/rakudo/Makefile
+++ b/lang/rakudo/Makefile
@@ -8,31 +8,25 @@
PORTNAME= rakudo
PORTVERSION= 2010.02
PORTEPOCH= 1
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://cloud.github.com/downloads/rakudo/rakudo/
MAINTAINER= perl@FreeBSD.org
COMMENT= The Rakudo Perl 6 Compiler targets the Parrot Virtual Machine
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
- ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
- parrot>=${PARROT_VERSION}:${PORTSDIR}/lang/parrot
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4 \
- icudata:${PORTSDIR}/devel/icu
+BUILD_DEPENDS= parrot>=${PARROT_VERSION}:${PORTSDIR}/lang/parrot
+LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu
RUN_DEPENDS= parrot>=${PARROT_VERSION}:${PORTSDIR}/lang/parrot
-# amd64 i386 sparc
-# 9-current pass gcc
-# 8-stable gcc pass
-# 7-stable pass pass
-# 6-stable icu icu
+# amd64 i386 sparc
+# 9-current pass pass
+# 8-stable pass pass
+# 7-stable pass pass
+# 6-stable icu icu
.include <bsd.port.pre.mk>
-.if ${ARCH} == 'i386' && ${OSVERSION} >= 900000
-BROKEN= internal gcc bugs
-.endif
-
.if ${OSVERSION} < 700000
BROKEN= dependency devel/icu is broken on 6.x
.endif