aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/drawterm/Makefile3
-rw-r--r--net/drawterm/files/patch-Make.pthread6
-rw-r--r--net/drawterm/files/patch-include_unix.h12
3 files changed, 17 insertions, 4 deletions
diff --git a/net/drawterm/Makefile b/net/drawterm/Makefile
index 7f334bb631cd..94d057e901aa 100644
--- a/net/drawterm/Makefile
+++ b/net/drawterm/Makefile
@@ -3,9 +3,9 @@
PORTNAME= drawterm
PORTVERSION= 20140106
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://swtch.com/drawterm/
-EXTRACT_SUFX= .tgz
MAINTAINER= winston@ml1.net
COMMENT= Plan9 cpu client
@@ -13,6 +13,7 @@ COMMENT= Plan9 cpu client
# Additionally the Lucent Public License
LICENSE= MIT
+USES= tar:tgz
USE_XORG= x11 xt
PLIST_FILES= bin/drawterm
diff --git a/net/drawterm/files/patch-Make.pthread b/net/drawterm/files/patch-Make.pthread
index d3c7433c9dfa..165799784164 100644
--- a/net/drawterm/files/patch-Make.pthread
+++ b/net/drawterm/files/patch-Make.pthread
@@ -1,6 +1,6 @@
---- Make.pthread.orig 2009-08-26 00:44:41.000000000 -0500
-+++ Make.pthread 2012-02-15 14:04:26.020899861 -0600
-@@ -4,14 +4,14 @@
+--- Make.pthread.orig 2009-08-26 05:44:41 UTC
++++ Make.pthread
+@@ -4,14 +4,14 @@ PTHREAD=-pthread -DPTHREAD
AR=ar
AS=no-as-here
RANLIB=ranlib
diff --git a/net/drawterm/files/patch-include_unix.h b/net/drawterm/files/patch-include_unix.h
new file mode 100644
index 000000000000..d697eb727bf6
--- /dev/null
+++ b/net/drawterm/files/patch-include_unix.h
@@ -0,0 +1,12 @@
+--- include/unix.h.orig 2015-07-13 22:14:41 UTC
++++ include/unix.h
+@@ -11,7 +11,9 @@
+ #define _FILE_OFFSET_BITS 64
+
+
++#define fdclose sysfdclose
+ #include <stdio.h>
++#undef fdclose
+ #include <stdlib.h>
+ #include <string.h>
+ #include <math.h>