aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--dns/kadnode/Makefile2
-rw-r--r--emulators/dolphin-emu/Makefile2
-rw-r--r--lang/gauche/Makefile1
-rw-r--r--lang/neko/Makefile2
-rw-r--r--net/bctoolbox/Makefile2
-rw-r--r--net/shadowsocks-libev/Makefile2
-rw-r--r--security/mbedtls/Makefile2
-rw-r--r--security/mbedtls/distinfo6
-rw-r--r--security/mbedtls/files/patch-dtls-srtp4
-rw-r--r--security/mbedtls/pkg-plist12
-rw-r--r--security/openvpn-devel/Makefile2
-rw-r--r--security/openvpn/Makefile2
-rw-r--r--www/hiawatha/Makefile2
13 files changed, 25 insertions, 16 deletions
diff --git a/dns/kadnode/Makefile b/dns/kadnode/Makefile
index 07018ce907c6..279bcef7a41f 100644
--- a/dns/kadnode/Makefile
+++ b/dns/kadnode/Makefile
@@ -4,7 +4,7 @@
PORTNAME= kadnode
DISTVERSIONPREFIX= v
DISTVERSION= 2.2.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= dns
MAINTAINER= moritzwarning@web.de
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index 375bcd4c768c..cc9f25db6148 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dolphin-emu
PORTVERSION= 5.0
-PORTREVISION= 22
+PORTREVISION= 23
CATEGORIES= emulators
MAINTAINER= martymac@FreeBSD.org
diff --git a/lang/gauche/Makefile b/lang/gauche/Makefile
index bfb9635d03a0..b83d7671bad8 100644
--- a/lang/gauche/Makefile
+++ b/lang/gauche/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gauche
PORTVERSION= 0.9.6
+PORTREVISION= 1
CATEGORIES= lang scheme
MASTER_SITES= SF/${PORTNAME}/Gauche
DISTNAME= Gauche-${PORTVERSION}
diff --git a/lang/neko/Makefile b/lang/neko/Makefile
index f435a02d3625..7dfab628f87c 100644
--- a/lang/neko/Makefile
+++ b/lang/neko/Makefile
@@ -3,7 +3,7 @@
PORTNAME= neko
DISTVERSIONPREFIX= v
DISTVERSION= 2-2-0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= lang
MAINTAINER= penzin.dev@gmail.com
diff --git a/net/bctoolbox/Makefile b/net/bctoolbox/Makefile
index fc6063b725a1..364b72b49229 100644
--- a/net/bctoolbox/Makefile
+++ b/net/bctoolbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bctoolbox
PORTVERSION= 0.2.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
MASTER_SITES= SAVANNAH/linphone/bctoolbox
diff --git a/net/shadowsocks-libev/Makefile b/net/shadowsocks-libev/Makefile
index f343fcb52977..43e50c5f877a 100644
--- a/net/shadowsocks-libev/Makefile
+++ b/net/shadowsocks-libev/Makefile
@@ -4,7 +4,7 @@
PORTNAME= shadowsocks-libev
DISTVERSIONPREFIX= v
DISTVERSION= 3.1.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
MAINTAINER= xiaoding+freebsd@xiaoding.org
diff --git a/security/mbedtls/Makefile b/security/mbedtls/Makefile
index efae60f7be55..c381d91f03cb 100644
--- a/security/mbedtls/Makefile
+++ b/security/mbedtls/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= mbedtls
-PORTVERSION= 2.9.0
+PORTVERSION= 2.12.0
DISTVERSIONPREFIX=${PORTNAME}-
CATEGORIES= security devel
diff --git a/security/mbedtls/distinfo b/security/mbedtls/distinfo
index 9e21be64337f..65c73dd41f5a 100644
--- a/security/mbedtls/distinfo
+++ b/security/mbedtls/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1528372776
-SHA256 (ARMmbed-mbedtls-mbedtls-2.9.0_GH0.tar.gz) = 1972a98a25486a5d174ac97706a468355a007842e0b3ad72305c53d38ea8f6d3
-SIZE (ARMmbed-mbedtls-mbedtls-2.9.0_GH0.tar.gz) = 2163543
+TIMESTAMP = 1533902976
+SHA256 (ARMmbed-mbedtls-mbedtls-2.12.0_GH0.tar.gz) = 05b126f25d4438f206d062b48cd2f2db2a1cd11bda58b21afe40b9b7cf6fca48
+SIZE (ARMmbed-mbedtls-mbedtls-2.12.0_GH0.tar.gz) = 2299830
diff --git a/security/mbedtls/files/patch-dtls-srtp b/security/mbedtls/files/patch-dtls-srtp
index e0777d0425de..dac835d23b17 100644
--- a/security/mbedtls/files/patch-dtls-srtp
+++ b/security/mbedtls/files/patch-dtls-srtp
@@ -639,7 +639,7 @@ index 4424f56..940f8aa 100644
#endif
+#if defined (MBEDTLS_SSL_DTLS_SRTP)
-+ mbedtls_zeroize( ssl->dtls_srtp_keys, ssl->dtls_srtp_keys_len );
++ mbedtls_platform_zeroize( ssl->dtls_srtp_keys, ssl->dtls_srtp_keys_len );
+ mbedtls_free( ssl->dtls_srtp_keys );
+#endif /* MBEDTLS_SSL_DTLS_SRTP */
+
@@ -654,6 +654,6 @@ index 4424f56..940f8aa 100644
+ mbedtls_free( conf->dtls_srtp_profiles_list );
+#endif
+
- mbedtls_zeroize( conf, sizeof( mbedtls_ssl_config ) );
+ mbedtls_platform_zeroize( conf, sizeof( mbedtls_ssl_config ) );
}
diff --git a/security/mbedtls/pkg-plist b/security/mbedtls/pkg-plist
index 9b7eaeb87b28..958a86f9ed7d 100644
--- a/security/mbedtls/pkg-plist
+++ b/security/mbedtls/pkg-plist
@@ -46,9 +46,11 @@ bin/mbedtls_ssl_server2
bin/mbedtls_strerror
bin/mbedtls_udp_proxy
bin/mbedtls_udp_proxy_wrapper.sh
+bin/mbedtls_zeroize
include/mbedtls/aes.h
include/mbedtls/aesni.h
include/mbedtls/arc4.h
+include/mbedtls/aria.h
include/mbedtls/asn1.h
include/mbedtls/asn1write.h
include/mbedtls/base64.h
@@ -58,6 +60,8 @@ include/mbedtls/bn_mul.h
include/mbedtls/camellia.h
include/mbedtls/ccm.h
include/mbedtls/certs.h
+include/mbedtls/chacha20.h
+include/mbedtls/chachapoly.h
include/mbedtls/check_config.h
include/mbedtls/cipher.h
include/mbedtls/cipher_internal.h
@@ -78,6 +82,7 @@ include/mbedtls/entropy_poll.h
include/mbedtls/error.h
include/mbedtls/gcm.h
include/mbedtls/havege.h
+include/mbedtls/hkdf.h
include/mbedtls/hmac_drbg.h
include/mbedtls/md.h
include/mbedtls/md2.h
@@ -87,6 +92,7 @@ include/mbedtls/md_internal.h
include/mbedtls/memory_buffer_alloc.h
include/mbedtls/net.h
include/mbedtls/net_sockets.h
+include/mbedtls/nist_kw.h
include/mbedtls/oid.h
include/mbedtls/padlock.h
include/mbedtls/pem.h
@@ -97,6 +103,8 @@ include/mbedtls/pkcs12.h
include/mbedtls/pkcs5.h
include/mbedtls/platform.h
include/mbedtls/platform_time.h
+include/mbedtls/platform_util.h
+include/mbedtls/poly1305.h
include/mbedtls/ripemd160.h
include/mbedtls/rsa.h
include/mbedtls/rsa_internal.h
@@ -119,10 +127,10 @@ include/mbedtls/x509_csr.h
include/mbedtls/xtea.h
lib/libmbedcrypto.a
lib/libmbedcrypto.so
-lib/libmbedcrypto.so.2
+lib/libmbedcrypto.so.3
lib/libmbedtls.a
lib/libmbedtls.so
-lib/libmbedtls.so.10
+lib/libmbedtls.so.11
lib/libmbedx509.a
lib/libmbedx509.so
lib/libmbedx509.so.0
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index f56325bc0171..938d3c00f655 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openvpn
DISTVERSION= 201821
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security net
MASTER_SITES= https://secure-computing.net/files/openvpn/ \
ftp://ftp2.secure-computing.net/pub/FreeBSD/openvpn-devel/
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 72aa005e69d0..1d08c01cdead 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -3,7 +3,7 @@
PORTNAME= openvpn
DISTVERSION= 2.4.6
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= security net
MASTER_SITES= https://swupdate.openvpn.org/community/releases/ \
https://build.openvpn.net/downloads/releases/
diff --git a/www/hiawatha/Makefile b/www/hiawatha/Makefile
index d35505372615..4def49e22c8b 100644
--- a/www/hiawatha/Makefile
+++ b/www/hiawatha/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hiawatha
PORTVERSION= 10.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= https://www.hiawatha-webserver.org/files/