aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/ttf2pt1/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/print/ttf2pt1/Makefile b/print/ttf2pt1/Makefile
index 75238b2ab415..6f88d0ca2b43 100644
--- a/print/ttf2pt1/Makefile
+++ b/print/ttf2pt1/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ttf2pt1
PORTVERSION= 3.4.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= print
MASTER_SITES= SF
EXTRACT_SUFX= .tgz
@@ -11,12 +11,13 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= True Type Font to Postscript Type 1 Converter
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
RUN_DEPENDS= t1asm:${PORTSDIR}/print/t1utils
-USES= pkgconfig shebangfix perl5 desthack
+USES= pkgconfig shebangfix perl5 uidfix
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} ${CPPFLAGS}" LIBS="${LDFLAGS}" \
- INSTDIR="${STAGEDIR}${PREFIX}" LIBXDIR="${STAGEDIR}${PREFIX}/bin"
+ INSTDIR="${STAGEDIR}${PREFIX}" LIBXDIR="${STAGEDIR}${PREFIX}/bin" \
+ OWNER=${BINOWN} GROUP=${BINGRP}
SHEBANG_FILES= app/TeX/sfd2map \
app/TeX/cjk-latex-config \
other/showdf \
@@ -35,4 +36,11 @@ CPPFLAGS+= `pkg-config --cflags freetype2` \
LDFLAGS+= `pkg-config --libs freetype2` \
-L${LOCALBASE}/lib -lm
+post-install:
+ @${SED} -i '' 's,${STAGEDIR},,' ${STAGEDIR}${PREFIX}/bin/ttf2pt1_convert \
+ ${STAGEDIR}${PREFIX}/man/man1/ttf2pt1_x2gs.1 \
+ ${STAGEDIR}${PREFIX}/man/man1/ttf2pt1.1 \
+ ${STAGEDIR}${PREFIX}/man/man1/ttf2pt1_convert.1 \
+ ${STAGEDIR}${DATADIR}/scripts/convert
+
.include <bsd.port.mk>