aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--editors/openoffice-4/Makefile5
-rw-r--r--editors/openoffice-4/files/patch-solenv_gbuild_platform_freebsd.mk10
-rw-r--r--editors/openoffice-4/files/patch-solenv_inc_unxfbsd.mk11
3 files changed, 25 insertions, 1 deletions
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index 7a8e523d339f..9ddb24522386 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -416,7 +416,10 @@ do-build:
fi ; \
cd ${WRKSRC}/instsetoo_native ; \
. ../${FREEBSD_ENV_SET} ; \
- build.pl --all -P$${numproc} -- -P$${dmproc}
+ if [ -n "${HOME}" -a ! -w "${HOME}" ]; then \
+ export HOME=/tmp ; \
+ fi ; \
+ HOME=/tmp build.pl --all -P$${numproc} -- -P$${dmproc}
do-install:
@${MKDIR} ${STAGEDIR}${PRINSTALLATION_BASEDIR} \
diff --git a/editors/openoffice-4/files/patch-solenv_gbuild_platform_freebsd.mk b/editors/openoffice-4/files/patch-solenv_gbuild_platform_freebsd.mk
new file mode 100644
index 000000000000..acee2d1a51ee
--- /dev/null
+++ b/editors/openoffice-4/files/patch-solenv_gbuild_platform_freebsd.mk
@@ -0,0 +1,10 @@
+--- solenv/gbuild/platform/freebsd.mk.orig 2017-11-27 13:50:25 UTC
++++ solenv/gbuild/platform/freebsd.mk
+@@ -94,6 +94,7 @@ gb_CXXFLAGS := \
+ -fno-use-cxa-atexit \
+ -fvisibility-inlines-hidden \
+ -fvisibility=hidden \
++ -std=gnu++98 \
+ -pipe
+ ifeq ($(COM),CLANG)
+ gb_CXXFLAGS += -DHAVE_STL_INCLUDE_PATH
diff --git a/editors/openoffice-4/files/patch-solenv_inc_unxfbsd.mk b/editors/openoffice-4/files/patch-solenv_inc_unxfbsd.mk
new file mode 100644
index 000000000000..f91d88004b2d
--- /dev/null
+++ b/editors/openoffice-4/files/patch-solenv_inc_unxfbsd.mk
@@ -0,0 +1,11 @@
+--- solenv/inc/unxfbsd.mk.orig 2017-11-27 13:50:28 UTC
++++ solenv/inc/unxfbsd.mk
+@@ -96,7 +96,7 @@ CFLAGSEXCEPTIONS=-fexceptions -fno-enforce-eh-specs
+ CFLAGS_NO_EXCEPTIONS=-fno-exceptions
+
+ # -fpermissive should be removed as soon as possible
+-CFLAGSCXX= -pipe $(ARCH_FLAGS)
++CFLAGSCXX= -pipe $(ARCH_FLAGS) -std=gnu++98
+ .IF "$(HAVE_GCC_VISIBILITY_FEATURE)" == "TRUE"
+ CFLAGSCXX += -fvisibility-inlines-hidden
+ .ENDIF # "$(HAVE_GCC_VISIBILITY_FEATURE)" == "TRUE"