aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/global/Makefile4
-rw-r--r--devel/p5-AnyEvent-MessagePack/Makefile3
-rw-r--r--devel/p5-CPAN-Testers-Report/Makefile9
-rw-r--r--devel/p5-Chooser/Makefile3
-rw-r--r--devel/p5-DateTime-Event-Chinese/Makefile9
-rw-r--r--devel/p5-Devel-CoreStack/Makefile8
-rw-r--r--devel/p5-Device-USB/Makefile3
-rw-r--r--devel/p5-Dir-Watch/Makefile9
-rw-r--r--devel/p5-File-Find-Rule-Filesys-Virtual/Makefile9
-rw-r--r--devel/p5-File-Util/Makefile9
-rw-r--r--devel/p5-Gearman/Makefile9
-rw-r--r--devel/p5-IPC-Mmap-Share/Makefile9
-rw-r--r--devel/p5-IPC-Shareable/Makefile9
-rw-r--r--devel/p5-Log-Dispatch-Screen-Color/Makefile8
-rw-r--r--devel/p5-MooseX-FollowPBP/Makefile9
-rw-r--r--devel/p5-Package-Stash-XS/Makefile3
-rw-r--r--devel/p5-RunApp/Makefile9
-rw-r--r--devel/p5-String-Dump/Makefile3
-rw-r--r--devel/p5-User-Identity/Makefile9
19 files changed, 49 insertions, 85 deletions
diff --git a/devel/global/Makefile b/devel/global/Makefile
index c40341f2edf7..84f2edc35fef 100644
--- a/devel/global/Makefile
+++ b/devel/global/Makefile
@@ -1,4 +1,4 @@
-# Created by: chuckr@freebsd.org
+# Created by: chuckr@FreeBSD.org
# $FreeBSD$
PORTNAME= global
@@ -10,7 +10,7 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= A source code tag system
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
MAN1= global.1 globash.1 gozilla.1 gtags.1 gtags-cscope.1 htags.1
INFO= global
diff --git a/devel/p5-AnyEvent-MessagePack/Makefile b/devel/p5-AnyEvent-MessagePack/Makefile
index 05149dc52f8d..0165bc8eabab 100644
--- a/devel/p5-AnyEvent-MessagePack/Makefile
+++ b/devel/p5-AnyEvent-MessagePack/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= \
p5-Data-MessagePack-Stream>=0.07:${PORTSDIR}/devel/p5-Data-MessagePack-Stream
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= AnyEvent::MessagePack.3
diff --git a/devel/p5-CPAN-Testers-Report/Makefile b/devel/p5-CPAN-Testers-Report/Makefile
index e307938d7e4b..73631a8ae3f0 100644
--- a/devel/p5-CPAN-Testers-Report/Makefile
+++ b/devel/p5-CPAN-Testers-Report/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-CPAN-Testers-Report
-# Date created: 2011-02-05
-# Whom: Steve Wills <swills@FreeBSD.org>
-#
+# Created by: Steve Wills <swills@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= CPAN-Testers-Report
PORTVERSION= 1.999001
@@ -18,7 +14,8 @@ COMMENT= CPAN Testers report object
BUILD_DEPENDS= p5-Metabase-Fact>0:${PORTSDIR}/devel/p5-Metabase-Fact
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CPAN::Testers::Fact::LegacyReport.3 \
CPAN::Testers::Fact::TestEnvironment.3 \
diff --git a/devel/p5-Chooser/Makefile b/devel/p5-Chooser/Makefile
index 7a7e90b2456b..b25d8086a657 100644
--- a/devel/p5-Chooser/Makefile
+++ b/devel/p5-Chooser/Makefile
@@ -15,7 +15,8 @@ RUN_DEPENDS= p5-Net-CIDR-Lite>=0.21:${PORTSDIR}/net/p5-Net-CIDR-Lite \
p5-IO-Socket-SSL>=1.74:${PORTSDIR}/security/p5-IO-Socket-SSL \
p5-Text-NeatTemplate>=0.10.01:${PORTSDIR}/textproc/p5-Text-NeatTemplate
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Chooser.3
diff --git a/devel/p5-DateTime-Event-Chinese/Makefile b/devel/p5-DateTime-Event-Chinese/Makefile
index c23460415de5..2851b477ab07 100644
--- a/devel/p5-DateTime-Event-Chinese/Makefile
+++ b/devel/p5-DateTime-Event-Chinese/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-DateTime-Event-Chinese
-# Date created: 2007-11-06
-# Whom: Masahiro Teramoto <markun@onohara.to>
-#
+# Created by: Masahiro Teramoto <markun@onohara.to>
# $FreeBSD$
-#
PORTNAME= DateTime-Event-Chinese
PORTVERSION= 1.00
@@ -23,7 +19,8 @@ BUILD_DEPENDS= p5-DateTime-Astro>=0:${PORTSDIR}/devel/p5-DateTime-Astro \
RUN_DEPENDS= p5-DateTime-Astro>=0:${PORTSDIR}/devel/p5-DateTime-Astro \
p5-Math-Round>=0:${PORTSDIR}/math/p5-Math-Round
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= DateTime::Event::Chinese.3
diff --git a/devel/p5-Devel-CoreStack/Makefile b/devel/p5-Devel-CoreStack/Makefile
index b864e1eb85e3..df041aff9dbf 100644
--- a/devel/p5-Devel-CoreStack/Makefile
+++ b/devel/p5-Devel-CoreStack/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: p5-Devel-CoreStack
-# Date created: April 3rd 2006
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Devel-CoreStack
PORTVERSION= 1.3
@@ -14,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= A perl5 module that generates a stack dump from a core file
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Devel::CoreStack.3
diff --git a/devel/p5-Device-USB/Makefile b/devel/p5-Device-USB/Makefile
index 545e442fec8c..2bc9d0b00420 100644
--- a/devel/p5-Device-USB/Makefile
+++ b/devel/p5-Device-USB/Makefile
@@ -15,7 +15,8 @@ BUILD_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
RUN_DEPENDS= p5-Inline>=0:${PORTSDIR}/devel/p5-Inline
MAKE_JOBS_UNSAFE=yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Device::USB.3 \
Device::USB::Bus.3 \
diff --git a/devel/p5-Dir-Watch/Makefile b/devel/p5-Dir-Watch/Makefile
index 6918b7287237..b9faad5f6582 100644
--- a/devel/p5-Dir-Watch/Makefile
+++ b/devel/p5-Dir-Watch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: devel/p5-Dir-Watch
-# Date created: 2009-12-18
-# Whom: Zane C, Bowers <vvelox@vvelox.net>
-#
+# Created by: Zane C, Bowers <vvelox@vvelox.net>
# $FreeBSD$
-#
PORTNAME= Dir-Watch
PORTVERSION= 0.0.0
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vvelox@vvelox.net
COMMENT= Watches the current directory for file/dir additions or removals
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Dir::Watch.3
diff --git a/devel/p5-File-Find-Rule-Filesys-Virtual/Makefile b/devel/p5-File-Find-Rule-Filesys-Virtual/Makefile
index 5e840755fce1..1908ec9b7f61 100644
--- a/devel/p5-File-Find-Rule-Filesys-Virtual/Makefile
+++ b/devel/p5-File-Find-Rule-Filesys-Virtual/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-File-Find-Rule-Filesys-Virtual
-# Date created: 2006-07-19
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= File-Find-Rule-Filesys-Virtual
PORTVERSION= 1.22
@@ -18,7 +14,8 @@ RUN_DEPENDS= p5-File-Find-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule \
p5-Filesys-Virtual>=0:${PORTSDIR}/devel/p5-Filesys-Virtual \
p5-Filesys-Virtual-Plain>=0:${PORTSDIR}/devel/p5-Filesys-Virtual-Plain
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= File::Find::Rule::Filesys::Virtual.3
diff --git a/devel/p5-File-Util/Makefile b/devel/p5-File-Util/Makefile
index 5138f5bed28e..47e742513bfd 100644
--- a/devel/p5-File-Util/Makefile
+++ b/devel/p5-File-Util/Makefile
@@ -1,9 +1,5 @@
-# New ports collection Makefile for: p5-File-Util
-# Date created: 25th April 2007
-# Whom: jeffhung
-#
+# Created by: jeffhung
# $FreeBSD$
-#
PORTNAME= File-Util
PORTVERSION= 3.27
@@ -19,7 +15,8 @@ RUN_DEPENDS= p5-Class-OOorNO>=0.01:${PORTSDIR}/devel/p5-Class-OOorNO \
p5-Exception-Handler>=1:${PORTSDIR}/devel/p5-Exception-Handler
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= File::Util.3
diff --git a/devel/p5-Gearman/Makefile b/devel/p5-Gearman/Makefile
index 7b88f8834efc..c2e93c2334fe 100644
--- a/devel/p5-Gearman/Makefile
+++ b/devel/p5-Gearman/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Gearman
-# Date created: Mon Mar 26 11:45:06 EDT 2007
-# Whom: Vivek Khera <vivek@khera.org>
-#
+# Created by: Vivek Khera <vivek@khera.org>
# $FreeBSD$
-#
PORTNAME= Gearman
PORTVERSION= 1.11
@@ -17,7 +13,8 @@ COMMENT= Gearman client libraray for Perl
RUN_DEPENDS+= p5-String-CRC32>=0.0:${PORTSDIR}/devel/p5-String-CRC32
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gearman::Client.3 Gearman::Task.3 Gearman::Worker.3
PLIST_FILES= %%SITE_PERL%%/Gearman/Client.pm \
diff --git a/devel/p5-IPC-Mmap-Share/Makefile b/devel/p5-IPC-Mmap-Share/Makefile
index 9d3f153a122e..47516025f699 100644
--- a/devel/p5-IPC-Mmap-Share/Makefile
+++ b/devel/p5-IPC-Mmap-Share/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-IPC-Mmap-Share
-# Date created: 2006-07-17
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
+# Created by: Gea-Suan Lin <gslin@gslin.org>
# $FreeBSD$
-#
PORTNAME= IPC-Mmap-Share
PORTVERSION= 0.03
@@ -17,7 +13,8 @@ COMMENT= Safely share structures among processes using anonymous mmap
RUN_DEPENDS= p5-IPC-Mmap>=0:${PORTSDIR}/devel/p5-IPC-Mmap
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IPC::Mmap::Share.3
diff --git a/devel/p5-IPC-Shareable/Makefile b/devel/p5-IPC-Shareable/Makefile
index b69ad4224f81..2bf94f29055c 100644
--- a/devel/p5-IPC-Shareable/Makefile
+++ b/devel/p5-IPC-Shareable/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-IPC-Shareable
-# Date created: May 25th 2000
-# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
-#
+# Created by: Yen-Ming Lee <leeym@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= IPC-Shareable
PORTVERSION= 0.61
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= leeym@FreeBSD.org
COMMENT= Share Perl variables between processes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= IPC::Shareable.3 IPC::Shareable::SharedMem.3
diff --git a/devel/p5-Log-Dispatch-Screen-Color/Makefile b/devel/p5-Log-Dispatch-Screen-Color/Makefile
index 340e3927ac4d..842454551c1e 100644
--- a/devel/p5-Log-Dispatch-Screen-Color/Makefile
+++ b/devel/p5-Log-Dispatch-Screen-Color/Makefile
@@ -1,9 +1,4 @@
-# New ports collection makefile for: Log::Dispatch::Screen::Color
-# Date created: 23 Sep 2009
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
# $FreeBSD$
-#
PORTNAME= Log-Dispatch-Screen-Color
PORTVERSION= 0.04
@@ -20,7 +15,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-IO-stringy>0:${PORTSDIR}/devel/p5-IO-stringy
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Log::Dispatch::Screen::Color.3
diff --git a/devel/p5-MooseX-FollowPBP/Makefile b/devel/p5-MooseX-FollowPBP/Makefile
index 0ee459b6f605..42cb37d14d72 100644
--- a/devel/p5-MooseX-FollowPBP/Makefile
+++ b/devel/p5-MooseX-FollowPBP/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-MooseX-FollowPBP
-# Date created: 11 August 2010
-# Whom: Frederic Culot <frederic@culot.org>
-#
+# Created by: Frederic Culot <frederic@culot.org>
# $FreeBSD$
-#
PORTNAME= MooseX-FollowPBP
PORTVERSION= 0.05
@@ -19,7 +15,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
LICENSE= ART20
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MooseX::FollowPBP.3 \
MooseX::FollowPBP::Role::Attribute.3
diff --git a/devel/p5-Package-Stash-XS/Makefile b/devel/p5-Package-Stash-XS/Makefile
index c1ef5ed683a8..03862ab0b9c7 100644
--- a/devel/p5-Package-Stash-XS/Makefile
+++ b/devel/p5-Package-Stash-XS/Makefile
@@ -16,7 +16,8 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Package::Stash::XS.3
diff --git a/devel/p5-RunApp/Makefile b/devel/p5-RunApp/Makefile
index a7d50d070c51..07864cfed93c 100644
--- a/devel/p5-RunApp/Makefile
+++ b/devel/p5-RunApp/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-RunApp
-# Date created: Dec 29 2006
-# Whom: Rong-En Fan <rafan@FreeBSD.org>
-#
+# Created by: Rong-En Fan <rafan@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= RunApp
PORTVERSION= 0.13
@@ -21,7 +17,8 @@ BUILD_DEPENDS= p5-App-Control>=0:${PORTSDIR}/devel/p5-App-Control \
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= App::Control::Apache.3 \
RunApp.3 \
diff --git a/devel/p5-String-Dump/Makefile b/devel/p5-String-Dump/Makefile
index 06e28defb472..683ab717c557 100644
--- a/devel/p5-String-Dump/Makefile
+++ b/devel/p5-String-Dump/Makefile
@@ -13,7 +13,8 @@ COMMENT= Dump strings of characters or bytes for printing and debugging
BUILD_DEPENDS= p5-Getopt-Lucid>=0:${PORTSDIR}/textproc/p5-Getopt-Lucid
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN1= dumpstr.1
MAN3= String::Dump.3 String::Dump::Debugging.3
diff --git a/devel/p5-User-Identity/Makefile b/devel/p5-User-Identity/Makefile
index 66f011e23eb9..1ee8f2641b94 100644
--- a/devel/p5-User-Identity/Makefile
+++ b/devel/p5-User-Identity/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-User-Identity
-# Date created: 21 Jul 2005
-# Whom: Max Campos <mcampos@bpsw.biz>
-#
+# Created by: Max Campos <mcampos@bpsw.biz>
# $FreeBSD$
-#
PORTNAME= User-Identity
PORTVERSION= 0.93
@@ -16,7 +12,8 @@ COMMENT= Perl module for abstracting information about a physical person
RUN_DEPENDS= p5-Geography-Countries>=0:${PORTSDIR}/misc/p5-Geography-Countries
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Mail::Identity.3 \
User::Identity.3 \