aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--print/fontforge/Makefile2
-rw-r--r--print/fontforge/distinfo8
-rw-r--r--print/fontforge/files/patch-Makefile.dynamic.in4
-rw-r--r--print/fontforge/files/patch-fontforge::Makefile.dynamic.in16
-rw-r--r--print/fontforge/files/patch-fontforge::makenomenh.c11
-rw-r--r--print/fontforge/pkg-plist36
6 files changed, 52 insertions, 25 deletions
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index 76b47cf525f7..168a19b78b6f 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fontforge
-PORTVERSION= 20050909
+PORTVERSION= 20051028
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fontforge
diff --git a/print/fontforge/distinfo b/print/fontforge/distinfo
index 1b9a2e99aac6..bbebd9b0b50f 100644
--- a/print/fontforge/distinfo
+++ b/print/fontforge/distinfo
@@ -1,4 +1,4 @@
-MD5 (fontforge_full-20050909.tar.bz2) = 8bb93d8c047c2ac4c8635080af61bc39
-SIZE (fontforge_full-20050909.tar.bz2) = 3175627
-MD5 (fontforge_htdocs-20050909.tgz) = 0484d971d9f9433eff98d55e578ccddc
-SIZE (fontforge_htdocs-20050909.tgz) = 2137899
+MD5 (fontforge_full-20051028.tar.bz2) = 3d385a58cb37c544cfef9a0434072dd6
+SIZE (fontforge_full-20051028.tar.bz2) = 3014049
+MD5 (fontforge_htdocs-20051028.tgz) = 1a4f98489bcbb7aa91e38a8cade6f2f5
+SIZE (fontforge_htdocs-20051028.tgz) = 2156822
diff --git a/print/fontforge/files/patch-Makefile.dynamic.in b/print/fontforge/files/patch-Makefile.dynamic.in
index 72b0623b8a1a..fd121882cbe1 100644
--- a/print/fontforge/files/patch-Makefile.dynamic.in
+++ b/print/fontforge/files/patch-Makefile.dynamic.in
@@ -1,5 +1,5 @@
---- Makefile.dynamic.in.orig Thu Jun 9 02:20:04 2005
-+++ Makefile.dynamic.in Thu Jun 30 13:51:27 2005
+--- Makefile.dynamic.in.orig Mon Oct 17 03:30:49 2005
++++ Makefile.dynamic.in Mon Oct 17 10:14:46 2005
@@ -48,34 +48,34 @@
$(LIBTOOL) $(INSTALL) -c libgunicode.la $(libdir)/libgunicode.la
#cp .libs/*.so.*.* $(libdir)
diff --git a/print/fontforge/files/patch-fontforge::Makefile.dynamic.in b/print/fontforge/files/patch-fontforge::Makefile.dynamic.in
index b6a788563966..c584750d1725 100644
--- a/print/fontforge/files/patch-fontforge::Makefile.dynamic.in
+++ b/print/fontforge/files/patch-fontforge::Makefile.dynamic.in
@@ -1,11 +1,19 @@
---- fontforge/Makefile.dynamic.in.orig Fri Jul 30 01:26:29 2004
-+++ fontforge/Makefile.dynamic.in Wed Aug 25 19:48:55 2004
-@@ -42,7 +42,7 @@
+--- fontforge/Makefile.dynamic.in.orig Fri Oct 14 11:14:37 2005
++++ fontforge/Makefile.dynamic.in Sat Oct 15 14:23:19 2005
+@@ -43,13 +43,13 @@
DIFFOBJS = sfddiff.o sfd.o diffstubs.o stamp.o
ACORNOBJS = acorn2sfd.o sfd.o diffstubs.o psunicodenames.o stamp.o
-_CFLAGS = -I$(top_srcdir)/inc -I$(srcdir) -I. @WFLAGS@ $(X_CFLAGS) \
+_CFLAGS = -I$(LOCALBASE)/include -I$(top_srcdir)/inc -I$(srcdir) -I. @WFLAGS@ $(X_CFLAGS) \
@DEFS@ '-DSHAREDIR="$(sharedir)"' -DLIBDIR='"$(libdir)"'
- CFLAGS = @CFLAGS@ $(_CFLAGS)
+ CFLAGS = @CFLAGS@ @CPPFLAGS@ $(_CFLAGS)
+
+ LIBS = -rpath $(libdir) $(X_LIBS) ../libgdraw.la ../libgunicode.la \
+- $(X_PRE_LIBS) $(X_11LIB) $(X_EXTRA_LIBS) @LIBS@ $(STATIC_LIBS) -L/usr/lib -lm
+-DLIBS = -rpath $(libdir) ../libgunicode.la @LIBS@ -lm
++ $(X_PRE_LIBS) $(X_11LIB) $(X_EXTRA_LIBS) @LIBS@ $(STATIC_LIBS) -L/usr/lib -lm -lintl
++DLIBS = -rpath $(libdir) ../libgunicode.la @LIBS@ -lm -lintl
+
+ all: fontforge sfddiff
diff --git a/print/fontforge/files/patch-fontforge::makenomenh.c b/print/fontforge/files/patch-fontforge::makenomenh.c
new file mode 100644
index 000000000000..7f470e78e301
--- /dev/null
+++ b/print/fontforge/files/patch-fontforge::makenomenh.c
@@ -0,0 +1,11 @@
+--- fontforge/makenomenh.c.orig Wed Oct 19 09:50:52 2005
++++ fontforge/makenomenh.c Wed Oct 19 09:51:36 2005
+@@ -299,7 +299,7 @@
+ fprintf( po, "\"Project-Id-Version: PACKAGE VERSION\\n\"\n" );
+ time(&now);
+ tmnow = localtime(&now);
+-#if !defined(__Mac) && !defined(__CygWin)
++#if !defined(__Mac) && !defined(__CygWin) && !defined(__FreeBSD__)
+ fprintf( po, "\"POT-Creation-Date: %d-%02d-%02d %02d:%02d+%02ld%02ld\\n\"\n",
+ tmnow->tm_year+1900, tmnow->tm_mon, tmnow->tm_mday,
+ tmnow->tm_hour, tmnow->tm_min,
diff --git a/print/fontforge/pkg-plist b/print/fontforge/pkg-plist
index 050477f1db5d..5fe0f0f965b7 100644
--- a/print/fontforge/pkg-plist
+++ b/print/fontforge/pkg-plist
@@ -1,6 +1,5 @@
bin/fontforge
bin/sfddiff
-bin/pfaedit
lib/libgdraw.a
lib/libgdraw.la
lib/libgdraw.so
@@ -49,8 +48,8 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/Eperspective.png
%%PORTDOCS%%%%DOCSDIR%%/FVHMetrics.png
%%PORTDOCS%%%%DOCSDIR%%/FVVMetrics.png
-%%PORTDOCS%%%%DOCSDIR%%/FontForgeSplash.png
%%PORTDOCS%%%%DOCSDIR%%/FontDisplay.png
+%%PORTDOCS%%%%DOCSDIR%%/FontForgeSplash.png
%%PORTDOCS%%%%DOCSDIR%%/FontSample.png
%%PORTDOCS%%%%DOCSDIR%%/GSUB-Order.png
%%PORTDOCS%%%%DOCSDIR%%/GenerateFamily.png
@@ -169,7 +168,6 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/cidmapformat.html
%%PORTDOCS%%%%DOCSDIR%%/cidmenu.html
%%PORTDOCS%%%%DOCSDIR%%/cliargs.html
-%%PORTDOCS%%%%DOCSDIR%%/contextchain.html
%%PORTDOCS%%%%DOCSDIR%%/contextchain-class.png
%%PORTDOCS%%%%DOCSDIR%%/contextchain-classlist.png
%%PORTDOCS%%%%DOCSDIR%%/contextchain-coverage.png
@@ -179,6 +177,7 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/contextchain-pickglyph.png
%%PORTDOCS%%%%DOCSDIR%%/contextchain-rcover.png
%%PORTDOCS%%%%DOCSDIR%%/contextchain-seqlookup.png
+%%PORTDOCS%%%%DOCSDIR%%/contextchain.html
%%PORTDOCS%%%%DOCSDIR%%/copyfeatures.png
%%PORTDOCS%%%%DOCSDIR%%/corpchar.html
%%PORTDOCS%%%%DOCSDIR%%/corpchar.txt
@@ -203,8 +202,8 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/cvscaleicon.png
%%PORTDOCS%%%%DOCSDIR%%/cvskewicon.png
%%PORTDOCS%%%%DOCSDIR%%/cvstaricon.png
-%%PORTDOCS%%%%DOCSDIR%%/cvtangenticon.png
%%PORTDOCS%%%%DOCSDIR%%/cvt-to-mac.png
+%%PORTDOCS%%%%DOCSDIR%%/cvtangenticon.png
%%PORTDOCS%%%%DOCSDIR%%/definegroups.png
%%PORTDOCS%%%%DOCSDIR%%/diffs.html
%%PORTDOCS%%%%DOCSDIR%%/display.html
@@ -212,15 +211,15 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/document.nvd
%%PORTDOCS%%%%DOCSDIR%%/doublestruck-B.png
%%PORTDOCS%%%%DOCSDIR%%/editcvt.png
+%%PORTDOCS%%%%DOCSDIR%%/editexample-fr.html
%%PORTDOCS%%%%DOCSDIR%%/editexample.html
%%PORTDOCS%%%%DOCSDIR%%/editexample2.html
%%PORTDOCS%%%%DOCSDIR%%/editexample3.html
%%PORTDOCS%%%%DOCSDIR%%/editexample4.html
%%PORTDOCS%%%%DOCSDIR%%/editexample5.html
-%%PORTDOCS%%%%DOCSDIR%%/editexample6.html
%%PORTDOCS%%%%DOCSDIR%%/editexample6-5.html
+%%PORTDOCS%%%%DOCSDIR%%/editexample6.html
%%PORTDOCS%%%%DOCSDIR%%/editexample7.html
-%%PORTDOCS%%%%DOCSDIR%%/editexample-fr.html
%%PORTDOCS%%%%DOCSDIR%%/editmenu.html
%%PORTDOCS%%%%DOCSDIR%%/edittransition-context.png
%%PORTDOCS%%%%DOCSDIR%%/edittransition-indic.png
@@ -243,8 +242,8 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/faqFS.html
%%PORTDOCS%%%%DOCSDIR%%/faqFrame.html
%%PORTDOCS%%%%DOCSDIR%%/featsetdlg.png
-%%PORTDOCS%%%%DOCSDIR%%/feature-tag-pos.png
%%PORTDOCS%%%%DOCSDIR%%/feature-tag-pair.png
+%%PORTDOCS%%%%DOCSDIR%%/feature-tag-pos.png
%%PORTDOCS%%%%DOCSDIR%%/feature-tag-sub.png
%%PORTDOCS%%%%DOCSDIR%%/ffanvil16.png
%%PORTDOCS%%%%DOCSDIR%%/ffanvil32.png
@@ -256,18 +255,17 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/fi.png
%%PORTDOCS%%%%DOCSDIR%%/filemenu.html
%%PORTDOCS%%%%DOCSDIR%%/files.html
-%%PORTDOCS%%%%DOCSDIR%%/findprobs.png
%%PORTDOCS%%%%DOCSDIR%%/findprobs-att.png
%%PORTDOCS%%%%DOCSDIR%%/findprobs-cid.png
%%PORTDOCS%%%%DOCSDIR%%/findprobs-hint.png
%%PORTDOCS%%%%DOCSDIR%%/findprobs-paths.png
%%PORTDOCS%%%%DOCSDIR%%/findprobs-random.png
%%PORTDOCS%%%%DOCSDIR%%/findprobs-refs.png
+%%PORTDOCS%%%%DOCSDIR%%/findprobs.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-anchors.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-cid.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-comment.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-context.png
-%%PORTDOCS%%%%DOCSDIR%%/fontview-grouped.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-macfeat.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-macstyle.png
%%PORTDOCS%%%%DOCSDIR%%/fontinfo-markclasses.png
@@ -286,6 +284,7 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/fontinfo.png
%%PORTDOCS%%%%DOCSDIR%%/fontutils.html
%%PORTDOCS%%%%DOCSDIR%%/fontview-cid.png
+%%PORTDOCS%%%%DOCSDIR%%/fontview-grouped.png
%%PORTDOCS%%%%DOCSDIR%%/fontview.fr.png
%%PORTDOCS%%%%DOCSDIR%%/fontview.html
%%PORTDOCS%%%%DOCSDIR%%/fontview.ru.png
@@ -327,8 +326,8 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/kern-We-12.png
%%PORTDOCS%%%%DOCSDIR%%/kern-We-150.png
%%PORTDOCS%%%%DOCSDIR%%/kernbyclasses.png
-%%PORTDOCS%%%%DOCSDIR%%/kerningclass.png
%%PORTDOCS%%%%DOCSDIR%%/kerningclass-kern.png
+%%PORTDOCS%%%%DOCSDIR%%/kerningclass.png
%%PORTDOCS%%%%DOCSDIR%%/kernpairclose.png
%%PORTDOCS%%%%DOCSDIR%%/kernpairs.html
%%PORTDOCS%%%%DOCSDIR%%/l1.png
@@ -351,13 +350,15 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/logo3.gif
%%PORTDOCS%%%%DOCSDIR%%/lparen-108.png
%%PORTDOCS%%%%DOCSDIR%%/lparen-174.png
+%%PORTDOCS%%%%DOCSDIR%%/mac-install.html
%%PORTDOCS%%%%DOCSDIR%%/macFeatureSetting.png
%%PORTDOCS%%%%DOCSDIR%%/macfeature.png
%%PORTDOCS%%%%DOCSDIR%%/macformats.html
%%PORTDOCS%%%%DOCSDIR%%/mad.html
+%%PORTDOCS%%%%DOCSDIR%%/manual-ja.png
+%%PORTDOCS%%%%DOCSDIR%%/markclass.png
%%PORTDOCS%%%%DOCSDIR%%/mergepost.png
%%PORTDOCS%%%%DOCSDIR%%/mergepre.png
-%%PORTDOCS%%%%DOCSDIR%%/markclass.png
%%PORTDOCS%%%%DOCSDIR%%/metricsmenu.html
%%PORTDOCS%%%%DOCSDIR%%/metricsview.html
%%PORTDOCS%%%%DOCSDIR%%/mmappleaxes.png
@@ -371,11 +372,13 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/mmmenu.html
%%PORTDOCS%%%%DOCSDIR%%/mmnamedstyles.png
%%PORTDOCS%%%%DOCSDIR%%/mmnamingastyle.png
+%%PORTDOCS%%%%DOCSDIR%%/ms-install.html
%%PORTDOCS%%%%DOCSDIR%%/multilayer.html
%%PORTDOCS%%%%DOCSDIR%%/multiplemaster.html
%%PORTDOCS%%%%DOCSDIR%%/newanchor.png
%%PORTDOCS%%%%DOCSDIR%%/newcountermask.png
%%PORTDOCS%%%%DOCSDIR%%/newfont.png
+%%PORTDOCS%%%%DOCSDIR%%/nix-install.html
%%PORTDOCS%%%%DOCSDIR%%/non-linear.png
%%PORTDOCS%%%%DOCSDIR%%/non-standard.html
%%PORTDOCS%%%%DOCSDIR%%/nvd.html
@@ -434,6 +437,7 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/rparen-174.png
%%PORTDOCS%%%%DOCSDIR%%/rplref.png
%%PORTDOCS%%%%DOCSDIR%%/rplserifs.png
+%%PORTDOCS%%%%DOCSDIR%%/running.html
%%PORTDOCS%%%%DOCSDIR%%/sans-serif-def.png
%%PORTDOCS%%%%DOCSDIR%%/script-A.png
%%PORTDOCS%%%%DOCSDIR%%/scripting.html
@@ -451,10 +455,11 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/sfd.html
%%PORTDOCS%%%%DOCSDIR%%/sfddiff.html
%%PORTDOCS%%%%DOCSDIR%%/sfdformat.html
-%%PORTDOCS%%%%DOCSDIR%%/sidebearings.png
%%PORTDOCS%%%%DOCSDIR%%/showatt.html
%%PORTDOCS%%%%DOCSDIR%%/showatt.png
+%%PORTDOCS%%%%DOCSDIR%%/sidebearings.png
%%PORTDOCS%%%%DOCSDIR%%/sm-picture.png
+%%PORTDOCS%%%%DOCSDIR%%/source-build.html
%%PORTDOCS%%%%DOCSDIR%%/splash.png
%%PORTDOCS%%%%DOCSDIR%%/splinefont.html
%%PORTDOCS%%%%DOCSDIR%%/splines.gif
@@ -478,17 +483,20 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/tools.png
%%PORTDOCS%%%%DOCSDIR%%/transform.html
%%PORTDOCS%%%%DOCSDIR%%/transform.png
-%%PORTDOCS%%%%DOCSDIR%%/transition-kern.png
%%PORTDOCS%%%%DOCSDIR%%/transition-context.png
%%PORTDOCS%%%%DOCSDIR%%/transition-indic.png
%%PORTDOCS%%%%DOCSDIR%%/transition-insert.png
-%%PORTDOCS%%%%DOCSDIR%%/ttfinstrs.html
+%%PORTDOCS%%%%DOCSDIR%%/transition-kern.png
%%PORTDOCS%%%%DOCSDIR%%/ttfinstrs-edit.png
%%PORTDOCS%%%%DOCSDIR%%/ttfinstrs-view.png
+%%PORTDOCS%%%%DOCSDIR%%/ttfinstrs.html
+%%PORTDOCS%%%%DOCSDIR%%/tutorial-ja.png
+%%PORTDOCS%%%%DOCSDIR%%/tutorial-zh_TW.png
%%PORTDOCS%%%%DOCSDIR%%/twolines.png
%%PORTDOCS%%%%DOCSDIR%%/typofeat.html
%%PORTDOCS%%%%DOCSDIR%%/viewmenu.html
%%PORTDOCS%%%%DOCSDIR%%/views.html
+%%PORTDOCS%%%%DOCSDIR%%/vms-install.html
%%PORTDOCS%%%%DOCSDIR%%/wacom.html
%%PORTDOCS%%%%DOCSDIR%%/windowmenu.html
%%PORTDOCS%%%%DOCSDIR%%/x-height.png