aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--astro/orsa/Makefile8
-rw-r--r--audio/smasher/Makefile8
-rw-r--r--graphics/seom/Makefile4
-rw-r--r--graphics/svgalib/Makefile4
-rw-r--r--graphics/yukon/Makefile8
-rw-r--r--irc/minbif/Makefile8
-rw-r--r--lang/gforth/Makefile6
-rw-r--r--misc/toilet/Makefile8
-rw-r--r--multimedia/openquicktime/Makefile4
-rw-r--r--net-mgmt/nocol/Makefile8
-rw-r--r--net/cphone/Makefile8
-rw-r--r--net/netembryo/Makefile10
-rw-r--r--net/ohphone/Makefile8
-rw-r--r--net/openam/Makefile8
-rw-r--r--net/vde2/Makefile4
-rw-r--r--net/xorp-devel/Makefile4
-rw-r--r--security/bsp_upektfmess/Makefile3
-rw-r--r--security/libpwstor/Makefile4
-rw-r--r--x11-toolkits/sakura/Makefile8
-rw-r--r--x11-wm/devilspie/Makefile8
20 files changed, 12 insertions, 119 deletions
diff --git a/astro/orsa/Makefile b/astro/orsa/Makefile
index e7cd60e226d2..55cfd7cc0a89 100644
--- a/astro/orsa/Makefile
+++ b/astro/orsa/Makefile
@@ -28,10 +28,4 @@ ACLOCAL_ARGS= -I macros -I ${LOCALBASE}/share/aclocal
CONFIGURE_ENV= ac_cv_c_inline=no
USE_LDCONFIG= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/smasher/Makefile b/audio/smasher/Makefile
index 1c660af5ffa4..a9702e23df2d 100644
--- a/audio/smasher/Makefile
+++ b/audio/smasher/Makefile
@@ -37,10 +37,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/share/applications|${LOCALBASE}/share/applications|g' \
${WRKSRC}/src/Makefile.am ${WRKSRC}/src/Makefile.in
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} <= 700000
-BROKEN= does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/seom/Makefile b/graphics/seom/Makefile
index 04dce909eab3..0b5676998940 100644
--- a/graphics/seom/Makefile
+++ b/graphics/seom/Makefile
@@ -59,8 +59,4 @@ do-fetch:
.endif
.endif # defined(BOOTSTRAP)
-.if ${OSVERSION} < 700000
-IGNORE= unsupported on FreeBSD versions prior to 7.0
-.endif
-
.include <bsd.port.post.mk>
diff --git a/graphics/svgalib/Makefile b/graphics/svgalib/Makefile
index e296630e48b1..fada017cd41c 100644
--- a/graphics/svgalib/Makefile
+++ b/graphics/svgalib/Makefile
@@ -35,10 +35,6 @@ MAN${i}!= ${CAT} ${FILESDIR}/man${i}
.endif
.endfor
-.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
-BROKEN= does not compile on 6.X
-.endif
-
post-patch: .SILENT
${MKDIR} ${WRKSRC}/include/linux
# Fix for GCC 4.1
diff --git a/graphics/yukon/Makefile b/graphics/yukon/Makefile
index 2e6ca26f0625..c8b4444303b5 100644
--- a/graphics/yukon/Makefile
+++ b/graphics/yukon/Makefile
@@ -71,10 +71,4 @@ do-install:
@(${INSTALL_DATA} ${WRKSRC}/tools/yukon.conf \
${PREFIX}/etc/yukon/conf.sample)
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-IGNORE= unsupported on FreeBSD versions prior to 7.0
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/minbif/Makefile b/irc/minbif/Makefile
index 652a92633184..0989f9bef80d 100644
--- a/irc/minbif/Makefile
+++ b/irc/minbif/Makefile
@@ -41,12 +41,6 @@ OPTIONS= CACA "Buddy icon display using libcaca" On \
SUB_LIST+= USERS=${USERS}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not link on 6.X
-.endif
-
.include <bsd.port.options.mk>
.if defined(WITH_CACA)
@@ -100,4 +94,4 @@ do-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index ae866be236e6..36370159ab8c 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -48,15 +48,9 @@ PORTDOCS= *
BUILD_DEPENDS= ${LOCALBASE}/include/avcall.h:${PORTSDIR}/devel/ffcall
.endif
-.if ${OSVERSION} < 700000
-BROKEN= Does not compile on ports build cluster
-.endif
-
-.if ${OSVERSION} >= 700042
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
BROKEN= Does not compile
.endif
-.endif
.if ${ARCH} == i386 || ${ARCH} == "powerpc"
WORDSIZE=32
diff --git a/misc/toilet/Makefile b/misc/toilet/Makefile
index d2407fbf414e..097b58e9c75e 100644
--- a/misc/toilet/Makefile
+++ b/misc/toilet/Makefile
@@ -23,12 +23,6 @@ CFLAGS+= -fno-strength-reduce
MAN1= ${PORTNAME}.1
PORT_VERBS= ${PORTNAME} caca2tlf share/figlet/*tlf
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not compile
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/CFLAGS=/d;/ac_build_date=/s|=.*|="$$stamp"|'\
${WRKSRC}/configure
@@ -37,4 +31,4 @@ post-patch:
post-install:
@${INSTALL_PROGRAM} ${WRKSRC}/tools/caca2tlf ${PREFIX}/bin/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/openquicktime/Makefile b/multimedia/openquicktime/Makefile
index 90e7344c2a82..8b80f2b5f801 100644
--- a/multimedia/openquicktime/Makefile
+++ b/multimedia/openquicktime/Makefile
@@ -32,10 +32,6 @@ OPTIONS= DEBUG "Turn on debugging" off
CONFIGURE_ARGS+= --enable-debug=no
.endif
-.if ${OSVERSION} < 700000
-BROKEN= Does not install
-.endif
-
.if ${ARCH} == "amd64"
CFLAGS+= -fPIC
.endif
diff --git a/net-mgmt/nocol/Makefile b/net-mgmt/nocol/Makefile
index 8b468ee80e82..97f59a618467 100644
--- a/net-mgmt/nocol/Makefile
+++ b/net-mgmt/nocol/Makefile
@@ -29,10 +29,4 @@ NO_PACKAGE= Hostname is needed.
post-install:
@cd ${WRKSRC} && make root
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 601104 && ${OSVERSION} < 602101
-BROKEN= Does not compile on some FreeBSD 6.x versions, please update to 6.2R or later
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/cphone/Makefile b/net/cphone/Makefile
index 7b1bea4d55c7..10a1ada25238 100644
--- a/net/cphone/Makefile
+++ b/net/cphone/Makefile
@@ -30,12 +30,6 @@ MAKE_ENV= QTDIR=${QT_PREFIX} \
MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${ARCH:S/i386/x86/} \
OSRELEASE=${OSVERSION} CPLUS=${CXX}
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == sparc64 && ${OSVERSION} <= 700003
-BROKEN= does not link due to missing symbol in default thread library
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/graphdisplay.h/d' -e '/videodisplay.h/d' \
-e '/labeldisplay.h/d' ${WRKSRC}/mainwindow.ui \
@@ -44,4 +38,4 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_r/cphone ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/netembryo/Makefile b/net/netembryo/Makefile
index 7a6eae118a01..50bd4b5e847c 100644
--- a/net/netembryo/Makefile
+++ b/net/netembryo/Makefile
@@ -21,12 +21,4 @@ USE_BZIP2= yes
USE_LDCONFIG= yes
USE_GNOME= pkgconfig gnomehack
-OPTIONS= SCTP "Don't check if SCTP is present" off
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700028 && ! defined(WITH_SCTP)
-IGNORE= sorry, please use FreeBSD 7.x or patch your system for SCTP (http://www.sctp.org/download.html) and use WITH_SCTP=YES
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ohphone/Makefile b/net/ohphone/Makefile
index 518ac92b7858..b9f4e940477d 100644
--- a/net/ohphone/Makefile
+++ b/net/ohphone/Makefile
@@ -31,12 +31,6 @@ PLIST_SUB= PORTNAME=${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/openh323
EXAMPLESDIR= ${PREFIX}/share/examples/openh323
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == sparc64 && ${OSVERSION} <= 700003
-BROKEN= does not link due to missing symbol in default thread library
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_r/ohphone ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ohphone.1 ${PREFIX}/man/man1
@@ -49,4 +43,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/regtest ${EXAMPLESDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/stresstest ${EXAMPLESDIR}/${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/openam/Makefile b/net/openam/Makefile
index be0237fadd47..cc585140b28b 100644
--- a/net/openam/Makefile
+++ b/net/openam/Makefile
@@ -31,12 +31,6 @@ MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${ARCH:S/i386/x86/} \
PLIST_SUB= PORTNAME=${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/openh323
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == sparc64 && ${OSVERSION} <= 700003
-BROKEN= does not link due to missing symbol in default thread library
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/obj_r/openam ${PREFIX}/bin
@${MKDIR} ${DOCSDIR}/${PORTNAME}
@@ -44,4 +38,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/sample_message.wav ${DOCSDIR}/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/sample_message_g7231.wav ${DOCSDIR}/${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/vde2/Makefile b/net/vde2/Makefile
index 6b1d8bcaf8ed..b858fec78a3b 100644
--- a/net/vde2/Makefile
+++ b/net/vde2/Makefile
@@ -32,10 +32,6 @@ MAN8= vde_tunctl.8
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-BROKEN= fails to build on 6.x
-.endif
-
.if defined(BATCH) || defined(PACKAGE_BUILDING)
MAKE_ENV+= V=1
.endif
diff --git a/net/xorp-devel/Makefile b/net/xorp-devel/Makefile
index 279da72ebeab..dee7ac62092b 100644
--- a/net/xorp-devel/Makefile
+++ b/net/xorp-devel/Makefile
@@ -59,10 +59,6 @@ do-fetch:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-IGNORE= unsupported on FreeBSD versions prior to 7.0
-.endif
-
XORP_GROUP= xorp
USE_RC_SUBR= xorp
diff --git a/security/bsp_upektfmess/Makefile b/security/bsp_upektfmess/Makefile
index 57959842d1be..ed9f504e4f11 100644
--- a/security/bsp_upektfmess/Makefile
+++ b/security/bsp_upektfmess/Makefile
@@ -38,9 +38,6 @@ ONLY_FOR_ARCHS= i386
OPTIONS= GUI "Install GUI" off
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000
-IGNORE= needs at least FreeBSD 7.0-RELEASE
-.endif
.if defined(WITH_GUI)
TFMESSPATH=${WRKDIR}/${DISTNAME}
diff --git a/security/libpwstor/Makefile b/security/libpwstor/Makefile
index bf41732d480f..f366d8cc6a7f 100644
--- a/security/libpwstor/Makefile
+++ b/security/libpwstor/Makefile
@@ -45,10 +45,6 @@ MAN3= pwstor.3 \
CFLAGS+= -fPIC -DPIC
.endif
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on FreeBSD 6.x
-.endif
-
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
diff --git a/x11-toolkits/sakura/Makefile b/x11-toolkits/sakura/Makefile
index 8c540861d223..b4e94165d2e6 100644
--- a/x11-toolkits/sakura/Makefile
+++ b/x11-toolkits/sakura/Makefile
@@ -20,12 +20,6 @@ USE_BZIP2= yes
MAN1= sakura.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not compile
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/NOT MATCHES "Debug"/d ; \
/"-O2"/d ; \
@@ -38,4 +32,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-wm/devilspie/Makefile b/x11-wm/devilspie/Makefile
index 7ae7b80a0d81..82bfe7b7b1d8 100644
--- a/x11-wm/devilspie/Makefile
+++ b/x11-wm/devilspie/Makefile
@@ -26,12 +26,6 @@ PORTDOCS= AUTHORS NEWS README TODO
PLIST_FILES= bin/devilspie \
share/locale/de/LC_MESSAGES/devilspie.mo
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||' \
${WRKSRC}/src/Makefile.in
@@ -42,4 +36,4 @@ post-install:
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>