aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--french/MT/Makefile5
-rw-r--r--german/MT/Makefile5
-rw-r--r--japanese/MT/Makefile6
-rw-r--r--russian/MT/Makefile5
-rw-r--r--www/MT/Makefile34
-rw-r--r--www/MT/distinfo31
6 files changed, 35 insertions, 51 deletions
diff --git a/french/MT/Makefile b/french/MT/Makefile
index df9715c6abf8..eef411448c36 100644
--- a/french/MT/Makefile
+++ b/french/MT/Makefile
@@ -7,13 +7,12 @@
PORTNAME= MT
CATEGORIES= french www
-DISTNAME= MTOS-${PORTVERSION}${PORTREVISION}-fr
+DISTNAME= MTOS-${PORTVERSION}-fr
COMMENT= french localization of the MovableType publishing system
MASTERDIR= ${.CURDIR}/../../www/${PORTNAME}
-CONFLICTS= MT-[2-5].* ja-MT-[2-5].* de-MT-[2-5].* es-MT-[2-5].* \
- nl-MT-[2-5].* ru-MT-[2-5].*
+CONFLICTS= MT-[2-5].* de-MT-[2-5].* ja-MT-[2-5].* ru-MT-[2-5].*
.include "${MASTERDIR}/Makefile"
diff --git a/german/MT/Makefile b/german/MT/Makefile
index add0db9e9999..52dbb846fe7d 100644
--- a/german/MT/Makefile
+++ b/german/MT/Makefile
@@ -7,13 +7,12 @@
PORTNAME= MT
CATEGORIES= german www
-DISTNAME= MTOS-${PORTVERSION}${PORTREVISION}-de
+DISTNAME= MTOS-${PORTVERSION}-de
COMMENT= german localization of the MovableType publishing system
MASTERDIR= ${.CURDIR}/../../www/${PORTNAME}
-CONFLICTS= MT-[2-5].* ja-MT-[2-5].* fr-MT-[2-5].* es-MT-[2-5].* \
- nl-MT-[2-5].* ru-MT-[2-5].*
+CONFLICTS= MT-[2-5].* fr-MT-[2-5].* ja-MT-[2-5].* ru-MT-[2-5].*
.include "${MASTERDIR}/Makefile"
diff --git a/japanese/MT/Makefile b/japanese/MT/Makefile
index 7951a189d1be..3d414859f80f 100644
--- a/japanese/MT/Makefile
+++ b/japanese/MT/Makefile
@@ -3,18 +3,18 @@
# Whom: Takefu Kenji <takefu@airport.fm>
#
# $FreeBSD$
+#
PORTNAME= MT
CATEGORIES= japanese www
-DISTNAME= MTOS-${PORTVERSION}${PORTREVISION}-ja
+DISTNAME= MTOS-${PORTVERSION}-ja
COMMENT= Japanese localization of the MovableType publishing system
MASTERDIR= ${.CURDIR}/../../www/${PORTNAME}
MT_LANG= ja
-CONFLICTS= MT-[2-5].* fr-MT-[2-5].* de-MT-[2-5].* es-MT-[2-5].* \
- nl-MT-[2-5].* ru-MT-[2-5].*
+CONFLICTS= MT-[2-5].* de-MT-[2-5].* fr-MT-[2-5].* ru-MT-[2-5].*
MT_DOCS_URL= http://movabletype.jp/documentation/
MT_UPGRADE_URL= http://movabletype.jp/documentation/upgrade/
diff --git a/russian/MT/Makefile b/russian/MT/Makefile
index db61dd56ff7e..091404fbb3f3 100644
--- a/russian/MT/Makefile
+++ b/russian/MT/Makefile
@@ -8,7 +8,7 @@
PORTNAME= MT
CATEGORIES= russian www
MASTER_SITES= GOOGLE_CODE
-DISTNAME= MTOS-${PORTVERSION}${PORTREVISION}-ru
+DISTNAME= MTOS-${PORTVERSION}-ru
COMMENT= Russian localization of the MovableType publishing system
@@ -16,8 +16,7 @@ PROJECTHOST= movabletype
MASTERDIR= ${.CURDIR}/../../www/${PORTNAME}
MT_LANG= ru
-CONFLICTS= MT-[2-5].* ja-MT-[2-5].* fr-MT-[2-5].* de-MT-[2-5].* \
- es-MT-[2-5].* nl-MT-[2-5].*
+CONFLICTS= MT-[2-5].* de-MT-[2-5].* fr-MT-[2-5].* ja-MT-[2-5].*
MT_DOCS_URL= http://movable-type.ru/wiki/
MT_UPGRADE_URL= http://movable-type.ru/wiki/%D0%9E%D0%B1%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5_Movable_Type
diff --git a/www/MT/Makefile b/www/MT/Makefile
index 235cbbe9772c..1440bb9f650c 100644
--- a/www/MT/Makefile
+++ b/www/MT/Makefile
@@ -6,49 +6,47 @@
#
PORTNAME= MT
-PORTVERSION?= 5.03
-PORTREVISION= 1
+PORTVERSION?= 5.04
+PORTREVISION?= 0
CATEGORIES?= www
MASTER_SITES?= http://movabletype.org/downloads/stable/
-DISTNAME?= MTOS-${PORTVERSION}${PORTREVISION}-en
+DISTNAME?= MTOS-${PORTVERSION}-en
MAINTAINER?= takefu@airport.fm
COMMENT?= A web-based personal publishing system for weblogs
-CONFLICTS?= ja-MT-[2-5].* fr-MT-[2-5].* de-MT-[2-5].* es-MT-[2-5].* \
- nl-MT-[2-5].* ru-MT-[2-5].*
+CONFLICTS?= de-MT-[2-5].* fr-MT-[2-5].* ja-MT-[2-5].* ru-MT-[2-5].*
RUN_DEPENDS= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
-OPTIONS= APACHE "USE_APACHE" off\
- MYSQL "USE_MYSQL" off\
+OPTIONS= APACHE "USE_APACHE" off \
+ MYSQL "USE_MYSQL" off \
OPTIONAL_MODULES "OPTIONAL_MODULES" on
.include <bsd.port.options.mk>
.if !defined(WITHOUT_OPTIONAL_MODULES)
RUN_DEPENDS+= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite \
- ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
- ${SITE_PERL}/Crypt/DSA.pm:${PORTSDIR}/security/p5-Crypt-DSA \
- ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
- ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
- ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
- ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+ ${SITE_PERL}/SOAP/Lite.pm:${PORTSDIR}/net/p5-SOAP-Lite \
+ ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
+ ${SITE_PERL}/Crypt/DSA.pm:${PORTSDIR}/security/p5-Crypt-DSA \
+ ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
+ ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
+ ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
.endif
DATADIR= www/data
CGIDIR= www/cgi-bin/mt
.if defined(WITH_MYSQL)
-DB_DIR?= /var/db/mysql/blog
-USE_MYSQL= yes
+DB_DIR?= /var/db/mysql/blog
+USE_MYSQL= yes
.else
DB_DIR?= ${PREFIX}/${CGIDIR}/db
-RUN_DEPENDS+=\
- ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite
WITH_DEFAULTDB= yes
.endif
diff --git a/www/MT/distinfo b/www/MT/distinfo
index 0e6cf34d0621..eae877eee177 100644
--- a/www/MT/distinfo
+++ b/www/MT/distinfo
@@ -1,21 +1,10 @@
-MD5 (MTOS-5.031-de.tar.gz) = 3c9d5b7e372938e7d1662f51ef83b46a
-SHA256 (MTOS-5.031-de.tar.gz) = bc24927b98fe5a6d9aac855e571015d382193a9a9d6c16581e1ed113c4de5e92
-SIZE (MTOS-5.031-de.tar.gz) = 5877094
-MD5 (MTOS-5.031-en.tar.gz) = a461d1473ac60e8074555da8c10a8ff5
-SHA256 (MTOS-5.031-en.tar.gz) = 83706210d0ebb976ce6b64e0ea4a5b0cc5bc665a8274d5554b0205c6f6c5d007
-SIZE (MTOS-5.031-en.tar.gz) = 5877220
-MD5 (MTOS-5.031-es.tar.gz) = 1f62d86790760037e4d65cdcf22477e8
-SHA256 (MTOS-5.031-es.tar.gz) = 591ec5b329f2a471ec336a207f0637aacd81213f3ae15a4867536819143bae9c
-SIZE (MTOS-5.031-es.tar.gz) = 5877682
-MD5 (MTOS-5.031-fr.tar.gz) = b07a5ab4ca0173c369b1d489cb073d4c
-SHA256 (MTOS-5.031-fr.tar.gz) = c4ba5b01c4874fedf3dbbe00c1b8a9e85886921e3810776f4a40cf9db529ca1a
-SIZE (MTOS-5.031-fr.tar.gz) = 5877679
-MD5 (MTOS-5.031-ja.tar.gz) = 9caddf6b0645973eaddeadb855d099ee
-SHA256 (MTOS-5.031-ja.tar.gz) = 4ccccf309e73736323ba9f6a83526611a9bc84eceda8dab530c344121c779f08
-SIZE (MTOS-5.031-ja.tar.gz) = 5869929
-MD5 (MTOS-5.031-nl.tar.gz) = e70aac133ce22c1c68536798fa4808f8
-SHA256 (MTOS-5.031-nl.tar.gz) = a0ef8c96f96b1be8df3813070b102dd71bc5bb498844ba25cd0227a480831f90
-SIZE (MTOS-5.031-nl.tar.gz) = 5877618
-MD5 (MTOS-5.031-ru.tar.gz) = 78da9ba049dc21da7ef4f7a6311a437a
-SHA256 (MTOS-5.031-ru.tar.gz) = ff26331b64ccc80c2459b560b6dc901a7a52aed82e55a328b499d5dba44cfc2f
-SIZE (MTOS-5.031-ru.tar.gz) = 5994342
+SHA256 (MTOS-5.04-de.tar.gz) = 5e981e25bee62f157464a2ef841cdb16c90098a75e46862931340786bff198d1
+SIZE (MTOS-5.04-de.tar.gz) = 5873151
+SHA256 (MTOS-5.04-en.tar.gz) = 1460dfe9083fde713fd2053403d6e8aa44e8ed21fc17da3e795d26733141ebc1
+SIZE (MTOS-5.04-en.tar.gz) = 5873433
+SHA256 (MTOS-5.04-fr.tar.gz) = 4d170e62a9b619af88bf8d44c40df9090af346ebc3a64c9d61ccb86cea8f1437
+SIZE (MTOS-5.04-fr.tar.gz) = 5873115
+SHA256 (MTOS-5.04-ja.tar.gz) = f89a92ec79ed0ad74fe870b514105362eb1e5a9c96e94a66a4b64f237f08d939
+SIZE (MTOS-5.04-ja.tar.gz) = 5865587
+SHA256 (MTOS-5.04-ru.tar.gz) = 2ff4b3a47ff1acf0f9ecb158106a1fe0a56cb5af9f000f8f38ff1ef1405e0ae3
+SIZE (MTOS-5.04-ru.tar.gz) = 6039995