aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/mutt-devel/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 9891fd9e64ba..0246a582695c 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -8,6 +8,7 @@
PORTNAME= mutt-devel
PORTVERSION= 1.3.20
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.demon.co.uk/pub/mirrors/mutt/devel/ \
ftp://ftp.parodius.com/pub/mutt/devel/
@@ -19,7 +20,7 @@ MAINTAINER= ust@cert.siemens.de
DIST_SUBDIR= mutt
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-pop --enable-imap --enable-flock --disable-fcntl \
+CONFIGURE_ARGS= --enable-flock --disable-fcntl \
--with-sharedir=${PREFIX}/share/mutt \
--with-docdir=${PREFIX}/share/doc/mutt \
--sysconfdir=${PREFIX}/etc \
@@ -78,6 +79,15 @@ CONFIGURE_ARGS+= --with-curses=${PREFIX}
.if defined(WITH_MUTT_SSL)
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
.endif
+.if defined(WITH_MUTT_POP)
+CONFIGURE_ARGS+= --enable-pop
+.endif
+.if defined(WITH_MUTT_IMAP)
+CONFIGURE_ARGS+= --enable-imap
+.endif
+.if defined(WITH_MUTT_POP_IMAP)
+CONFIGURE_ARGS+= --enable-pop --enable-imap
+.endif
PATCH_DIST_STRIP= -p1