aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/calibre/Makefile10
-rw-r--r--deskutils/calibre/distinfo6
-rw-r--r--deskutils/calibre/files/patch-setup_build__environment.py11
-rw-r--r--deskutils/calibre/files/patch-src_calibre_linux.py8
-rw-r--r--deskutils/calibre/pkg-message24
-rw-r--r--deskutils/calibre/pkg-plist10
6 files changed, 40 insertions, 29 deletions
diff --git a/deskutils/calibre/Makefile b/deskutils/calibre/Makefile
index df195c3cd300..382f39bd7124 100644
--- a/deskutils/calibre/Makefile
+++ b/deskutils/calibre/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= calibre
-PORTVERSION= 3.14.0
+PORTVERSION= 3.15.0
CATEGORIES= deskutils python
MASTER_SITES= http://download.calibre-ebook.com/${PORTVERSION}/
@@ -93,8 +93,12 @@ do-install:
${PYSETUP} install --prefix ${PREFIX} \
--staging-root ${STAGEDIR}${PREFIX})
@${RM} ${STAGEDIR}${PREFIX}/bin/calibre-uninstall \
- ${STAGEDIR}${PREFIX}/share/applications/defaults.list
- @${RMDIR} ${STAGEDIR}${PREFIX}/share/desktop-directories
+ ${STAGEDIR}${PREFIX}/share/applications/defaults.list \
+ ${STAGEDIR}${PREFIX}/share/mime/application/* \
+ ${STAGEDIR}${PREFIX}/share/mime/text/*
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/desktop-directories \
+ ${STAGEDIR}${PREFIX}/share/mime/application \
+ ${STAGEDIR}${PREFIX}/share/mime/text
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/calibre/calibre/plugins/*
.include <bsd.port.mk>
diff --git a/deskutils/calibre/distinfo b/deskutils/calibre/distinfo
index 81020d8ee8e8..3c69406720a3 100644
--- a/deskutils/calibre/distinfo
+++ b/deskutils/calibre/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1513325134
-SHA256 (calibre-3.14.0.tar.xz) = a14c37514850e5b9eedf53d5f80005e631cdf1f8ae82d1fca652c22a1094c78c
-SIZE (calibre-3.14.0.tar.xz) = 38059200
+TIMESTAMP = 1515144901
+SHA256 (calibre-3.15.0.tar.xz) = 8746f52315561d606fd7120fec8284c2e4433f6ead14639c40b4b5f1522273ff
+SIZE (calibre-3.15.0.tar.xz) = 38177684
diff --git a/deskutils/calibre/files/patch-setup_build__environment.py b/deskutils/calibre/files/patch-setup_build__environment.py
deleted file mode 100644
index 801d79741bae..000000000000
--- a/deskutils/calibre/files/patch-setup_build__environment.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup/build_environment.py.orig 2017-06-16 04:00:12 UTC
-+++ setup/build_environment.py
-@@ -84,7 +84,7 @@ pyqt['sip_bin'] = os.environ.get('SIP_BIN', 'sip')
- from PyQt5.QtCore import PYQT_CONFIGURATION
- pyqt['sip_flags'] = PYQT_CONFIGURATION['sip_flags']
- def get_sip_dir():
-- q = os.environ.get('SIP_DIR', os.path.join(sys.prefix, 'share', 'sip') if iswindows else os.path.join(sys.prefix, 'share', 'sip'))
-+ q = os.environ.get('SIP_DIR', os.path.join(sys.prefix, 'share', 'sip') if iswindows else os.path.join(sys.prefix, 'share', 'py-sip'))
- for x in ('', 'Py2-PyQt5', 'PyQt5', 'sip/PyQt5'):
- base = os.path.join(q, x)
- if os.path.exists(os.path.join(base, 'QtWidgets')):
diff --git a/deskutils/calibre/files/patch-src_calibre_linux.py b/deskutils/calibre/files/patch-src_calibre_linux.py
index 5b10c7bdfd48..cf1abfb2ecf6 100644
--- a/deskutils/calibre/files/patch-src_calibre_linux.py
+++ b/deskutils/calibre/files/patch-src_calibre_linux.py
@@ -1,4 +1,4 @@
---- src/calibre/linux.py.orig 2017-07-28 04:07:52 UTC
+--- src/calibre/linux.py.orig 2018-01-05 05:41:54 UTC
+++ src/calibre/linux.py
@@ -841,7 +841,7 @@ class PostInstall:
f.close()
@@ -18,9 +18,9 @@
Icon=calibre-viewer
Categories=Graphics;Viewer;
'''
-@@ -1021,7 +1021,7 @@ Name=Edit E-book
- GenericName=Edit E-books
- Comment=Edit e-books in various formats
+@@ -1021,7 +1021,7 @@ Name=E-book Editor
+ GenericName=Editor for E-books
+ Comment=Edit E-books in various formats
TryExec=ebook-edit
-Exec=ebook-edit --detach %f
+Exec=ebook-edit %f
diff --git a/deskutils/calibre/pkg-message b/deskutils/calibre/pkg-message
index c4c9b5227e37..a64913ec3d90 100644
--- a/deskutils/calibre/pkg-message
+++ b/deskutils/calibre/pkg-message
@@ -26,6 +26,30 @@ attack) add the following:
---
+In addition to the above, for USB and MTP devices the user needs
+to be able to access the device node in /dev.
+
+to be aware of USB devices attached to the machine, the user needs
+to be a member of the operator group:
+
+# pw groupmod operator -m yourusername
+
+Then, add the following to /etc/devfs.rules, or create this file
+if it does not exist yet:
+
+[system=10]
+add path 'usb/*' mode 0660 group operator
+
+To load these new rules, add the following to /etc/rc.conf:
+
+devfs_system_ruleset="system"
+
+Then, restart devfs
+
+# service devfs restart
+
+---
+
If you are using an Android device as your e-book reader, please note
that the stock Google Books app uses a storage format that is not
supported by calibre. The calibre FAQ recommends that either of the
diff --git a/deskutils/calibre/pkg-plist b/deskutils/calibre/pkg-plist
index 86f1fc994f42..d52ddcfbda1d 100644
--- a/deskutils/calibre/pkg-plist
+++ b/deskutils/calibre/pkg-plist
@@ -1181,6 +1181,8 @@ lib/calibre/calibre/plugins/hunspell.so
lib/calibre/calibre/plugins/icu.so
lib/calibre/calibre/plugins/imageops.so
lib/calibre/calibre/plugins/libheadless.so
+lib/calibre/calibre/plugins/libmtp.so
+lib/calibre/calibre/plugins/libusb.so
lib/calibre/calibre/plugins/lzma_binding.so
lib/calibre/calibre/plugins/lzx.so
lib/calibre/calibre/plugins/matcher.so
@@ -2087,12 +2089,4 @@ share/icons/hicolor/64x64/mimetypes/gnome-mime-application-x-mobipocket-ebook.pn
share/icons/hicolor/64x64/mimetypes/gnome-mime-application-x-topaz-ebook.png
share/icons/hicolor/64x64/mimetypes/gnome-mime-text-lrs.png
share/icons/hicolor/64x64/mimetypes/text-lrs.png
-share/mime/application/epub+zip.xml
-share/mime/application/x-kindle-application.xml
-share/mime/application/x-mobi8-ebook.xml
-share/mime/application/x-mobipocket-ebook.xml
-share/mime/application/x-mobipocket-subscription.xml
-share/mime/application/x-sony-bbeb.xml
-share/mime/application/x-topaz-ebook.xml
share/mime/packages/calibre-mimetypes.xml
-share/mime/text/lrs.xml